LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-21-2010, 11:19 AM   #1
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Rep: Reputation: 15
broadom 4311 and broadom sta driver not working


so I was originally trying to set up my wireless using b43-fwcutter and the b43 driver from linuxwireless.org. I was not having much luck getting that to work however with my broadcom 4311 chip so I switched to using broadcom's driver which I found here.

http://www.broadcom.com/support/802.11/linux_sta.php

I removed b43 modules and added modules for this driver and installed it but I still can't figure out why I can't get a connection. Below I've included relevant console outputs that I think should be able to help some of you braniacs help me figure this out.

Code:
root@darkstar:/etc/rc.d# ifconfig            
eth0      Link encap:Ethernet  HWaddr 00:1b:24:4e:5c:11  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Base address:0x6000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1240 (1.2 KiB)  TX bytes:1240 (1.2 KiB)

root@darkstar:/etc/rc.d# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

root@darkstar:/etc/rc.d# iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

root@darkstar:/etc/rc.d# lsmod | grep "b43\|ssb\|wl"
wl                   1962468  0
lib80211                5216  1 wl
root@darkstar:/etc/rc.d# dmesg | tail
b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the latest firmware (version 4).
input: b43-phy0 as /devices/virtual/input/input17
b43 ssb0:0: firmware: requesting b43/ucode13.fw
b43-phy0 ERROR: Firmware file "b43/ucode13.fw" not found
b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the latest firmware (version 4).
lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
wl: module license 'unspecified' taints kernel.
b43-pci-bridge 0000:03:00.0: PCI INT A disabled
usb 1-6: USB disconnect, address 3
root@darkstar:/etc/rc.d# uname -r
2.6.29.6-smp
root@darkstar:/etc/rc.d#
------EDIT 9:55 AM MST------

Below are some additional details I found. the first portion is relevant to my broadcom chip when running lspci -vn and the second part is just showing that I don't have any modules for ssb, even though my broadcom chip seems to be expecting one. I would say that is obviously a problem although I don't know how to change it..

Code:
03:00.0 0280: 14e4:4311 (rev 02)
        Subsystem: 103c:1374    
        Flags: fast devsel, IRQ 19
        Memory at b6000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3           
        Capabilities: [58] Vendor Specific Information <?>      
        Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel <?>
        Capabilities: [160] Device Serial Number 14-37-73-ff-ff-bc-00-1a
        Capabilities: [16c] Power Budgeting <?>
        Kernel modules: ssb
root@darkstar:~# lsusb
Bus 001 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@darkstar:~# lsmod | grep "ssb"
root@darkstar:~# lsmod | grep "wl"
wl                   1962468  0
lib80211                5216  1 wl
root@darkstar:~#

Last edited by R Tanner; 02-21-2010 at 11:59 AM. Reason: adding additional code details i forgot
 
Old 02-21-2010, 12:53 PM   #2
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
try
Code:
modprobe ssb
you might need to
Code:
modprobe b44
too

Code:
depmod -a
 
Old 02-21-2010, 01:06 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by R Tanner View Post
...
I removed b43 modules and added modules for this driver and installed it but I still can't figure out why I can't get a connection. Below I've included relevant console outputs that I think should be able to help some of you braniacs help me figure this out.

Code:
...
root@darkstar:/etc/rc.d# lsmod | grep "b43\|ssb\|wl"
wl                   1962468  0
lib80211                5216  1 wl
root@darkstar:/etc/rc.d# dmesg | tail
b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the latest firmware (version 4).
input: b43-phy0 as /devices/virtual/input/input17
b43 ssb0:0: firmware: requesting b43/ucode13.fw
b43-phy0 ERROR: Firmware file "b43/ucode13.fw" not found
b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the latest firmware (version 4).
...
That snippet of what you posted strongly suggests (to me) that, despite your comment about removing the b43 modules, you have failed to do so. I'd suggest that you consider adding b43 and b43_phy to /etc/modules.d/blacklist-b43.conf or (since I don't use Slackware) wherever your system keeps it's module blacklists.

<edit>
It is, of course, possible that the driver you're trying to use is, in fact, a version of the b43
driver, and you just need to install the firmware specified in the message I quoted from your post.
</edit>

Looking at your prior thread, did you consider checking that the power to your wireless device was turned on? (On my laptop the wireless power switch is on the front of the case, and easily "tripped" by sliding the unit on my lap. I spent a couple of hours once trying to figure out what had gone wrong before I thought to check the switch position. In fact, , I booted Vista which popped a message that the power to the device was "off" before I thought to check.)

Last edited by PTrenholme; 02-21-2010 at 01:12 PM.
 
Old 02-21-2010, 01:11 PM   #4
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
this is what i get when i type those commands

Code:
root@darkstar:~# depmod -a
root@darkstar:~# modprobe b44
root@darkstar:~# modprobe ssb
root@darkstar:~# modprobe -l ssb
kernel/drivers/ssb/ssb.ko
root@darkstar:~# modprobe -l b44
kernel/drivers/net/b44.ko
 
Old 02-21-2010, 01:21 PM   #5
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
I wish that the only problem was that i need to hit the switch. that would be pretty nice.

in slackware it is /etc/modprobe.d/blacklist.conf and i've done the following (even though it doesn't seem to be working since these modules seem to be loaded into the kernel anyways - or so thats what modprobe is telling me, right? )

Code:
echo "blacklist 43" >> /etc/modprobe.d/blacklist.conf
echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
 
Old 02-21-2010, 01:22 PM   #6
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
You`ve been battling this for a while. If all else fails the ndiswrapper module and windows drivers will work. However, Im surprised the b43 didn`t work. You should really check the drivers at slackbuilds.org. Search for broadcom. I`m not sure but the drivers there could have modified install paths or something. The stuff there almost always works on slackware systems.
 
Old 02-21-2010, 01:42 PM   #7
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
The slackbuilds site doesn`t list any dependencies for the broadcom-sta driver. Not even the firmware. So I doubt the ssb and b44 modules were needed. Are you using the huge kernel or generic?
 
Old 02-21-2010, 01:58 PM   #8
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
lol not sure...i'm pretty sure the huge one..how can i tell?

in the readme for the broadcom sta driver it says i need to remove ssb, b43, all that cause it causes conflicts...thats why i added it to the blacklist and did rmmod on them
 
Old 02-21-2010, 02:24 PM   #9
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
go to /boot directory
Code:
ls -l
check to see what the vmlinuz symbolic link is to.
Chances are your using the huge kernel with just about everything compiled into it. You will not be able to remove or blacklist anything.
The b43 drivers will be in the kernel. You need to switch to the generic kernel
make an initrd
then use broadcom-sta driver

Last edited by mryuck; 02-21-2010 at 03:54 PM. Reason: Pretty sure this is the problem
 
Old 02-21-2010, 02:38 PM   #10
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
I just saw your old thread. The wpa supplicant is on the slackware disk in N so you may have it already.If you can you should disable security until you get connectivity. Then work on security. It makes troubleshooting easier. You might have already had the b43 driver working but the wpa issue didn`t allow connectivity.
 
Old 02-21-2010, 05:32 PM   #11
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
this is what i get. why on earth can i not unload specific modules or blacklist anything? thats pretty annoying. lol

Code:
ls -l

vmlinuz -> vk=nkubyz-huge-smp-2.6.29.6-smp
 
Old 02-21-2010, 05:51 PM   #12
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,450
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Look at 'Slackware 13.0 RC2 X86_64 Broadcom bcm4312 problems' to possibly get some insight to help solve your 'STA' problems.

BTW, what's the output for 'ifconfig -a'? 'SSB' is necessary for the b44 driver if you plan to use the Ethernet.

 
Old 02-21-2010, 05:57 PM   #13
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mryuck View Post
I just saw your old thread. The wpa supplicant is on the slackware disk in N so you may have it already.If you can you should disable security until you get connectivity. Then work on security. It makes troubleshooting easier. You might have already had the b43 driver working but the wpa issue didn`t allow connectivity.

...how do i disable security, what is the wpa issue, and how would it keep me from connecting? are you referring to the fact I couldn't set the key on the wlan0? somehow i managed to completely remove wlan0 as it doesn't come up at all when i enter
Code:
iwconfig

I was trying to work with the ndiswrapper but its saying I need to download the windows driver for my wireless card and extract it but its an exe file which is unextractable. lol
 
Old 02-21-2010, 06:13 PM   #14
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
below is the output...and i don't really care about ethernet..i never hook up to ethernet..i'm always using wireless..

Code:
root@darkstar:/media/disk/ndiswrapper-1.56# ifconfig -a                                                                                                                             
eth0      Link encap:Ethernet  HWaddr 00:1b:24:4e:5c:11                                                                                                                             
          UP BROADCAST MULTICAST  MTU:1500  Metric:1                                                                                                                                
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                                                                                                                        
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                      
          collisions:0 txqueuelen:1000                                                                                                                                              
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                                                                                                                                    
          Interrupt:20 Base address:0xc000                                                                                                                                          

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1240 (1.2 KiB)  TX bytes:1240 (1.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1a:73:bc:14:37
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-1A-73-BC-14-37-6C-6F-00-00-00-00-00-00-00-00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
Old 02-21-2010, 06:15 PM   #15
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
You should use a generic kernel if you have one in /boot.
You need to change your symbolic links for vmlinuz, syatem.map, and config to point to their generic files in /boot if they exist.
Then make an initrd. The /boot directory has an easy readme for this.
Don`t forget to do
Code:
lilo
after making the initrd.
It is easy to do.
When you use the huge kernels everything is in kernel. Generic kernel uses mostly loadable modules.
The huge kernel is a PITA when conflicts arise.
If you do want to stay with the huge kernel you probably only needed firmware for b43. The drivers were already in the kernel.

Last edited by mryuck; 02-21-2010 at 06:19 PM.
 
  


Reply

Tags
broadcom, slackware, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help configuring rodneybeighle Linux - Networking 1 09-08-2005 04:42 PM
configuring Keeble Linux - Newbie 3 02-08-2004 05:17 PM
Configuring X egh128 Slackware 5 08-31-2003 07:54 AM
Not configuring Culbert Linux - Software 3 08-24-2003 11:37 AM
Configuring X Solidus Slackware 8 05-03-2002 07:08 PM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration