LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2010, 02:23 PM   #46
Hangaber
Member
 
Registered: Sep 2004
Location: USA
Distribution: Slackware, Debian
Posts: 93

Rep: Reputation: 25

Quote:
Originally Posted by R Tanner View Post
[...] I haven't been able to figure out how to connect to even an open network through a command prompt though. I mean I can always set the essid for the wlan0 but that doesn't connect me.
Assuming you're using wlan0... (I think this is taken from the appropriate IFNAME[x] in rc.inet1.conf)

/etc/rc.d/rc.inet1 wlan0_stop
/etc/rc.d/rc.inet1 wlan0_start
 
Old 03-01-2010, 11:34 PM   #47
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
working with WPA, wext, and wpa_supplicant

So I'm trying to figure out what I've configured wrong with my wireless...I need to set up a WPA but it won't connect...below is the output of my rc.inet1.conf and wpa_supplicant.conf and the output of /etc/rc.d/rc.inet1.conf wlan0_restart...

First the stuff pertaining to wlan0 in rc.inet1.conf...

Code:
########
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="darkstar"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="bd9552595fdcb903cb84436c566c05ec821c68803f355bd4bdb7b5d4729d4c46"
WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
WLAN_WPAWAIT[4]=30
This is everything in wpa_supplicant.conf

Code:
network={
        ssid="Katies Corner"
        #psk="mypassphrase"
        psk="bd9552595fdcb903cb84436c566c05ec821c68803f355bd4bdb7b5d4729d4c46"
        priority=5
}
when i run /etc/rc.d/rc.inet1.conf wlan0_[restart, stop, start] I get absolutely nothing...any help is greatly appreciated...

---------------------------EDIT---------------------------------------

I forgot to say I can connect fine to networks that don't require a password...but i can't connect to networks that do

---------------------------EDIT---------------------------------------

Last edited by R Tanner; 03-01-2010 at 11:45 PM. Reason: forgot to say something
 
Old 03-02-2010, 07:49 AM   #48
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 164

Rep: Reputation: 20
Quote:
Originally Posted by R Tanner View Post
So I'm trying to figure out what I've configured wrong with my wireless...I need to set up a WPA but it won't connect...below is the output of my rc.inet1.conf and wpa_supplicant.conf and the output of /etc/rc.d/rc.inet1.conf wlan0_restart...

First the stuff pertaining to wlan0 in rc.inet1.conf...

Code:
########
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="darkstar"
WLAN_WPA[4]="wpa_supplicant"  
WLAN_WPADRIVER[4]="wext"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="bd9552595fdcb903cb84436c566c05ec821c68803f355bd4bdb7b5d4729d4c46"
WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
WLAN_WPAWAIT[4]=30
This is everything in wpa_supplicant.conf

Code:
network={
        ssid="Katies Corner"
        #psk="mypassphrase"
        psk="bd9552595fdcb903cb84436c566c05ec821c68803f355bd4bdb7b5d4729d4c46"
        priority=5
}
when i run /etc/rc.d/rc.inet1.conf wlan0_[restart, stop, start] I get absolutely nothing...any help is greatly appreciated...

---------------------------EDIT---------------------------------------

I forgot to say I can connect fine to networks that don't require a password...but i can't connect to networks that do

---------------------------EDIT---------------------------------------
looks like you're making lots of progress

1. you have uncommented lines you don't need to use in /etc/rc.d/rc.inet1.conf
comment these lines back again
WLAN_MODE[4]=Managed
WLAN_KEY[4]="bd9...
WLAN_IWPRIV[4]="set...
WPAPSK=96...
WLAN_WPAWAIT[4]=30....

2. did you name your machine "darkstar" when you installed Slack? If not, comment this out in inet1.conf
DHCP_HOSTNAME[4]="darkstar"

3. ssid="Katies Corner"

Linux/Unix doesn't like white spaces...it reads a white space as an end of a line...I would type the essid as Katies_Corner, and you would need to make that change in the configuration of your router as well.

4. psk="bd9...c46" from wpa_supplicant.conf

no quote signs required, just the number from wpa_passphrase

5. when done do
/etc/rc.d/rc.inet1 wlan0 restart NOT /etc/rc.d/rc.inet1.conf restart
 
1 members found this post helpful.
Old 03-02-2010, 01:05 PM   #49
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
okay sweet thank you I will see if it works tonight. What if I have multiple networks I might be connecting to that have different essid's and different pass phrases? Do I just have a separate network code block in wpa_supplicant.conf? I'm guessing I would then just need to restart the interface if I change networks...
 
Old 03-02-2010, 10:00 PM   #50
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 164

Rep: Reputation: 20
Quote:
Originally Posted by R Tanner View Post
okay sweet thank you I will see if it works tonight. What if I have multiple networks I might be connecting to that have different essid's and different pass phrases? Do I just have a separate network code block in wpa_supplicant.conf? I'm guessing I would then just need to restart the interface if I change networks...
I don't think so. Since you seem to want to work manually, you're going to have to learn to use the iwconfig command to connect to different networks. And if you change the settings for your card to connect another place, you'll need to do it again manually when you get home. I saw a script called rc.inet1.smart a while back that looked like interesting but never putzed with it.

wicd is really the tool for connecting to different networks if you do that frequently. I use it. easy-peasy
 
Old 03-03-2010, 09:12 PM   #51
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
woohooo!!!!!!

I'm connected to a network with a WPA key and am posting this from that connection I'm not sure how I did it, but that's beside the point. That was quite a challenge, but well worth it. Thank you everyone for your help. I'm marking this as solved. Everyone was very helpful and it was very much appreciated. Hopefully, as I learn more about wireless and how it works with Linux, I will be able to contribute on here and help others.

Thanks again everyone
 
  


Reply

Tags
broadcom, slackware, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help configuring rodneybeighle Linux - Networking 1 09-08-2005 04:42 PM
configuring Keeble Linux - Newbie 3 02-08-2004 05:17 PM
Configuring X egh128 Slackware 5 08-31-2003 07:54 AM
Not configuring Culbert Linux - Software 3 08-24-2003 11:37 AM
Configuring X Solidus Slackware 8 05-03-2002 07:08 PM


All times are GMT -5. The time now is 10:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration