LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 03-11-2005, 06:16 AM   #61
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55

As far as the font-spacing issue is concerned it may be your choice of fonts. I always get that result to a greater or lesser degree when I choose a true type font for a terminal rather than a monospace font (console, courier new, courier 10 pitch etc.) My personal pref is for console, which is missing from the misc font folder in slack (and others as well, Debian for example) but can be copied from the /opt/kde/share/fonts folder (that may be off a bit - working from memory here ). Check an earlier post of mine in this thread regarding that issue.

Ya, they do look antialiased, but I can't tell you why for sure. I had an issue in SuSE earlier where Konqueror refused to render non-antialiased for web browsing when everything else was working properly. I finally tried shutting down aa completely everywhere (no point ranges, no hinting) and restarting X and that seemed to help. I was then able to edit my preferences again to include hinting and point ranges without konqueror misbehaving.

HTH
 
Old 03-12-2005, 11:14 AM   #62
tazdevil77
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware 10.1 with 2.6.11
Posts: 9

Rep: Reputation: 0
hi

i've made screenshots after setting "DisplaySize"(now 120dpi) in xorg.conf and removed "-dpi 96" in startx.
look here:
screenshot1
screenshot2
screenshot3
screenshot4
screenshot5

slackware 10.1
kde 3.3.92(beta2)
1280x1024
(dell 1905fp)

i think it looks great.

rico
 
Old 03-14-2005, 02:53 AM   #63
asklepios
Member
 
Registered: Apr 2003
Distribution: Slackware 10.0
Posts: 46

Rep: Reputation: 15
amazing is the word that comes to mind!!!
i never knew that screwing patent laws can bring such great results :-P
thanx a lot dude...just can't thank you enough
 
Old 03-18-2005, 08:06 PM   #64
KENTOSI
LQ Newbie
 
Registered: Mar 2005
Location: sydney, australia
Posts: 9

Rep: Reputation: 0
Hey dude thanks HEAPS for your help. You have no idea how much of a relief this is for my eyes! Everything worked fine here and I'm lovin my linux even more now - thanks to you :-)

Just a quick question (since I'm exhusted from searching/reading about this) - Certain websites (including this one!) make use of the Courier font (not Courier New). My Fedora uses its own native (Type 1 I think) version of it which looks very distorted. How do I make it use the Windows one? I tried moving the native courier fonts from the /usr/X11R6/lib/X11/fonts/Type1/ to some other backup location and added the windows TTF courier font files to /usr/X11R6/lib/X11/fonts/TTF and ran the proper mkfontscale/mkfontdir/chkfontpath commands, but still no luck.

Basically, what I'm asking is this: How do you make linux take precedence of the windows fonts and ignore its own native versions?

Thanks in advance!
 
Old 03-19-2005, 11:59 AM   #65
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Not certain if this is what you are asking, but depending on the browser, you can specify whether the bowser only uses your fonts or allows documents to use other fonts. You will find this option as a radio button on the same page where you select your font preferences. I prefer to allow documents to use other fonts and, on occasion, these will be fonts that do not render well. Forcing the browser to use my fonts will usually fix this, but these sites are in the minority so I keep my settings the same. I use Arial as my default sans serif font and on many sites this renders too small when used for the smallest fonts (LQ is an example). Allowing sites to use their own fonts produces a better result on most occasions.

The only browser where I cannot find this option is konqueror, but I use this less and less for web browsing anyway.

HTH
 
Old 03-19-2005, 05:51 PM   #66
KENTOSI
LQ Newbie
 
Registered: Mar 2005
Location: sydney, australia
Posts: 9

Rep: Reputation: 0
Umm... ok here's the deal:

When I look at one of your original posts at:
http://www.linuxquestions.org/questi...27#post1309027
The part where you write:
Code:
#   FontPath  "/usr/X11R6/lib/X11/fonts/local"
#   FontPath  "/usr/X11R6/lib/X11/fonts/CID"
on my linux, look all distorted. I've provided a screenshot here.

I imagine that this is because my linux is using the Type 1 Courier font, which I believe is located in:
Code:
cd /usr/X11R6/lib/X11/fonts/Type1/cour*.*
Now, after searching google, I managed to get my hands on the original Windows courier font - COURE.FON. Note that this doesn't have a TTF extension.

My question is, how do I make my linux disregard the Type 1 fonts and use the COURE.FON font instead? Ie - how do I make the standard Courier font look good without having to replace it with the TrueType Courier New font eveywhere?

Hope I've made myself a lot more clearer
 
Old 03-19-2005, 06:13 PM   #67
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Did you specify "courier new" as the monotype/monospace font for your web browser? If I specify courier or courier 10 pitch, I get similar results - courier is the worst.
 
Old 03-21-2005, 05:48 AM   #68
alxnd
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
Franklin, excellent results, but there is still one little thing: XP always do anti-aliasing on bold fonts, regardless of size. This is not so with your solution. Can't that be done, too?
 
Old 03-21-2005, 07:13 PM   #69
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55


I don't know if it can. But, if if CAN be done, it would be accomplished perhaps by editing /home/<user>/.font.conf and stipulating that antialiasing be enabled "except" for the fonts arial, tahoma, verdana, helvetica - rather than stipulating a particular font size to be exempt from antialiasing. Then all fonts would be antialiased except the ones you want.

You could start with that and, if you are successful try to narrow it down further.

I have no idea if this would work or not but it came to my mind and I thought I would offer it as a suggestion.

Good luck if you try - post results if it works.

Last edited by Franklin; 04-08-2005 at 06:54 PM.
 
Old 03-29-2005, 05:48 AM   #70
Hal
Member
 
Registered: Oct 2003
Location: East Anglia, England
Distribution: Dapper Drake / Slackware
Posts: 151

Rep: Reputation: 30
Part two: make Windows XP fonts look like Linux.

Step one: download cleartype; http://www.microsoft.com/typography/...ePowerToy.mspx


Step two: click randomly

Step Three: enjoy horrible aliased fonts with XP.

Heh, no really...
I followed the instructions you set out Franklin and am now enjoying nice non-aliased fonts with GNOME. Great job, cheers!
 
Old 03-30-2005, 08:28 PM   #71
jfall
Member
 
Registered: Oct 2002
Location: PEI
Distribution: Slackware
Posts: 56

Rep: Reputation: 15
Franklin,

I followed your guide a month or so ago and it worked great, I was finally able to get my fonts setup perfectly.

Today I decided to upgrade with swaret, which included the new KDE 3.4 package. Since I upgraded, my fonts look terrible. I followed through your guide again twice, but no matter what I do, the fonts look very bad.

I have confirmed that i'm running in 96x96 DPI and TTF fonts are properly installed. I have compiled the latest Freetype making sure to enable truetype in the ftoption include file to no avail.

Have you recently upgraded to KDE 3.4? Did you also experience similar problems? Do you know of any way to get it fixed up?

Thanks again for your guide!
 
Old 03-31-2005, 05:09 AM   #72
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Yes I have, though not with swaret. I rsync current on a local drive and use upgradepkg.
KDE 3.4.0 works fine with my install.

Check Xorg.0.log and make sure that freetype is loading correctly from xorg.conf.
I had this happen with an upgrade of ubuntu from warty to hoary. After checking everything and recompiling freetype and reinstalling fonts, I found that freetype was failing with and error. My solution was to do a clean install using a hoary install disk rather than doing an upgrade.

Not sure if this is your problem or not, but it may be worth a look. A re-install may not have been needed in my case, but was the fastest for me since I am not familiar with debian-like systems.

HTH
 
Old 03-31-2005, 07:52 AM   #73
jfall
Member
 
Registered: Oct 2002
Location: PEI
Distribution: Slackware
Posts: 56

Rep: Reputation: 15
It does appear that FreeType is loading correctly, I have the following in xorg.conf

Load "freetype"

and see this in the xorg log:

(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 6.8.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType

I wonder if it's loading the proper freetype module. The /usr/X11R6/lib/modules/fonts/libfreetype.so file hasn't been modified recently. Shouldn't it be loading from /usr/lib?
 
Old 04-02-2005, 03:24 AM   #74
da644
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
Hi All.

This is really excellent and worked really well (Fedora Core 3), apart from the Gnome Terminal window now looks terriable, almost unreadable, but everything else is great. Any ideas how to fix the terminal window?

Andrew.
 
Old 04-08-2005, 01:35 PM   #75
spes_hominis
Member
 
Registered: Jun 2004
Location: N. Ireland
Distribution: Zenwalk 6.2
Posts: 30

Rep: Reputation: 15
There is a mistake in the Freetype readme that you quote; in the latest version (2.1.9) you just remove the comments that bracket the line. Not your fault
 
  


Reply

Tags
antialiasing, fonts, howto, openoffice.org, resolution, screen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xft2 not antialiased fonts look ugly pijulius Linux - Software 0 02-20-2004 09:53 AM
No antialiased fonts in Mozilla 1.6? misfit-x Linux - Software 13 02-10-2004 06:57 AM
Fuzzy antialiased fonts in Slackware 9.0 Kovacs Slackware 1 11-23-2003 08:12 AM
too blurry antialiased fonts oski Mandriva 4 10-12-2003 01:22 PM
How to make the GDM to use the antialiased fonts? Xterminator Conectiva 1 11-22-2002 08:10 PM


All times are GMT -5. The time now is 11:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration