LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices



Reply
 
Search this Thread
Old 04-25-2005, 04:38 PM   #76
artistikone
Member
 
Registered: Jul 2003
Distribution: slackware-current
Posts: 76

Rep: Reputation: 15

I'm having the same issue as jfall

Quote:
It does appear that FreeType is loading correctly, I have the following in xorg.conf

Load "freetype"

and see this in the xorg log:

(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 6.8.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType

I wonder if it's loading the proper freetype module. The /usr/X11R6/lib/modules/fonts/libfreetype.so file hasn't been modified recently. Shouldn't it be loading from /usr/lib?
All my libs in /usr/lib updated with the new compile however the one in /usr/X11R6/lib/modules/fonts/ has not. I tried linking that one to the updated one in /usr/lib, of course that didn't work.
 
Old 04-27-2005, 08:21 AM   #77
dirk.wessner
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
Unhappy Debian/Sarge - cant' get it working.

Hello,

I followed the detailed HOWTO, and as some said above, everything *seems* to work
but there is no visble change. Fonts still look terrible with anti-aliasing off.

I also have tried to replace the freetype lib that X seems to load by default
/usr/X11R6/lib/modules/fonts/libfreetype.a
with the newly compiled/installed, but this will produce an error message:

Quote:
Duplicate symbol BitOrderInvert in /usr/X11R6/lib/modules/fonts/libfreetype.a:wi
nfnt.o
Also defined in (built-in)

Fatal server error:
Module load failure
But, if I do not replace the X standard libfreetype.a, will it have any effect
to install a new version of freetype? Don't understand in detail when which lib file is loaded
by what process (does X load another one then KDE?!)

I also tried to experiment with /etc/font/*, for example by adding
Code:
<match target="font" >
   <edit mode="assign" name="hinting" >
      <bool>true</bool>
   </edit>
</match>
to local.conf.

Sad...your screenshots are really looking great...But I'm near to give up.
Finding this thread already took me several days...

Maybe anybody has succeeded in getting this working with Debian/Sarge?

[UPDATE]

Hey!
I don't know what I did wrong before, but now it is working!
Finally I fetched the latest version of freetype (2.1.9), compiled, installed,
and it works!
BUT only with the additional lines in /etc/fonts/local.conf, as mentioned above.
I tried it out, removing the lines->ugly fonts, adding the lines->nice.

Well, as I tried out so many things now It could be that I did sth. else to get it work,
but I can't remember.

Hopes this is useful for anybody.

Cheers,
Dirk

Last edited by dirk.wessner; 04-27-2005 at 10:03 AM.
 
Old 05-01-2005, 05:37 AM   #78
yhager
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
Thanks for the detailed instructions.

One problem I had was the Firefox 1.0.2 kept crashing when printing to a postscript printer with:

/usr/lib/mozilla-firefox/firefox-bin: relocation error: /usr/lib/mozilla-firefox/components/libgfxps.so: undefined symbol: FTC_Image_Cache_New

Reverting to use libfreetype v6.3.5 (the one that comes with hoary) resolved the problem.
 
Old 05-20-2005, 06:12 PM   #79
tantotea
LQ Newbie
 
Registered: Oct 2004
Location: UK
Distribution: Fedora Core 4, Redhat 9, Mandrake 10.1
Posts: 15

Rep: Reputation: 0
monospace fonts still look ugly

Hi, Thank you for the HOWTO. After following the suggestion, my fonts are beautiful.

However, I don't know why, but my monospace font still looks ugly - rough. I tried monospace and courier new size 9 and 10, but they still look ugly, other fonts are ok.

I don't know if this is related, but I think BEFORE the xorg was upgraded to 6.8.2 (using rpm - FC3) the monospace fonts was OK. Since the xorg is upgraded to 6.8.2 my monospace font is rough.
 
Old 05-30-2005, 11:41 AM   #80
small_boy22
Member
 
Registered: May 2005
Posts: 45

Rep: Reputation: 15
problem with windowmaker && fluxbox

First to say thanks to Franklin for this amazing how-to...
I've been searching many times on the net to find something good about fonts and now my head does not heart after many hours on my slackware box

But i have some problems yet to solve...

I followed the howto.All went ok.

if i am logged in as root:

mozilla && firefox and all GTK,GTK+2 apps work great when i created .gtkrc and .gtkrc-2.0(changing font to Verdana 10) files in /root/ . This apps work great on KDE , WindowMaker and FluxBox ... i don't have GNOME

--->
the problems starts when i log on as user:

I have created .gtkrc and .gtkrc-2.0 to my $HOME changing font to Verdana 10
contets of these 2 files in /root/ and $HOME are exactly the same. AA is turned off.

If i use KDE , GTK,GTK+2 applications look like the ones in the screenshots of Franklin (that means perfect !!)
BUT if I use WindowMaker (my default) or FluxBox ONLY GTK,GTK+2 apps look like they are Anti-Aliased !!!!!!ALL else look great

GTK,GTK+2 apps look to respond to .gtkrc and .gtkrc-2.0 because i changed the font size and i saw the difference.Also i tried to change the font to other MS-Fonts or NON-MS but results are the same they look AA

I have edited /etc/fonts/local.conf with some things suggested in this topic but nothing changed.Fonts permissions are OK.
Damn this problems seems to be hard because i repeat : if i use KDE as user all look ok , but if i use WindowMaker or Fluxbox ONLY the GTK,GTK+2 fonts look like Anti-Aliased DESPITE the fact that Anti-Aliasing is turned off in both WindowMaker and FluxBox....


Any ideas ???

using slack10.1 and i recompiled the freetype2.1.9 library from Pat's sources(slackware's sources) where there is also a patch that prevents breakings of many things :P
i have also installed freetype 1.3.1 that i needed to compile some other stuff, i hope that there is impication between those 2 libraries

Last edited by small_boy22; 05-30-2005 at 12:01 PM.
 
Old 05-30-2005, 05:08 PM   #81
tantotea
LQ Newbie
 
Registered: Oct 2004
Location: UK
Distribution: Fedora Core 4, Redhat 9, Mandrake 10.1
Posts: 15

Rep: Reputation: 0
Smile re: monospace fonts still look ugly

just found out that by inserting the following into /etc/fonts/local.conf,
monospace can be AA (while others are non-AA)
- so I can like monospace in console and in code editor.


Code:
<match target="pattern">
    <test qual="any" name="family">
        <string>monospace</string>
    </test>
    <edit name="antialias">
        <bool>true</bool>
    </edit>
</match>

Last edited by tantotea; 05-30-2005 at 05:10 PM.
 
Old 05-31-2005, 11:57 AM   #82
small_boy22
Member
 
Registered: May 2005
Posts: 45

Rep: Reputation: 15
anyone else have the same problem as i do with GTK applications ?
 
Old 06-01-2005, 11:21 AM   #83
small_boy22
Member
 
Registered: May 2005
Posts: 45

Rep: Reputation: 15
Quote:
Originally posted by small_boy22
anyone else have the same problem as i do with GTK applications ?
nvm i found the solution.
Even if i had AA disabled from the windowmaker panel i need to add some XML code in my ~/.fonts/local.conf to disable AA.
Now everything looks more than great !!!
 
Old 07-02-2005, 12:52 PM   #84
spes_hominis
Member
 
Registered: Jun 2004
Location: N. Ireland
Distribution: Zenwalk 6.2
Posts: 30

Rep: Reputation: 15
Some kind soul has wrapped the MS Core Fonts and the recompiled Freetype into an installable Slackware package
http://www.fairylinux.org
You still have to make your own .gtkrc-2.0, though.
 
Old 07-05-2005, 11:29 AM   #85
adamb10
Member
 
Registered: Aug 2003
Posts: 86

Rep: Reputation: 15
I don't wanna read through 6 pages of replies. Who can confirm this works on Ubuntu Hoary?
 
Old 07-05-2005, 12:35 PM   #86
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
I have done this successfully for the following:

Slackware
SuSE
Ubuntu
Debian

I never remove the original package anymore - just

./configure --prefix=/usr
make
make install (as root)

I am using fretype 2.1.10
 
Old 07-12-2005, 06:55 PM   #87
83Scrambler
LQ Newbie
 
Registered: Jul 2005
Location: Nashville, TN
Distribution: Fedora
Posts: 1

Rep: Reputation: 0
Fantastic!

Those fuzzy fonts on Linux have been keeping me away from Linux for my main use. This solves it! I'm thrilled.

FYI for others with Fedora Core 4 and Gnome:

No need to mess with resolution, screen size, and dpi. Gnome handles this for you as far as I can tell.

Just recompile freetype, set your fonts, build the gtk file that Franklin mentioned, and restart X. It's a different world

Thanks...
 
Old 07-19-2005, 06:25 PM   #88
sierra
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
Franklin

You said it works for ubuntu hoary, thats great.

I have not clear couple of things, excuse my linux ignorance and my English (im not English native speaker)

does ubuntu hoary (debian) come with the BCI enabled ?

having a LCD monitor Samsung sync 710 N, and enabling the BCI (recompiling freetype), makes fonts to look better ?

my ttf fonts look funny, some look a little thick (little blurry )

i m using sub pixel rendering and hinting full in gnome

i dont know if you need more info

thanks in advance
 
Old 07-19-2005, 07:45 PM   #89
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Hi Sierra,

Debian and Ubuntu "could" have a version of freetype with the bytecode interpreter enabled depending on where the mirror was that you installed from - i.e. non US mirror (this is what I remember reading regarding Debian at least - may not be true for Ubuntu - may not be true for Deb either )

In my experience, I have had better results for both distros by compiling freetype from source.
This implies that my installs did NOT have BCI enabled. I do not know for sure though.

I will also state that my monitor is a CRT - I do not like flat panels as a general rule.

LCD's are finicky and, from my limited experience with them, appear to look best at a particular resolution. You may need to play to get things to look nice to you.

Heck, you may like antialiased fonts better for the monitor you use. I can't help you with that.

In regard to the english - I am ashamed that I cannot speak any other language as well as you have just done with english.

In regard to linux - I don't think you ever stop being a newbie - certainly not me.

Later
 
Old 07-20-2005, 08:16 AM   #90
burngalf
LQ Newbie
 
Registered: Jul 2005
Location: Germany
Posts: 1

Rep: Reputation: 0
Hello Franklin, hello all!

So glad that this thread exists and is still active! It helped me a lot - now hardly any eye strain when working with Linux :-)

However, I came across a strange phenomenon when following the above mentioned steps (recompilation of freetype, enabling bytecode interpreter): I tried the procedure using the Kanotix distribution (Debian-based, Knoppix-derivative) and resulted in having perfectly rendered (truetype) fonts when logged in as root - however, bytecode interpreter does not seem to be activated as normal user. How can I turn on the bytecode interpreter for a specific user? Generally, the compilation must have worked: as I said, everything OK as root...

Anybody out there who can help me??
 
  


Reply

Tags
antialiasing, fonts, howto, openoffice.org, resolution, screen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xft2 not antialiased fonts look ugly pijulius Linux - Software 0 02-20-2004 10:53 AM
No antialiased fonts in Mozilla 1.6? misfit-x Linux - Software 13 02-10-2004 07:57 AM
Fuzzy antialiased fonts in Slackware 9.0 Kovacs Slackware 1 11-23-2003 09:12 AM
too blurry antialiased fonts oski Mandriva 4 10-12-2003 02:22 PM
How to make the GDM to use the antialiased fonts? Xterminator Conectiva 1 11-22-2002 09:10 PM


All times are GMT -5. The time now is 03:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration