LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 10-12-2003, 06:51 AM   #1
oski
Member
 
Registered: Aug 2003
Location: GMT +1(+2 summer)
Distribution: Xubuntu 7.10
Posts: 60

Rep: Reputation: 15
Unhappy too blurry antialiased fonts


I easily switched off antialiasing in KDE desktop, but it had no efect in non KDE applications. I didn't find where to perform the disabling and re-enabling (if necessary) of antialiasing valid for non KDE applications. I guess I'll need to edit some sort of .conf file, but I don't know where to start. Thanks in advance!
 
Old 10-12-2003, 12:04 PM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
there should be a file called .fonts.conf in your home directory. If there isn't, go to kde control center, enable anti-aliasing with it disabled for certain font sizes. Then disable it again.

When you open .fonts.conf, you should see what needs to be done. Basically,

<edit mode="assign" name="antialias" >
<bool>true</bool>

needs to be changed to

<edit mode="assign" name="antialias" >
<bool>false</bool>

It must be a bug in kde not to change the settings in this file as well. I actually don't know where kde saves its own aa-settings...
 
Old 10-12-2003, 01:15 PM   #3
oski
Member
 
Registered: Aug 2003
Location: GMT +1(+2 summer)
Distribution: Xubuntu 7.10
Posts: 60

Original Poster
Rep: Reputation: 15
Thanks for quick answer quatsch. Unfortunately I was unable to find .fonts.conf in my home, all I found was /etc/fonts/fonts.conf, I openned in a text editor and no lines, like the ones you showed me, exist. Must I add them? I guess that editing such a file is not danger free, nor newbie proof. Do you have more ideas? Does anyone? Yes, I know the blurry fonts is not a crucial problem, but is one that causes fatigue to eyes with the hours. Thanks one more time.
 
Old 10-12-2003, 01:38 PM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
did you try enabling anti-aliasing in kde control center? When you specify that some font sizes are to be excluded from aa-ing, it should create a .fonts.conf in your home directory. BTW, it's a hidden file as the leading . indicates.
I do NOT recomment editing /etc/fonts/fonts.conf

If nothing else, you can create a .fonts.conf in your home directory. After logging in again, the settings will take effect. Mine looks like this: It is set to anti-alias fonts smaller than 8pts and larger than 16pts, and leave the rest normal - you can change the numbers to your liking. For very small and very large things, anti-aliasing is good.
Code:
<?xml version="1.0"?>
<fontconfig>
 <match target="font" >
  <test compare="more" name="size" qual="any" >
   <double>8</double>
  </test>
  <test compare="less" name="size" qual="any" >
   <double>16</double>
  </test>
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>
 
Old 10-12-2003, 02:22 PM   #5
oski
Member
 
Registered: Aug 2003
Location: GMT +1(+2 summer)
Distribution: Xubuntu 7.10
Posts: 60

Original Poster
Rep: Reputation: 15
I got it! thanks so much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making non-antialiased fonts looks nice. Franklin LinuxQuestions.org Member Success Stories 186 11-05-2008 03:47 AM
xft2 not antialiased fonts look ugly pijulius Linux - Software 0 02-20-2004 10:53 AM
No antialiased fonts in Mozilla 1.6? misfit-x Linux - Software 13 02-10-2004 07:57 AM
Fuzzy antialiased fonts in Slackware 9.0 Kovacs Slackware 1 11-23-2003 09:12 AM
How to make the GDM to use the antialiased fonts? Xterminator Conectiva 1 11-22-2002 09:10 PM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration