LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-25-2004, 10:47 AM   #1
raven
Member
 
Registered: Dec 2001
Location: Basel, Switzerland
Distribution: ubuntu
Posts: 297

Rep: Reputation: 31
xfree module load error (duplicate symbol)


Hello I recently updated my gentoo system by reinstalling everything from sratch. First I tryed the package called xorg-x11. It compiled and installed fine, but then, when I wanted to start the Xserver, I got following message:
Duplicate symbol __i686.get_pc_thunk.bx in /usr/X11R6/lib/modules/fonts/libbitmap.a:bitmapmod.so
Also defined in /usr/X11R6/lib/modules/fonts/libbitmap.a

What can I do about this? I do'n t really understand what happened here, becaues my previous system worked fine (with almost the same version of xfree). The other strange thing is, this error occurs with BOTH xorg-x11 AND xfree86.

Any hints?

Thanks

raven
 
Old 09-30-2004, 07:37 PM   #2
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 396

Rep: Reputation: 32
I have the same issue if I find a fix I will post it here. I am serching google now
 
Old 10-01-2004, 02:26 AM   #3
raven
Member
 
Registered: Dec 2001
Location: Basel, Switzerland
Distribution: ubuntu
Posts: 297

Original Poster
Rep: Reputation: 31
hello

I already found a solution. I used hardened sources, thats wat made my system stop working. So, i switched back to default and now it runs fine.

G

raven
 
Old 10-01-2004, 05:56 PM   #4
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 396

Rep: Reputation: 32
Lightbulb The real fix!

Yes you have you X GUI back up, but not with the best slution. The howto says that USE=dlloader will not work with nVidia or ATI drivers, but the patch is step 2 and 3 is a fix for this. I have hardened + xorg + nVidia.
Now that is a fix!

0. Read http://www.gentoo.org/proj/en/hardened/hardenedxorg.xml

1. Goto http://bugs.gentoo.org/show_bug.cgi?id=64618

2. Get the xorg-x11-6.8.0-r1.ebuild.diff patch

3. cp patch to /usr/portage/x11-base/xorg-x11/

4. mkdir /mnt/backup; cd /mnt/backup; tar -cvjf dev.tar.bz2 /dev

5. type patch -nu xorg-x11-6.8.0-r1.ebuild xorg-x11-6.8.0-r1.ebuild.diff

6. type USE=dlloader ACCEPT_KEYWORDS="~x86" emerge xorg-x11-6.8.0-r1.ebuild


Last edited by enyawix; 10-01-2004 at 07:26 PM.
 
Old 01-20-2005, 06:09 AM   #5
Vrosten
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
Exclamation An another resolution

Hi guys,

I find the same problem when I trie to install Gentoo+hardened+Fluxbox. In the end of my search, I found this site which has a solution. This is working to me.

http://lwn.net/Articles/106214/

In bottom of this page have a post of an user.

I hope this help you too !!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel module symbol error b123coder Programming 0 12-03-2004 04:56 AM
firmware_class error on module load grey_rook Linux - Laptop and Netbook 2 10-01-2004 12:42 AM
unresolved symbol error/ acx100_pci.o module sahil1 Linux - Hardware 0 03-12-2004 01:32 AM
(EE) Failed to load module error Seventh Linux - Newbie 8 02-23-2004 03:16 PM
xfree and euro symbol zeppelin Linux - General 1 06-24-2003 05:52 AM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration