LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-23-2004, 12:46 PM   #1
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
(EE) Failed to load module error


Starting X, latest nvidia compiled from source and insmodd'ed.

It's also in /etc/modules, and seems to be working, or at least installed correctly - I don't see why the error it's throwing is that the module doesn't exist. It's loading, and it's in /lib/modules/(kernel)/video.


My XF86Config:

Code:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
#	Load  "dri"
EndSection

Section "InputDevice"
	Option	"XkbDisable"
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "PS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "Monitor"
	Identifier   "WUXGA"
	HorizSync    28-110
	VertRefresh  43-90
	Option	    "DPMS"
        Modeline "1920x1200" 162 1920 1984 2176 2480 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Device"
	Identifier	"GeForce 4200 Go"  
	Driver      	"nvidia"
        Option          "NoLogo"                "true"
        Option          "FlatPanelProperties"   "aspect-scaled"
        Option          "RenderAccel"           "off"
        Option          "UseEdidFreqs"          "on"
	Option 		"NvAgp" 		"2"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "GeForce 4200 Go"
	Monitor    "WUXGA"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1920x1200" "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

And my XFree86.0.log:

Code:
This is a pre-release version of XFree86, and is not supported in any
way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
	If the server is older than 6-12 months, or if your card is
	newer than the above date, look for a newer version before
	reporting problems.  (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.3-bk2 i686 [ELF] 
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Feb 23 08:36:25 2004
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "WUXGA"
(**) |   |-->Device "GeForce 4200 Go"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbDisable"
(**) XKB: disabled
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "DevInputMice"
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
	XFree86 ANSI C Emulation: 0.1
	XFree86 Video Driver: 0.4
	XFree86 XInput driver : 0.2
	XFree86 Server Extension : 0.1
	XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	Module class: XFree86 Font Renderer
	ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,3340 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,3341 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:1d:0: chip 8086,24c2 card 8086,4541 rev 01 class 0c,03,00 hdr 80
(II) PCI: 00:1d:1: chip 8086,24c4 card 8086,4541 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:1d:2: chip 8086,24c7 card 8086,4541 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:1d:7: chip 8086,24cd card 1028,014e rev 01 class 0c,03,20 hdr 00
(II) PCI: 00:1e:0: chip 8086,2448 card 0000,0000 rev 81 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,24cc card 0000,0000 rev 01 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,24ca card 8086,4541 rev 01 class 01,01,8a hdr 00
(II) PCI: 00:1f:5: chip 8086,24c5 card 1028,014e rev 01 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0286 card 1028,0179 rev a1 class 03,00,00 hdr 00
(II) PCI: 02:00:0: chip 14e4,165d card 1028,865d rev 01 class 02,00,00 hdr 00
(II) PCI: 02:01:0: chip 104c,ac47 card 0000,0000 rev 01 class 06,07,00 hdr 82
(II) PCI: 02:01:1: chip 104c,ac4a card 0000,0000 rev 01 class 06,07,00 hdr 82
(II) PCI: 02:01:2: chip 104c,802b card 1028,014e rev 00 class 0c,00,10 hdr 80
(II) PCI: 02:01:3: chip 104c,8204 card 1028,014e rev 00 class 08,80,00 hdr 80
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1 0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
	[0] -1 0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
	[0] -1 0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0c (VGA_EN is set)
(II) Bus 1 I/O range:
	[0] -1 0	0x0000c000 - 0x0000c0ff (0x100) IX[B]
	[1] -1 0	0x0000c400 - 0x0000c4ff (0x100) IX[B]
	[2] -1 0	0x0000c800 - 0x0000c8ff (0x100) IX[B]
	[3] -1 0	0x0000cc00 - 0x0000ccff (0x100) IX[B]
(II) Bus 1 non-prefetchable memory range:
	[0] -1 0	0xfc000000 - 0xfdffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
	[0] -1 0	0xf0000000 - 0xf3ffffff (0x4000000) MX[B]
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x04 (VGA_EN is cleared)
(II) Bus 2 I/O range:
	[0] -1 0	0x0000d000 - 0x0000d0ff (0x100) IX[B]
	[1] -1 0	0x0000d400 - 0x0000d4ff (0x100) IX[B]
	[2] -1 0	0x0000d800 - 0x0000d8ff (0x100) IX[B]
	[3] -1 0	0x0000dc00 - 0x0000dcff (0x100) IX[B]
	[4] -1 0	0x0000e000 - 0x0000e0ff (0x100) IX[B]
	[5] -1 0	0x0000e400 - 0x0000e4ff (0x100) IX[B]
	[6] -1 0	0x0000e800 - 0x0000e8ff (0x100) IX[B]
	[7] -1 0	0x0000ec00 - 0x0000ecff (0x100) IX[B]
(II) Bus 2 non-prefetchable memory range:
	[0] -1 0	0xf6000000 - 0xfbffffff (0x6000000) MX[B]
(II) Bus 2 prefetchable memory range:
(II) Bus -1: bridge is at (0:31:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0286) rev 161, Mem @ 0xfc000000/24, 0xf0000000/26, BIOS @ 0x80000000/17
(II) Addressable bus resource ranges are
	[0] -1 0	0x00000000 - 0xffffffff (0x0) MX[B]
	[1] -1 0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
	[0] -1 0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1 0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1 0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1 0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1 0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1 0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[6] -1 0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
	[0] -1 0	0xfafe8000 - 0xfafeffff (0x8000) MX[B]E
	[1] -1 0	0xfafef800 - 0xfafeffff (0x800) MX[B]E
	[2] -1 0	0xf4fff400 - 0xf4fff7ff (0x400) MX[B]E
	[3] -1 0	0xf4fff800 - 0xf4ffffff (0x800) MX[B]E
	[4] -1 0	0xf4fffc00 - 0xf4ffffff (0x400) MX[B]E
	[5] -1 0	0xec000000 - 0xefffffff (0x4000000) MX[B]E
	[6] -1 0	0x80000000 - 0x8001ffff (0x20000) MX[B](B)
	[7] -1 0	0xf0000000 - 0xf3ffffff (0x4000000) MX[B](B)
	[8] -1 0	0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
	[9] -1 0	0x0000ecf8 - 0x0000ecff (0x8) IX[B]E
	[10] -1 0	0x0000bc40 - 0x0000bc7f (0x40) IX[B]E
	[11] -1 0	0x0000b800 - 0x0000b8ff (0x100) IX[B]E
	[12] -1 0	0x0000bfa0 - 0x0000bfbf (0x20) IX[B]E
	[13] -1 0	0x00000374 - 0x00000377 (0x4) IX[B]E
	[14] -1 0	0x00000170 - 0x0000017f (0x10) IX[B]E
	[15] -1 0	0x000003f4 - 0x000003f7 (0x4) IX[B]E
	[16] -1 0	0x000001f0 - 0x000001ff (0x10) IX[B]E
	[17] -1 0	0x0000bf20 - 0x0000bf3f (0x20) IX[B]E
	[18] -1 0	0x0000bf40 - 0x0000bf7f (0x40) IX[B]E
	[19] -1 0	0x0000bf80 - 0x0000bfff (0x80) IX[B]E
(II) PCI Memory resource overlap reduced 0xfafe8000 from 0xfafeffff to 0xfafebfff
(II) PCI Memory resource overlap reduced 0xf4fff800 from 0xf4ffffff to 0xf4fffbff
(II) PCI I/O resource overlap reduced 0x0000bf80 from 0x0000bfff to 0x0000bf9f
(II) Active PCI resource ranges after removing overlaps:
	[0] -1 0	0xfafe8000 - 0xfafebfff (0x4000) MX[B]E
	[1] -1 0	0xfafef800 - 0xfafeffff (0x800) MX[B]E
	[2] -1 0	0xf4fff400 - 0xf4fff7ff (0x400) MX[B]E
	[3] -1 0	0xf4fff800 - 0xf4fffbff (0x400) MX[B]E
	[4] -1 0	0xf4fffc00 - 0xf4ffffff (0x400) MX[B]E
	[5] -1 0	0xec000000 - 0xefffffff (0x4000000) MX[B]E
	[6] -1 0	0x80000000 - 0x8001ffff (0x20000) MX[B](B)
	[7] -1 0	0xf0000000 - 0xf3ffffff (0x4000000) MX[B](B)
	[8] -1 0	0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
	[9] -1 0	0x0000ecf8 - 0x0000ecff (0x8) IX[B]E
	[10] -1 0	0x0000bc40 - 0x0000bc7f (0x40) IX[B]E
	[11] -1 0	0x0000b800 - 0x0000b8ff (0x100) IX[B]E
	[12] -1 0	0x0000bfa0 - 0x0000bfbf (0x20) IX[B]E
	[13] -1 0	0x00000374 - 0x00000377 (0x4) IX[B]E
	[14] -1 0	0x00000170 - 0x0000017f (0x10) IX[B]E
	[15] -1 0	0x000003f4 - 0x000003f7 (0x4) IX[B]E
	[16] -1 0	0x000001f0 - 0x000001ff (0x10) IX[B]E
	[17] -1 0	0x0000bf20 - 0x0000bf3f (0x20) IX[B]E
	[18] -1 0	0x0000bf40 - 0x0000bf7f (0x40) IX[B]E
	[19] -1 0	0x0000bf80 - 0x0000bf9f (0x20) IX[B]E
(II) OS-reported resource ranges after removing overlaps with PCI:
	[0] -1 0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1 0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1 0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1 0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1 0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1 0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[6] -1 0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
	[0] -1 0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1 0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1 0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1 0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1 0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1 0	0xfafe8000 - 0xfafebfff (0x4000) MX[B]E
	[6] -1 0	0xfafef800 - 0xfafeffff (0x800) MX[B]E
	[7] -1 0	0xf4fff400 - 0xf4fff7ff (0x400) MX[B]E
	[8] -1 0	0xf4fff800 - 0xf4fffbff (0x400) MX[B]E
	[9] -1 0	0xf4fffc00 - 0xf4ffffff (0x400) MX[B]E
	[10] -1 0	0xec000000 - 0xefffffff (0x4000000) MX[B]E
	[11] -1 0	0x80000000 - 0x8001ffff (0x20000) MX[B](B)
	[12] -1 0	0xf0000000 - 0xf3ffffff (0x4000000) MX[B](B)
	[13] -1 0	0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
	[14] -1 0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[15] -1 0	0x00000000 - 0x000000ff (0x100) IX[B]
	[16] -1 0	0x0000ecf8 - 0x0000ecff (0x8) IX[B]E
	[17] -1 0	0x0000bc40 - 0x0000bc7f (0x40) IX[B]E
	[18] -1 0	0x0000b800 - 0x0000b8ff (0x100) IX[B]E
	[19] -1 0	0x0000bfa0 - 0x0000bfbf (0x20) IX[B]E
	[20] -1 0	0x00000374 - 0x00000377 (0x4) IX[B]E
	[21] -1 0	0x00000170 - 0x0000017f (0x10) IX[B]E
	[22] -1 0	0x000003f4 - 0x000003f7 (0x4) IX[B]E
	[23] -1 0	0x000001f0 - 0x000001ff (0x10) IX[B]E
	[24] -1 0	0x0000bf20 - 0x0000bf3f (0x20) IX[B]E
	[25] -1 0	0x0000bf40 - 0x0000bf7f (0x40) IX[B]E
	[26] -1 0	0x0000bf80 - 0x0000bf9f (0x20) IX[B]E
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 0.0.2
	ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.13.0
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.1.9
	Module class: XFree86 Font Renderer
	ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	Module class: XFree86 Font Renderer
	ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 1.0.0
	Module class: XFree86 XInput Driver
	ABI class: XFree86 XInput driver, version 0.2
(EE) No drivers available.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.
Card is an NVidia GEForce 4200 on The Accursed Dell Latitude D800 Of Doom.

Compiled from This source, which I got from This Guy's website.

Any ideas always appreciated, as are simple posts calling me a noob and pointing fingers.
 
Old 02-23-2004, 12:54 PM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Have you tried the nVidia binary installer?
Latest version supports 2.6 kernels, and did the job prefectly for me.

--Rounan
 
Old 02-23-2004, 01:08 PM   #3
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Hrm, no. I'm running 2.2.20 right now, however.

One thing of note is that a 'modprobe nv' gives me (in addition to listing the working nvidia.o module):

/lib/modules/2.2.20-idepci/video/nv.o: init_module: Device or resource busy

and a couple of lines, ending with "insmod nv vailed".

Perhaps the nv.o is somehow using the resources that nvidia.o needs?

I'd be interested in that binary installer though. Got a link handy?
 
Old 02-23-2004, 01:16 PM   #4
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
what you're describing is normal, but you've got the interpretation reversed.
You're trying to install nv.o (which you don't want) on top of nvidia.o (which you do), and it's telling you you can't do that because nvidia.o is already using the resource. This is a good thing.

2.2 kernel?? yeee-gads, man! get 2.6! :P

Binary:
http://www.nvidia.com/object/linux.html

Try the latest version - don't know if it'll work with a 2.2, though it should be backwards compatible. There's a link off that page to older versions though (Archive). 4496 is tried and tested, 5328 is notably flakey.

--Rounan
 
Old 02-23-2004, 01:33 PM   #5
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Heheh I'm not even going to go into why I'm not running 2.6 - search on my username in the Debian forum and you can bear witness to some of the hellish nightmare that I went through trying (and ultimately failing) to get it running on this machne. It's truly cursed.

Anyhow, I grabbed the binary (heh, I googled before I came back to post this). As with all things D800, it pretty much gives me the finger. Here's the log:

Code:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Feb 23 09:30:40 2004

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : false
  no questions            : false
  silent                  : false
  XFree86 install prefix  : /usr/X11R6
  OpenGL install prefix   : /usr
  Installer install prefix: /usr
  kernel source path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp site                : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
ERROR: Unable to find the kernel source tree for the currently running kernel. 
       Please make sure you have installed the kernel source files for your
       kernel; on Red Hat Linux systems, for example, be sure you have the
       'kernel-source' rpm installed.  If you know the correct kernel source
       files are installed, you may specify the kernel source path with the
       '--kernel-source-path' commandline option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
And as I read into my own errorlog - I'm pretty sure I installed the kernel source tree correctly. I did an apt-get install kernel-source-2.2.20, then extracted the tarball in /usr/src, giving me /usr/src/kernel-source-2.2.20.

There's a makefile in there, but I don't want to rebuild my kernel, and I assume that's what it's for, aye?

Thanks as always.

Last edited by Seventh; 02-23-2004 at 01:36 PM.
 
Old 02-23-2004, 01:36 PM   #6
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
You just need to make sure you have either the kernel headers for your kernel (if you're running stock) or that usr/src/linux points to the directory for your current version (if you compiled your own).

--Rounan
 
Old 02-23-2004, 01:49 PM   #7
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Hehehe, well I figured out the issue with teh binary installer. Compiled my source and made a few symlinks, from info I found in This Thread.

Installer runs fine now, but it still fails. Even better, it gives me the first cut and dry error message I've seen all day.

Code:
#error This driver does not support pre-2.4 kernels!
Looks like I'm back to doing it the hard way. Thanks again bud.
 
Old 02-23-2004, 02:15 PM   #8
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Try the 4496 or earlier installer.

I'd recommend using nVidia's binaries, simply because i don't think they've released the development information that would let people write source. (as you apparently found out. )
Their proprietary linux drivers are quite good though.
 
Old 02-23-2004, 02:16 PM   #9
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Got it worked out.

Installed the kernel headers, but really all it wanted to see was kernel.h, and via the log I was able to brilliantly deduct (snicker) that it was looking in the wrong place.

Symlinking it gave me an error, but I just copied kernel.h to the folder the nvidia installer was looking for, the install worked and my XSession is up and running (though I have no desktop managers installed aside from the ugly default one)..

Anyhow, thanks for pointing out the binary, looking in their archive I was able to find one that was built to support my kernel.

Mucho appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 05:51 PM
xorg: Failed to load module... NullDevice23 Linux - Hardware 4 08-05-2006 09:01 AM
ver:10.2, after startx, (EE)Failed to load module ...\..\libglx.a catfox Mandriva 5 07-07-2005 10:40 AM
Failed to load the NVIDA kernal module magisbladius Slackware 9 04-14-2005 04:27 PM
X11 - failed to load module keyboard hnad Slackware 2 09-15-2004 05:12 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration