LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 07-25-2005, 12:28 AM   #1
GregAsche
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
totem-xine won't play video files


Alright, I'm running Ubuntu Hoary (stable) and I was using totem-xine to play my video files and everything was working fine, and all of a sudden, any file I play, except for .mpg/.mpeg, stops working. I get the error "Video codec 'XviD format' is not handled. You might need to install additional plugins to be able to play some types of movies" 'XviD format' changes depending on whatever I'm playing obviously.

I can play audio fine. As far as I know, I have all the correct codec packages installed, because everything was playing fine in totem, and these videos will play in other players (MPlayer), so I'm thinking I must have changed something to make totem stop recognizing that I have the required codecs, but I can't figure out for the life of me what it is. I've also tried uninstalling and reinstalling totem-xine and w32codecs. So, I'd love to get this working if anyone could kindly help me out, thanks in advance
 
Old 07-25-2005, 02:22 AM   #2
Zeistler
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 108

Rep: Reputation: 15
Xine has two components: xine-lib xine-ui

The xine-ui component is just a graphical interface. Xine-lib however is a backend library that all Xine-based video players use. I order for xine-lib to support win32 codecs is needs to be built that way from source. Some distros build it with win32 support some don't. Have you made an general update or something lately? If you're unlucky you may have ended up with a Xine-lib that doesn't support win32 codecs.

Do you have xine-ui installed? If you do try typing xine in console to run Xine's own interface just to make sure this is not a problem with Totem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Totem doesn't play any viedo files... cverr Linux - Software 6 11-10-2005 01:42 AM
xine won't play any video zoomzoom Linux - Software 1 10-29-2005 03:36 PM
Totem-Xine only plays the first few seconds of a video in Firefox, then stops DaneM Ubuntu 1 10-20-2005 06:49 AM
Xine Doesnt Play Any Video (no Demux Plugin) kromatic Linux - Software 8 11-25-2004 05:19 PM
Problems with WMV files in Mplayer/Xine/Totem DYNO Linux - Software 14 11-04-2004 06:00 AM


All times are GMT -5. The time now is 02:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration