LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-31-2004, 08:33 AM   #1
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Rep: Reputation: 0
Problems with WMV files in Mplayer/Xine/Totem


I installed Mplayer some time ago witht eh hope that I could watch WMVs. When I saw I needed codecs, I downloaded the essential package and installed them under /usr/lib/win32. Mplayer still didn't play them. I installed Xine, and it won't play them either.

Anyone know what the problem is? I have no idea.
 
Old 10-31-2004, 08:37 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Re: Problems with WMV files in Mplayer/Xine/Totem

Quote:
Originally posted by DYNO
Mplayer still didn't play them.


Could you post up the output when you try to play them? Or could you elaborate on the result of the effort?



Thanks!

Cool
 
Old 10-31-2004, 08:44 AM   #3
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
In Mplayer I click play, 1 second goes by, and it goes back to the Mplayer screen.

In Xine I get an error message:
-xine engine error-
There is no demuxer plugin available to handle 'home/---/Desktop/Stuff/---/---.wmv
This usually means that the file format was not recognized.
 
Old 10-31-2004, 08:44 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Oh I see

Can you run mplayer from the command line and post up the output:
mplayer -vo xv filename.wmv

Be sure you are in the directory where the file exists first.

Cool
 
Old 10-31-2004, 08:50 AM   #5
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
[---@ Stargate SG-1 #8]$ mplayer -vo xv Stargate SG1 - 801 & 802 New Order.wmv
[1] 4224
bash: 802: command not found
[---@ Stargate SG-1 #8]$ MPlayer 1.0pre3-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1467 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/---/.mplayer/config
Reading /home/---/.mplayer/codecs.conf: Can't open '/home/---/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
font: can't open file: /home/---/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/---/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Stargate.
File not found: 'Stargate'
Failed to open Stargate


Playing SG1.
File not found: 'SG1'
Failed to open SG1


Playing -.
Reading from stdin...

Is that what you wanted?
 
Old 10-31-2004, 08:50 AM   #6
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
did you install from source? If you did you will need to recompile with your /lib/win32 directory with all the codecs so it can find them. When you recompile it will automatically locate and use the codecs there. When you compile without that directory it won't compile in support for the codecs. When compiling use configure --help to see the options you have and to give you an idea of what codecs you really want.
 
Old 10-31-2004, 08:53 AM   #7
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
I'm still new to linux. How do I compile the directory?
 
Old 10-31-2004, 09:02 AM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Whoa, you might not need to worry about that... yet

Ok, for the filename, use 'auto complete' which is done by pressing TAB a couple of times after typing the first couple of characters in the first word of the title of the video.
mplayer -vo xv Star{TAB}{TAB}{TAB}

Should work.

Then post up the output, thanks!

Cool
 
Old 10-31-2004, 09:06 AM   #9
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
[---@ Stargate SG-1 #8]$ mplayer -vo xv Star
Stargate SG1 - 801 & 802 New Order.wmv Stargate SG1 - 806 - Avatar.wmv
Stargate SG1 - 803 - Lockdown.wmv Stargate SG-1 - 808 - Covenant.wmv
Stargate SG1 - 804 Zero Hour.wmv Stargate SG 1 - 809 - Sacrifices.wmv
Stargate SG1 - 805 - Icon.wmv
[---@ Stargate SG-1 #8]$ mplayer -vo xv Stargate\ SG
Stargate SG1 - 801 & 802 New Order.wmv Stargate SG1 - 806 - Avatar.wmv
Stargate SG1 - 803 - Lockdown.wmv Stargate SG-1 - 808 - Covenant.wmv
Stargate SG1 - 804 Zero Hour.wmv Stargate SG 1 - 809 - Sacrifices.wmv
Stargate SG1 - 805 - Icon.wmv
[---@ Stargate SG-1 #8]$ mplayer -vo xv Stargate\ SG
Stargate SG1 - 801 & 802 New Order.wmv Stargate SG1 - 806 - Avatar.wmv
Stargate SG1 - 803 - Lockdown.wmv Stargate SG-1 - 808 - Covenant.wmv
Stargate SG1 - 804 Zero Hour.wmv Stargate SG 1 - 809 - Sacrifices.wmv
Stargate SG1 - 805 - Icon.wmv
[---@ Stargate SG-1 #8]$ mplayer -vo xv Stargate\ SG
MPlayer 1.0pre3-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1468 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/---/.mplayer/config
Reading /home/---/.mplayer/codecs.conf: Can't open '/home/jared/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
font: can't open file: /home/---/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/----/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Stargate SG.
File not found: 'Stargate SG'
Failed to open Stargate SG


Exiting... (End of file)
 
Old 10-31-2004, 09:21 AM   #10
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64


I didn't realize you had more than 1 file... You have a few options, use quotes around the entire filename, case sensitive if you type it. Or, use the auto complete, but continue the next few characters to give it more to autocomplete after it finds the matching characters. Here's what I'd do:
mplayer -vo xv "Stargate SG1 - 801 & 802 New Order.wmv"

To keep it simple.

Cool
 
Old 10-31-2004, 10:49 AM   #11
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Or you could rename the file so it didn't have any spaces. It's the spaces that are confusing bash. Try using _ instead
 
Old 10-31-2004, 12:20 PM   #12
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MasterC


I didn't realize you had more than 1 file... You have a few options, use quotes around the entire filename, case sensitive if you type it. Or, use the auto complete, but continue the next few characters to give it more to autocomplete after it finds the matching characters. Here's what I'd do:
mplayer -vo xv "Stargate SG1 - 801 & 802 New Order.wmv"

To keep it simple.

Cool
I typed that and I got more errors.

[---@ Stargate SG-1 #8]$ mplayer -vo xv 'Stargate SG1 - 801 & 802 New Order.wmv'
MPlayer 1.0pre3-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1467 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/---/.mplayer/config
Reading /home/---/.mplayer/codecs.conf: Can't open '/home/---/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
font: can't open file: /home/---/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/---/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Stargate SG1 - 801 & 802 New Order.wmv.
Cache fill: 0.00% (0 bytes) LMLM4 Stream Format not found


Exiting... (End of file)
 
Old 11-01-2004, 08:59 AM   #13
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Looks to be a mpeg4 format, something about linuxmedialabs Looks like you are probably going to have recompile mplayer after installing all the codecs from http://mplayerhq.hu as was suggested earlier. Too bad distros ship broken mplayer's with their distros, it doesn't make sense. Who doesn't watch videos on their computers?

Anyway, good luck!

Cool
 
Old 11-02-2004, 10:58 PM   #14
DYNO
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10
Posts: 13

Original Poster
Rep: Reputation: 0
How do you recompile Mplayer?
 
Old 11-04-2004, 06:00 AM   #15
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
That's quite the bag of worms, but luckily for you it's been answered several times on the forums, run a search and the answer will appear.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make xine or mplayer play .wmv files kkempter Linux - Software 22 07-25-2006 11:03 AM
Xine & Totem have different behaviours. / Problems with *.wmv kloss Linux - Software 3 11-01-2005 10:13 AM
Playing WMV files with MPlayer or Xine dth1 Linux - Software 7 08-16-2005 05:18 AM
Cant Play wmv files on mplayer or xine irish rebel Linux - Software 1 10-22-2004 10:32 PM
help!! xine, mplayer, totem display problems shinacalypse Linux - Software 12 12-12-2003 07:21 AM


All times are GMT -5. The time now is 12:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration