LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-10-2003, 11:01 AM   #1
suriyamohan
Member
 
Registered: Mar 2003
Location: Coimbatore
Posts: 50

Rep: Reputation: 15
Thumbs up Error Installing ATK (Accessibility Toolkit)..


Hi,
I have to install ATK (Accessibility Toolkit), atk-1.2.0.
Following error occurs after executing "./configure" in shell prompt.

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

I have installed pkgconfig-0.15.0 and glib-2.2.2 in my system (Red Hat Linux 7.2, kernel 2.4.7-10). I confirmed this by executing the following command in shell prompt and the output is as follows.

[root@instec atk-1.2.0]# rpm -qa | grep glib
glibc-2.2.93-5
glibc-common-2.2.93-5
glib-1.2.10-8
glibc-devel-2.2.93-5
glib2-2.0.6-2
glibc-kernheaders-2.4-7.20

I also added the line "/usr/local/lib" in "/etc/ld.so.conf" and executed "/sbin/ldconfig -v" to ensure that "Pkgconfig" searches for glib surces at right path. But still the problem persists.

Even after installing glib version > 2.0 the error occurs. How to overcome the aforesaid error ?
 
Old 06-13-2003, 05:23 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530
If this is still a problem, did you try setting the LD_LIBRARY_PATH or PKG_CONFIG_PATH environment variable? Your rpm output still shows a 2.0.6 package. Try deinstalling it first if no apps depend on it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing xmms (glib..atk...) nadroj Linux - Newbie 6 04-12-2005 03:41 PM
problem installing atk fecker"ok Linux - Software 3 01-15-2005 12:11 AM
problem installing atk for ethereal toships Linux - Wireless Networking 2 02-26-2004 02:47 AM
ATK make error k4zau Linux - Software 0 02-11-2004 08:38 PM
Configuration error while running atk-1.2.0 package suriyamohan Linux - General 0 04-16-2003 01:49 AM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration