I have to install ATK (Accessibility Toolkit), atk-1.2.0.
Following error occurs after executing "./configure" in shell prompt.
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
I have installed pkgconfig-0.15.0 and glib-2.2.2 in my system (Red Hat Linux 7.2, kernel 2.4.7-10). I confirmed this by executing the following command in shell prompt and the output is as follows.
[root@instec atk-1.2.0]# rpm -qa | grep glib
I also added the line "/usr/local/lib" in "/etc/ld.so.conf" and executed "/sbin/ldconfig -v" to ensure that "Pkgconfig" searches for glib surces at right path. But still the problem persists.
Even after installing glib version > 2.0 the error occurs. How to overcome the aforesaid error ?