ok thanks for the input...
downloaded glib-2.6.4 and installed that. yes i read the readme for the 3 files i downloaded to install, but basically used ./configure make and make install for all of them.
in synaptic when i search for 'glib' it comes up with the related results, and libglib1.2 (1.2.10-9) is installed (also as glib1.2-dev) and also libglib2.0-0 (2.6.3-1) (and corresponding -data, -dev packages installed too).
when i try and compile gtk (gtk+-2.6.5) it gives this error (truncated) output at the end:
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found
configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
so from this i downloaded atk-1.9.0 and tried to compile and install it from source..
the error it provides is:
checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.6.4, but GLIB (2.6.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
i tried searching for glib-2.0.pc and i think i found it in the extracted folder of the glib tarball i downloaded.. i figured it wouldnt have been here though, maybe somewhere in /usr/ or some other folder. i tried exporting this variable to see if that would then help compile but it didnt work, i did something like
any help appreciated.. thanks again
also, when it checks for other required packages and says which are not met but needed, how come it doesnt say "packageName >= 1.0.3 & < 2.x.x" or something like this.. or am i not reading what it displayed earlier properly?
and. i like downloading source files and trying to get them to work rather than using synaptic, because i feel i learn more by doing it this way (still very new, i would say)... dunno if this is a good or bad thing.
i will now download the 1.2.x versions of glib and gtk+ that you suggested (from ftp://ftp.gtk.org/pub/gtk/v1.2/
) and try to see if this fixes it.