Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-10-2003, 10:01 AM   #1
Registered: Mar 2003
Location: Coimbatore
Posts: 50

Rep: Reputation: 15
Thumbs up Error Installing ATK (Accessibility Toolkit)..

I have to install ATK (Accessibility Toolkit), atk-1.2.0.
Following error occurs after executing "./configure" in shell prompt.

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from

I have installed pkgconfig-0.15.0 and glib-2.2.2 in my system (Red Hat Linux 7.2, kernel 2.4.7-10). I confirmed this by executing the following command in shell prompt and the output is as follows.

[root@instec atk-1.2.0]# rpm -qa | grep glib

I also added the line "/usr/local/lib" in "/etc/" and executed "/sbin/ldconfig -v" to ensure that "Pkgconfig" searches for glib surces at right path. But still the problem persists.

Even after installing glib version > 2.0 the error occurs. How to overcome the aforesaid error ?
Old 06-13-2003, 04:23 AM   #2
Registered: May 2001
Posts: 29,359
Blog Entries: 55

Rep: Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546
If this is still a problem, did you try setting the LD_LIBRARY_PATH or PKG_CONFIG_PATH environment variable? Your rpm output still shows a 2.0.6 package. Try deinstalling it first if no apps depend on it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
installing xmms (glib..atk...) nadroj Linux - Newbie 6 04-12-2005 02:41 PM
problem installing atk fecker"ok Linux - Software 3 01-14-2005 11:11 PM
problem installing atk for ethereal toships Linux - Wireless Networking 2 02-26-2004 01:47 AM
ATK make error k4zau Linux - Software 0 02-11-2004 07:38 PM
Configuration error while running atk-1.2.0 package suriyamohan Linux - General 0 04-16-2003 12:49 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration