LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-23-2012, 03:46 PM   #1
1linux
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Rep: Reputation: Disabled
X11 installation on suse


Hi,

Plz provide steps to install X11 package on suse linux 10 SP2.
Just to let you, as root when issued command "startx", it showed me mesg: No startx installed.

How do i know which H/W for dsplay is installed or which driver is avilable for me ?

Thanks
 
Old 02-23-2012, 04:32 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
x11 should have been installed at time of install
but the NOT FREE operating system SELS 10 ( SUSE Enterprise Linux Server 10) normally dose not have a gui
installing a gui on a server is a big security risk and normally not done .

also spell out your words and do not use "text speak"

"please" IS NOT spelled "plz"

if you intend on using the OLD , very old sels10 then PAY novell for the required license

or
install the FREE and current and up to date OpenSUSE 12.1
http://www.opensuse.org/en/
 
1 members found this post helpful.
Old 02-23-2012, 10:34 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
We are a bit in the dark here. Dunno what you have or how you got it.

If you do have real Suse 10 installed you could have never installed x11. As above a server generally doesn't need it. The installer gave a choice maybe depending on how you originally received it. I may still have those cd's someplace. I can't remember that exact install.

Not sure what the easy way to do it is. If you have yast and internet connection you may be able to add in stuff. Might be able to use cd to re-start in installer to add in stuff. May not even have yast.

You generally don't want to startx it in root either or be running in root for that matter.

If you don't care and just want to re-install a custom install then SuseStudio still offers a Suse 10 image that has basic X. You can modify it as you want. Not sure they still offer 10 on their site.

OpenSuse may be a choice also to replace what you have.

Last edited by jefro; 02-23-2012 at 10:45 PM.
 
Old 02-24-2012, 01:21 PM   #4
1linux
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
We are a bit in the dark here. Dunno what you have or how you got it.

If you do have real Suse 10 installed you could have never installed x11. As above a server generally doesn't need it. The installer gave a choice maybe depending on how you originally received it. I may still have those cd's someplace. I can't remember that exact install.

Not sure what the easy way to do it is. If you have yast and internet connection you may be able to add in stuff. Might be able to use cd to re-start in installer to add in stuff. May not even have yast.

You generally don't want to startx it in root either or be running in root for that matter.

If you don't care and just want to re-install a custom install then SuseStudio still offers a Suse 10 image that has basic X. You can modify it as you want. Not sure they still offer 10 on their site.

OpenSuse may be a choice also to replace what you have.
Hi

Actually I have two suse server and on both machine there is client application(signature pad) running which requires X11 configured.

Now, one server where this signature pad runs properly, shows me below output:
ps -ef | grep X11
root 2650 1 0 Feb22 ? 00:00:00 /usr/X11R6/bin/Xvfb :1 -screen 0 1152x900x8
root 20598 20246 0 13:16 pts/0 00:00:00 grep X11

But, on the server where we have problem, shows :
ps -ef | grep X11
root 1028 1000 0 13:17 pts/0 00:00:00 grep X11


So, I guess there is somthing need to be done on X11 side !!

Last edited by 1linux; 02-24-2012 at 01:23 PM.
 
Old 02-24-2012, 06:39 PM   #5
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Try this command maybe. sax2

A lot of ways to go here by the way.
 
Old 02-25-2012, 11:23 AM   #6
1linux
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
Try this command maybe. sax2

A lot of ways to go here by the way.
Here is the output:

# SAX2
-bash: SAX2: command not found
<hostname>:~ # startx
No startx installed

command -> man sax2 says "No manual entry"

Tried uppercase/lowercase both including -csh.

Last edited by 1linux; 02-25-2012 at 11:25 AM.
 
Old 02-28-2012, 08:55 AM   #7
1linux
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 1linux View Post
Here is the output:

# SAX2
-bash: SAX2: command not found
<hostname>:~ # startx
No startx installed

command -> man sax2 says "No manual entry"

Tried uppercase/lowercase both including -csh.
Can anybody help ????
 
Old 02-28-2012, 05:35 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Do you have any other way to update this? Yast may be there. May have to get rpm's too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg-x11-devel installation guler Linux - Newbie 6 01-09-2012 09:22 PM
xorg-x11-devel installation guler Linux - General 1 01-08-2012 06:06 PM
xorg-x11 installation problem in centOS mamunbabu2001 Linux - Newbie 1 04-08-2010 01:26 PM
mainly need help with installation of intel graphics drivers also x11 and more crare Linux - Software 13 01-13-2009 01:20 PM
X11.Org installation gianpiero1978 Linux - Newbie 2 01-16-2008 09:53 AM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration