LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-08-2012, 04:18 PM   #1
guler
LQ Newbie
 
Registered: Jan 2012
Location: Geneva
Posts: 4

Rep: Reputation: Disabled
xorg-x11-devel installation


Hello Everybody,

this is my first question :-)

How can I install xorg-x11-devel with rpm resource (I downloaded xorg-x11-devel-7.6-28.1.x86_64.rpm )? Any hint, suggestion?

Many Thanks!
Guler
 
Old 01-08-2012, 05:19 PM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,508

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Hello and welcome to LinuxQuestions!

What Linux OS are you running on? Usually you don't need to download a package manually. You should let the package manager download and install it for you (unless your system lacks an active internet connection). By the way, to install a downloaded package (from the command line) you can do
Code:
yum localinstall xorg-x11-devel-7.6-28.1.x86_64.rpm
if running a Red-Hat based distribution, or
Code:
zypper in xorg-x11-devel-7.6-28.1.x86_64.rpm
if running OpenSuSE.
Alternatively, if you have a desktop environment you can try to right click on the package icon and select "open with package manager" or something similar.
 
1 members found this post helpful.
Old 01-09-2012, 04:33 AM   #3
guler
LQ Newbie
 
Registered: Jan 2012
Location: Geneva
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hey,

Thanks! on Ubuntu, it gives error when download it by using package manager. I check with

rpm -q xorg-x11-devel-7.6-28.1.x86_64.rpm

seems not installed. When do this

rpm -ihv xorg-x11-devel-7.6-28.1.x86_64.rpm

gives the error below. May be, need another package to install with this one ..

however, this works

sudo apt-get install xorg-dev

In this case, I don t know which x11 lib files missed..
###
error: Failed dependencies:
/usr/bin/pkg-config is needed by xorg-x11-devel-7.6-28.1.x86_64
fontconfig-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
freetype2-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libXi6-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libpciaccess0-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libpixman-1-0-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig(compositeproto) >= 0.4 is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig(damageproto) >= 1.1 is needed by xorg-x11-devel-7.6-28.1.x86_64
...
 
Old 01-09-2012, 04:50 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
You should never install packages designed for one distribution on another. Open up Synaptic and search for Ubuntu's version of the package.

Adam
 
1 members found this post helpful.
Old 01-09-2012, 05:17 AM   #5
guler
LQ Newbie
 
Registered: Jan 2012
Location: Geneva
Posts: 4

Original Poster
Rep: Reputation: Disabled
SOLVED: org-x11-devel installation

Hello Everybody,

X11 lib is OK now, I found its Ubuntu versions by Synaptic.

Thanks colucix,Adam!
 
Old 01-09-2012, 05:28 AM   #6
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,508

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
As adamk75 said. The RPM packages are for distributions based on Red Hat or OpenSuSE. The RPM acronym itself stats for Red-Hat Package Manager. Ubuntu is based on Debian and uses DEB packages. apt-get is the right tool from the command line, synaptic is a package manager with an easy Graphical User Interface.

There are rare cases when you have to truly install a RPM on a Debian based system. In that case you need to convert the RPM to DEB using alien. Believe me, these are very uncommon situations.

Especially in case of development packages, like xorg-x11-devel, you must install the software specifically built for your distribution, hence
Code:
sudo apt-get install xorg-dev
was the right thing to do. Indeed, ubuntu provides the rpm package manager you've installed, but I think it's based on alien as well.

Lastly, here are some useful links:
https://help.ubuntu.com/community/RPM/AlienHowto
https://help.ubuntu.com/community/SynapticHowto
https://help.ubuntu.com/community/AptGet/Howto

Edit: I've just seen your latest post. Well done!!
 
Old 01-09-2012, 08:22 PM   #7
jcky
Member
 
Registered: Feb 2008
Location: China-Shanghai
Distribution: Rhel&Suse
Posts: 80

Rep: Reputation: 15
You can keep pc online & yum repos has been created.

Code:
yum install <package-name>

Quote:
Originally Posted by guler View Post
Hey,

Thanks! on Ubuntu, it gives error when download it by using package manager. I check with

rpm -q xorg-x11-devel-7.6-28.1.x86_64.rpm

seems not installed. When do this

rpm -ihv xorg-x11-devel-7.6-28.1.x86_64.rpm

gives the error below. May be, need another package to install with this one ..

however, this works

sudo apt-get install xorg-dev

In this case, I don t know which x11 lib files missed..
###
error: Failed dependencies:
/usr/bin/pkg-config is needed by xorg-x11-devel-7.6-28.1.x86_64
fontconfig-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
freetype2-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libXi6-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libpciaccess0-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
libpixman-1-0-devel is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig(compositeproto) >= 0.4 is needed by xorg-x11-devel-7.6-28.1.x86_64
pkgconfig(damageproto) >= 1.1 is needed by xorg-x11-devel-7.6-28.1.x86_64
...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmgrace installation failed, problem of X11-devel landaille Red Hat 0 10-19-2010 07:05 AM
xorg-x11-devel dependant on old version of xorg-x11-libs thetawaverider Linux - Software 1 11-09-2006 07:22 AM
xorg-x11-devel for Mandrake 10.1 Malibyte Mandriva 3 03-20-2005 03:31 AM
How to install xorg-x11-devel??? ginda Linux - Software 2 03-06-2005 03:37 AM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration