LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-22-2013, 05:08 AM   #1
thallium
Member
 
Registered: Oct 2012
Location: Austin, TX
Distribution: Ubuntu Server 12.04
Posts: 33

Rep: Reputation: Disabled
Wake on LAN - Tried everything!


I have a seemingly simple problem, I can't wake my server locally by a magic packet.

I have used the WireShark packet sniffer to make sure the magic packet is broadcast, the BIOS has WOL enabled, I have made sure wakeonlan service is running before the server powers down and I have made sure that WOL is enabled on eth0 with ethtool. I am just plain confused about how something this simple could not work.
 
Old 02-22-2013, 05:40 AM   #2
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Kubuntu
Posts: 1,189

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
When you power down this server, check the LED on ethernet card. Is it still light (of course assuming it light when server is running)? Can you show output of
Code:
sudo ethtool your_card
Quote:
I have made sure wakeonlan service is running
What is this?
 
Old 02-22-2013, 02:58 PM   #3
thallium
Member
 
Registered: Oct 2012
Location: Austin, TX
Distribution: Ubuntu Server 12.04
Posts: 33

Original Poster
Rep: Reputation: Disabled
The light is definitely on, glowing a nice orange.

I don't really get what the wakeonlan service is either or why it has to run, I just saw it on a tutorial about setting up wake on lan.

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: umbg
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes
 
Old 02-22-2013, 05:35 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 10,246

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
Not sure you even need a hard drive to wol. Bios has wol and maybe some "state" settings that should allow it. Usually but not always it requires an onboard nic. Add on nics may not have power or allow settings. Also the power supply has to maintain power. This may not be a fully OK test but nic lights should be on when system is off to help see if power is on nic. I guess some network devices inbetween may cause an issue. Blocking by some rule or even power issue.

I think g setting if for magic packet.

Also it could not be working from OEM if never tested by you before.

Last edited by jefro; 02-22-2013 at 05:37 PM.
 
Old 02-22-2013, 05:48 PM   #5
Basher52
Member
 
Registered: Mar 2004
Location: .SE
Distribution: Fedora
Posts: 230

Rep: Reputation: 8
I've had the same problem some time ago and after a lot of searching and since nothing worked, I just stopped.
Now when seeing this thread I started again and saw that "Wake-on d" is "bad" like D as for Disabled so I turned that to a "Wake-on g" like as for "Go"
but I still get the same result.
How do I know that my setting is to a 'g' is really working when I have shut the PC down?
 
Old 02-22-2013, 05:50 PM   #6
thallium
Member
 
Registered: Oct 2012
Location: Austin, TX
Distribution: Ubuntu Server 12.04
Posts: 33

Original Poster
Rep: Reputation: Disabled
I understand this should ideally take very little hardware besides the ethernet port and that's exactly what I thought when trying this out. The network adapter is onboard, not attached on a separate slot. I have also read that sometimes some pins may need to be connected for this to work on the motherboard, but I have not seen any confirmation of this.
 
Old 02-23-2013, 06:09 AM   #7
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Kubuntu
Posts: 1,189

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Yes, G is for magic packet and must be set. These pins are sometimes required for external (ex. PCI) network cards. Onboard does not need this, it is internally connected.

These computers are connected by switch or by router? Check if this entry in /etc/network/interfaces will help:
Code:
iface eth0 inet dhcp
    post-down /sbin/ethtool -s eth0 wol g
Of course eth0, dhcp is only example, use your own settings. But I don't known if this is even interpreted when "Network Manager" package is used. I have uninstalled it as found it is needless.
Also please answer which client tool are you using to wake. I am using "wakeonlan" from Ubuntu repository. And one more thing, if you have nVidia network card, there was an error in drivers which causes a reversing of MAC address (and in my system assigning a random one), you can check your MAC if is correct on MAC lookup site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I wake up a server in "standby" or "memory" mode using wake-on-lan? songweijia Linux - Server 2 03-03-2010 06:51 PM
Wake on Lan & Sleep on lan? ufmale Linux - Networking 1 06-25-2008 05:34 PM
wake on lan magic packet does not wake. albean Linux - Networking 1 06-30-2007 03:57 PM
wake on lan upload-3 Linux - Networking 2 06-12-2006 01:00 PM
wake on lan Stex Linux - Networking 7 06-25-2003 11:38 PM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration