LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 06:26 AM   #1
songweijia
LQ Newbie
 
Registered: Mar 2010
Posts: 2

Rep: Reputation: 0
Question Can I wake up a server in "standby" or "memory" mode using wake-on-lan?


I have a linux server running RHEL 5.1 x86 (the distribution doesn't matter since the same happens on SuSE.). Using wake-on-lan, I can wake up it if it was shutted down by "shutdown -h now" or "echo disk > /sys/power/state". Since waking up from such a state implys long start-up time, I'd rather it stays "standby" or "sleep in memory" by command "echo standby|memory > /sys/power/state". Although it can be waken by pressing power button, it does not respond to a wake-on-lan packet.

To make sure WOL works, I checked BIOS and it said: "Wake On Lan:enabled"; I issued command: 'ethtool eth0' and it said: Supports Wake-on: umbg
Wake-on: d
;

I'm confused. Does linux in "standby" or "memory" power mode can be waken up by wake-on-lan mechanism? If the answer is no, is there a way I can remotely wake it up?
 
Old 03-03-2010, 06:55 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Quote:
To make sure WOL works, I checked BIOS and it said: "Wake On Lan:enabled"; I issued command: 'ethtool eth0' and it said: Supports Wake-on: umbg
Wake-on: d
Wake-on: d means it is disabled, so enable it with
ethtool -s eth0 wol g

If you want the setting to stick after a reboot you could add the same line to your start up scripts.
Code:
echo "ETHTOOL_OPTS=\"wol g\"" >> /etc/sysconfig/network-scripts/ifcfg-eth0
I can't find evidence of linux supporting WoL from suspend to ram

You might also look at /etc/sysconfig/apm-scripts/ if that directory exists. You might be able to influence the suspend/hibernate procedure from there. These control Automatic Power Management on RH.
http://www.linuxtopia.org/online_boo...sconf-dir.html

Last edited by smoker; 03-03-2010 at 07:22 AM. Reason: more
 
Old 03-03-2010, 06:51 PM   #3
songweijia
LQ Newbie
 
Registered: Mar 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you for your reply, smoker. I'm sorry that "Wake-on: d", which should be "Wake-on: g", is a clerical mistake I made. I typed this line instead of copy-and-paste for I posted on windows.

"/etc/sysconfig/apm-scripts" directory does not exists on my linux.I'm still not sure if linux can be WoL from standby mode. Maybe I need to install suspend-scripts.

Quote:
Originally Posted by smoker View Post
Wake-on: d means it is disabled, so enable it with
ethtool -s eth0 wol g

If you want the setting to stick after a reboot you could add the same line to your start up scripts.
Code:
echo "ETHTOOL_OPTS=\"wol g\"" >> /etc/sysconfig/network-scripts/ifcfg-eth0
I can't find evidence of linux supporting WoL from suspend to ram

You might also look at /etc/sysconfig/apm-scripts/ if that directory exists. You might be able to influence the suspend/hibernate procedure from there. These control Automatic Power Management on RH.
http://www.linuxtopia.org/online_boo...sconf-dir.html
 
  


Reply

Tags
standby, wakeonlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: Make "Wake on LAN" (WOL) Work tredegar Linux - Networking 6 02-26-2011 07:23 AM
pm-hibernate & "wake up in 5 minutes"? jsteel Linux - Software 1 11-02-2009 04:00 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-06-2005 11:44 PM
monitor in supsend/sleep mode... can't "wake" it up schbond Linux - Hardware 2 09-15-2003 12:03 AM


All times are GMT -5. The time now is 03:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration