LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-30-2005, 08:03 PM   #1
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Rep: Reputation: 15
Question Sound card line-in


I cannot get my sound to work correctly. System sounds work. I can play mp3's with Kaboodle. My problem is that I cannot get line-in to work. I have a cassette player attached to my line in, and try to record using Audacity. Audacity gets no input and nothing is sent to the speakers. Any ideas as to what could be wrong?

I am a newbie, so if I need to post something from a file to give you more info, let me know.

Roger
 
Old 08-30-2005, 08:11 PM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
you prob need to set the device
 
Old 08-30-2005, 11:31 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
you have to enable it as a capture device in the mixer
 
Old 08-31-2005, 06:08 PM   #4
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Question

OK. I am a REAL newbie. I need instrucions as to how to do the above. I did open the mixer(I am running Debian and KDE), and checked the 'record' checkbox. But, this action did not solve my problem...
 
Old 08-31-2005, 06:15 PM   #5
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
run from a terminal:

kmix

under the input tab the first one on the left is your line-input. Make sure the green like is on and the volume is up...

KC
 
Old 08-31-2005, 06:19 PM   #6
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
Yes, but you prob need to tell it where to record from. Open the mixer and set the device
 
Old 08-31-2005, 06:33 PM   #7
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
kencaz,

OK. Green light is on. Sliders are up. Still no line in through to speakers.

bosewicht,

How do I 'set the device'?
 
Old 08-31-2005, 06:40 PM   #8
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
In Audacity:

File >> Preferences >> Audio I/O

Set Playback and Record...

Example Mine is set at:
/dev/dsp <--- (the first sound device)
2channel

KC
 
Old 08-31-2005, 07:12 PM   #9
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
OK. There is what looks like it should be a drop-down menu, but there are no items on the drop-down....
 
Old 08-31-2005, 07:31 PM   #10
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
do you have alsa installed? have you ran alsaconf?
 
Old 08-31-2005, 07:38 PM   #11
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Yes, to both queries.

btw thanks for taking the time to help. This has been very frustrating.
 
Old 08-31-2005, 07:45 PM   #12
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
post the output of typing
lspci
in a terminal
 
Old 08-31-2005, 07:58 PM   #13
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Here are the results of lspci:

roger@roger-basement:~$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:00:0c.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
0000:00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
 
Old 08-31-2005, 08:07 PM   #14
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
err, nevermind...answering a few sound questions and I had to look back. U said ur system sounds are working.
Try
whereis /dev/dsp
in a terminal. I think audacity needs /dev/dsp and i'm willing to bet it's not seeing yours. It's prob seeing /dev/dsp1, /dev/dsp2,etc.

In the mean time try typing
artsdsp audacity
in a terminal, which will launch audacity and hopefully use arts to record.

Maybe someone a little more knowledgable about audacity will see this post and have a better answer. I've never used it before
 
Old 08-31-2005, 08:16 PM   #15
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
whereis /dev/dsp returns
dsp:

artsdsp audacity returns
segmentation fault


It seems to me that the problem is outside of Audacity, since nothing from line-in gets to the speakers. Shouldn't merely having an input signal go through the card to the output? It does on my windows box.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-30-2005 11:35 PM
Changing primary sound card or disabling a sound card tfr Linux - Hardware 2 02-10-2005 08:33 AM
If you have a PCI sound card, should you disable the on-board sound card? jtp51 Linux - Newbie 1 10-06-2004 10:42 AM
Vortex 2 card - I have cd-audio and line-in sound, but none from applications. BrianHenderson Linux - Hardware 0 08-26-2004 12:47 AM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 02:10 AM


All times are GMT -5. The time now is 01:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration