LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-26-2004, 12:47 AM   #1
BrianHenderson
Member
 
Registered: Aug 2004
Location: Oregon, USA
Distribution: Ubuntu 6.06; Debian Testing
Posts: 40

Rep: Reputation: 15
Vortex 2 card - I have cd-audio and line-in sound, but none from applications.


<EDIT2>: My problem was that the EQ was set to minimum. I had gotten the other sliders up, but the EQ's didn't show in the plain volume control that I used at first </EDIT2>

I can play cd's with cd player and I can play sound through the line-in connector, but cannot hear any sound from applications on my Debian Sarge box with kernel 2.6.7-1-686 (installed with apt-get). What should I do to get sound fully functional?

lspci:

0000:00:00.0 Host bridge: Intel Corp. 440LX/EX - 82443LX/EX Host bridge (rev 03)0000:00:01.0 PCI bridge: Intel Corp. 440LX/EX - 82443LX/EX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
0000:00:0f.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 21)
0000:00:12.0 Unknown mass storage controller: Silicon Image, Inc. (formerly CMD Technology Inc) PCI0680 Ultra ATA-133 Host Controller (rev 02)
0000:00:14.0 Multimedia audio controller: Aureal Semiconductor Vortex 2 (rev fe)
0000:01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)

dmesg:

PCI: Found IRQ 11 for device 0000:00:14.0
Vortex: init.... <6>done.
NET: Registered protocol family 17
eth0: Setting full-duplex based on MII#1 link partner capability of 05e1.
lp0: using parport0 (interrupt-driven).
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
vortex: IRQ fifo error
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f4780(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present

Edit: I watched boot up today and saw that the card was mentioned earlier, so I'll paster the whole dmesg this time:

Linux version 2.6.7-1-686 (dilinger@toaster.hq.voxel.net) (gcc version 3.3.4 (Debian 1:3.3.4-2)) #1 Thu Jul 8 05:36:53 EDT 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
128MB LOWMEM available.
On node 0 totalpages: 32768
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 28672 pages, LIFO batch:7
HighMem zone: 0 pages, LIFO batch:1
DMI 2.0 present.
ACPI disabled because your bios is from 97 and too old
You can enable it with acpi=force
Built 1 zonelists
Kernel command line: root=/dev/hda3 ro
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 233.944 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x25
Memory: 122352k/131072k available (1515k kernel code, 8148k reserved, 659k data, 148k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 459.77 BogoMIPS
Security Scaffold v1.0.0 initialized
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 0080fbff 00000000 00000000 00000000
CPU: After vendor identify, caps: 0080fbff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After all inits, caps: 0080fbff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Pentium II (Klamath) stepping 04
Checking 'hlt' instruction... OK.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 233.0831 MHz.
..... host bus clock speed is 66.0808 MHz.
checking if image is initramfs...it isn't (ungzip failed); looks like an initrd
Freeing initrd memory: 4536k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb270, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
PnPBIOS: Scanning system for PnP BIOS support...
PnPBIOS: Found PnP BIOS installation structure at 0xc00fbf00
PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0xbf28, dseg 0xf0000
PnPBIOS: 13 nodes reported by PnP BIOS; 13 recorded by driver
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router PIIX/ICH [8086/7110] at 0000:00:07.0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
NET: Registered protocol family 8
NET: Registered protocol family 20
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4536 blocks [1 disk] into ram disk... done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 148k freed
vesafb: probe of vesafb0 failed with error -6
NET: Registered protocol family 1
SCSI subsystem initialized
libata version 1.02 loaded.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 0000:00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hdaio, hdbio
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdcio, hddio
hda: QUANTUM Bigfoot TX8.0AT, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: CD-RW BCE1610IM, ATAPI CD/DVD-ROM drive
hdd: PCRW404, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
SiI680: IDE controller at PCI slot 0000:00:12.0
PCI: Found IRQ 9 for device 0000:00:12.0
SiI680: chipset revision 2
SiI680: BASE CLOCK == 133
SiI680: 100% native mode on irq 9
ide2: MMIO-DMA , BIOS settings: hdeio, hdfio
ide3: MMIO-DMA , BIOS settings: hdgio, hdhio
hde: WDC WD600BB-00DKA0, ATA DISK drive
ide2 at 0xc8821080-0xc8821087,0xc882108a on irq 9
hda: max request size: 128KiB
hda: 15698592 sectors (8037 MB) w/69KiB Cache, CHS=15574/16/63, UDMA(33)
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3
hde: max request size: 64KiB
hde: 117231408 sectors (60022 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(100)
/dev/ide/host2/bus0/target0/lun0: p1 p2 < p5 p6 p7 > p3 p4
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Adding 489972k swap on /dev/hde3. Priority:-1 extents:1
EXT3 FS on hda3, internal journal
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
Capability LSM initialized
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hde7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hde4, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hde6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Linux agpgart interface v0.100 (c) Dave Jones
Linux Tulip driver version 1.1.13 (May 11, 2002)
PCI: Found IRQ 10 for device 0000:00:0f.0
tulip0: MII transceiver #1 config 1000 status 782d advertising 01e1.
eth0: Lite-On 82c168 PNIC rev 33 at 0x6500, 00:A0:CC:3E:91:A1, IRQ 10.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
agpgart: Detected an Intel 440LX Chipset.
agpgart: Maximum main memory to use for agp memory: 96M
agpgart: AGP aperture is 256M @ 0xe0000000
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x1001
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:07.2: Intel Corp. 82371AB/EB/MB PIIX4 USB
uhci_hcd 0000:00:07.2: irq 11, io base 00006400
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb 1-1: new low speed USB device using address 2
hub 1-0:1.0: over-current change on port 2
usbcore: registered new driver hiddev
input: USB HID v1.00 Mouse [Microsoft Microsoft Trackball Explorer￿] on usb-0000:00:07.2-1
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
ts: Compaq touchscreen protocol output
PCI: Found IRQ 11 for device 0000:00:14.0
Vortex: init.... <6>done.
NET: Registered protocol family 17
eth0: Setting full-duplex based on MII#1 link partner capability of 05e1.
Generic RTC Driver v1.07
lp0: using parport0 (interrupt-driven).
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
vortex: IRQ fifo error
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f4780(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present

Also, I have two (2) tabs in Volume control - SigmaTel STAC9704 [OSS Mixer] and au8830 [alsa Mixer], both of which seem to control volume.

Last edited by BrianHenderson; 08-27-2004 at 09:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card recognized but no sound on SoundMAX Integrated Digital Audio xzallion Fedora 46 12-13-2006 10:18 PM
help diagnosing sound card - vortex 2 todd_seiler Linux - Hardware 7 10-14-2004 08:36 PM
No sound when playing audio files on Fedora using command line players k_wjss Linux - Newbie 0 10-01-2004 01:32 AM
Sound problem with Aureal Vortex 2 gueggs Fedora 1 11-27-2003 11:59 PM
Sound problems with Aureal Vortex 1 freezinbutt Linux - Newbie 3 05-23-2002 11:09 AM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration