LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-17-2005, 10:06 PM   #1
hackerarchangel
Member
 
Registered: Jan 2005
Distribution: Suse 9.3
Posts: 119

Rep: Reputation: 15
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop


I copied the info requested per the Hardware post... I am running Suse 9.3 smp.
I am using a Gateway 7330 Gz and the sound card is listed as a Conexant in windows, however the only driver i found supports the modem section of the card, but not the sound. I really do not want to learn how to program the darn thing... so if anyone has any suggestions....

dmesg
nd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)
snd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)
snd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)
snd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)
snd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)
snd_intel8x0: Unknown parameter `joystick'
load_module: err 0xfffffffe (dont worry)

/sbin/lspci
0000:00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
0000:00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
0000:00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
0000:00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
0000:00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
0000:00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
0000:01:04.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
0000:01:05.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:01:06.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
0000:01:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

uname-r
2.6.11.4-21.9-smp

BTW, I do not have a joystick port at all.... use the usb type.
 
Old 12-30-2005, 09:52 AM   #2
mjweyland
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
Same Issue

I am having the same issue, different distro though. Were you able to get this resolved? What did you do to make this happen?
 
Old 12-30-2005, 04:42 PM   #3
hackerarchangel
Member
 
Registered: Jan 2005
Distribution: Suse 9.3
Posts: 119

Original Poster
Rep: Reputation: 15
I tried several solutions, none of which worked. However, I did doscivoer that my card had Conexant components on it and that no Conexant card is the same in every computer.
Also I was only able to get the modem half of the card to work. One thing to do is get the card info, and go to www.alsa-project.org and look up your card there. If it isn't listed, there probably is not a easily installed or easily found t\for that mnatter driver for it.
 
Old 12-30-2005, 11:35 PM   #4
mjweyland
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
Solved it

Believe it or not it was something pretty trivial. I was looking for a solution and came across this article.

desktoplinux.com/articles/AT9133949670.html
(I can't link, not enough posts)

I followed thier suggestions and it worked slick as a whislte.

I opend KMix, went to the switches tab and turned off External Amplifier.

HTH

I am using PCLinuxOS .93
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound issues on a Gateway 7330 with Suse 9.3 hackerarchangel Suse/Novell 2 10-24-2005 05:50 PM
No Sound card with Gateway Laptop and Mandrake 10.1 Official vchandu Linux - Laptop and Netbook 6 03-07-2005 08:28 PM
Issues with sound card card Scrob Linux - Newbie 1 02-17-2005 12:52 PM
Conexant combo modem/sound card kayndy Linux - Hardware 3 06-19-2004 03:11 PM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 02:10 AM


All times are GMT -5. The time now is 05:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration