LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-11-2005, 07:14 PM   #1
eckelly
LQ Newbie
 
Registered: Oct 2005
Location: Oklahoma
Posts: 12

Rep: Reputation: 0
Please tell me how to un mute alsa


I am brand new to Linux, I have fd2. I know basically nothing. But I have a stubborn streak a mile long. I will learn this one step at a time. spent two weekends trying to install this the way I need it and fix sound problem, but my sound card would not be seen. I bought a new sound card and it is recognized, but no sound. Many google searches and many posts I have reade tell me I should unmute logging in as root and using alsamixer.

I've done that, but I cannot figure how to turn off to on. Please someone give me detailed instructions on how to use the mixer to unmute?

Thank you so much. If I can get past this I can begin to work on the other stuff

Kelly
 
Old 10-11-2005, 07:35 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
since you are keen to learn...

man alsamixer

the instructions are very simple and plain - one of the simplest man pages around - but you have to read carefully.
This will be an excellent introduction to reading the technical documentation for you so I hope nobody gives you the spoiler.
 
Old 10-11-2005, 07:48 PM   #3
eckelly
LQ Newbie
 
Registered: Oct 2005
Location: Oklahoma
Posts: 12

Original Poster
Rep: Reputation: 0
Please, I am begging. I went thru the no help route for two weeks, all of both weekends were all about figuring out a new operation system, trying to install, reinstalling, making mistakes and fixing them . all my evenings spent on this thing. My kids hate me and think I have left them for a fight I can't seem to win.

Why is it that I can't get straightforward help with this one problem? I followed advice from site to site with the no card detected. I paid, yet again bought a new card and it was detected.I found alsa mixer. I tried to use it. I just want to know how to turn mute off. Make sound............Why is it that those that know linux don''t help those that don't?

Please I'm ok with being given a spoiler, please please please help me. I am begging
 
Old 10-11-2005, 08:06 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try running as root, system-config-sound, which should detect the soundcard. Once thats done run alsamixer to setup the default volume levels and then run "alsactl store".
 
Old 10-11-2005, 08:06 PM   #5
xgreen
Member
 
Registered: Aug 2003
Distribution: Slackware,Ubuntu
Posts: 389

Rep: Reputation: 30
open terminal
type "alsamixer"


note"M" to change state from "OFF" to "ON" & vice versa

remember to to alsactl store & put "alsactl restore" in rc.local or any startup script.

Last edited by xgreen; 10-12-2005 at 10:40 AM.
 
Old 10-11-2005, 08:23 PM   #6
eckelly
LQ Newbie
 
Registered: Oct 2005
Location: Oklahoma
Posts: 12

Original Poster
Rep: Reputation: 0
nazmin,

Thank you so very much! I am listening to my test cd music, it sucks, going to change it now. I am very grateful for your help.

Now I can tackle anything (mebbe) lol
 
Old 10-12-2005, 02:30 AM   #7
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
from the alsamixer man page
When a mixer control is turned off, M (mute) appears below the volume bar. When itís turned on, O in green appears instead. You can toggle the switch via m key.
See - I said you had to read carefully. This is in the fourth paragraph of the "Mixer Views" section.

Probably everyone thinks I'm mean now...
 
Old 10-12-2005, 06:51 PM   #8
eckelly
LQ Newbie
 
Registered: Oct 2005
Location: Oklahoma
Posts: 12

Original Poster
Rep: Reputation: 0
Simon, I appreciate your advice, and I don't think you are mean at all. I apologize for the way I reacted to your excellent and helpful post. I was tired and sooooooooooo close to having sound after so much work that I was overly frustrated and biachified.

Thanks
 
Old 10-13-2005, 04:49 AM   #9
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
... and I believe we have all experienced that one, and not seldom in conjunction with a sound issue...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa mute default on startup simple Linux - Newbie 7 06-02-2005 04:15 AM
mute sound alsa mixer - used to work TroelsSmit Linux - Newbie 4 09-02-2004 12:39 PM
ALSA 1.04 auto mute kam_kenneth Linux - Newbie 2 05-09-2004 01:06 AM
Slackware 9.1 & Alsa mute... craigdolson Slackware 4 12-05-2003 02:05 AM
ALSA always defaults to mute strophy Linux - Software 1 09-01-2003 06:32 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration