LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-02-2005, 02:03 AM   #1
simple
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Ubuntu 5.04
Posts: 89

Rep: Reputation: 15
alsa mute default on startup


any easy way to change alsa from muting at startup
 
Old 06-02-2005, 02:38 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
There is an alsa-save command, but I'm not positive that the command is actually alsa-save. If you type alsa and press tab to show the possible commands, you'll see it. All you'd have to do it set the volume where you want it and execute the save command.

I'll look it up and I get some. I have to use windows here.
 
Old 06-02-2005, 02:57 AM   #3
simple
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Ubuntu 5.04
Posts: 89

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by musicman_ace
There is an alsa-save command, but I'm not positive that the command is actually alsa-save. If you type alsa and press tab to show the possible commands, you'll see it. All you'd have to do it set the volume where you want it and execute the save command.

I'll look it up and I get some. I have to use windows here.
Code:
simple@elemental:~$ alsa
alsaconf   alsactl    alsalisp   alsamixer
any of those might be the one?
 
Old 06-02-2005, 03:15 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Use "alsactl store" to save your settings. You must also take a look at /etc/modprobe.conf (or similar) because some distros use this command to save settings on exit and restore them on reboot.
For more:
Code:
man alsactl
 
Old 06-02-2005, 03:37 AM   #5
simple
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Ubuntu 5.04
Posts: 89

Original Poster
Rep: Reputation: 15
hmm
Code:
alsactl store
makes volume control not use mute as default now, but it makes the "volume" track at mute, so i still need to turn that up. i had it all the way up whilst saving it, and i didn't add alsactl "restore" i'm guessing it would be to modules for startup..but it isn't muting PCM2 which is making me think it's restoring something because that is what was muted in the first place, so i don't know

Last edited by simple; 06-02-2005 at 03:41 AM.
 
Old 06-02-2005, 04:07 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
First run "alsamixer" to unmute and adjust the volume for all the channels you want and then run "alsactl store" to save these settings (in /etc//etc/asound.state). "alsactl restore" is used at system startup to restore your settings.
 
Old 06-02-2005, 04:07 AM   #7
ravee
Member
 
Registered: Jan 2005
Location: India
Distribution: Fedora Core 2
Posts: 83

Rep: Reputation: 15
I had some problem in getting sound configured right. And I used alsa modules. I have detailed all about it at
http://linuxhelp.blogspot.com/2004/1...ipset-isa.html

Hope this helps.
 
Old 06-02-2005, 04:15 AM   #8
simple
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Ubuntu 5.04
Posts: 89

Original Poster
Rep: Reputation: 15
with my soundchip it's lame, there's two choices "HDA Intel (Alsa Mixer)" and with that it uses "Realtek ALC880 (OSS Mixer)" i've had trouble getting sound with the alsa mixer, there is no sound. with gstreamer i have the default output sink asla and default source oss, i think the stupid intel chipset 915gv is confusing me too much :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please tell me how to un mute alsa eckelly Linux - Newbie 8 10-13-2005 04:49 AM
Mute KDE startup sound? prompt Linux - Software 2 06-04-2004 03:33 PM
aumix mute on startup wlochaty Linux - Software 2 05-17-2004 09:48 AM
ALSA 1.04 auto mute kam_kenneth Linux - Newbie 2 05-09-2004 01:06 AM
ALSA always defaults to mute strophy Linux - Software 1 09-01-2003 06:32 AM


All times are GMT -5. The time now is 04:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration