LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2016, 10:17 AM   #1
dwnthk
Member
 
Registered: May 2016
Location: Hong Kong
Distribution: Slackware 14.1 + Fluxbox
Posts: 65

Rep: Reputation: Disabled
I got a problem at disabling my touchpad.


Hi there,

I don't like my laptop touchpad because it is so sensitive, and the cursor is jumping around when I am typing.

So, I have a little command to disable it in startup script when the Fluxbox is starting up.
Quote:
xinput set-prop 13 "Device Enabled" 0
But the touchpad ID keeps changing between 12 and 13. So sometimes the xinput command doesn't work for me.

Just curious... is there another way to disable the touchpad?

Last edited by dwnthk; 05-13-2016 at 10:18 AM.
 
Old 05-13-2016, 10:29 AM   #2
cmgeo
LQ Newbie
 
Registered: Oct 2011
Location: India
Distribution: Win 7, Debian Squees, Slackware
Posts: 26

Rep: Reputation: Disabled
Hello,

You could always disable it through bios if you can find the right option. I have done the same because just like you i find it useless.

CMG
 
Old 05-13-2016, 10:39 AM   #3
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Don't use the id number, use the name.
 
Old 05-13-2016, 11:19 AM   #4
dwnthk
Member
 
Registered: May 2016
Location: Hong Kong
Distribution: Slackware 14.1 + Fluxbox
Posts: 65

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cmgeo View Post
Hello,

You could always disable it through bios if you can find the right option. I have done the same because just like you i find it useless.

CMG
Thx. But I do need the touchpad sometimes when I am off from the desk and using M$ Windows.
 
Old 05-13-2016, 11:20 AM   #5
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Or disable/blacklist the kernel synaptics module altogether.
 
Old 05-13-2016, 11:23 AM   #6
dwnthk
Member
 
Registered: May 2016
Location: Hong Kong
Distribution: Slackware 14.1 + Fluxbox
Posts: 65

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
Don't use the id number, use the name.
Oh... Never thought of using name. Thx dude.
 
Old 05-13-2016, 11:29 AM   #7
dwnthk
Member
 
Registered: May 2016
Location: Hong Kong
Distribution: Slackware 14.1 + Fluxbox
Posts: 65

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
Or disable/blacklist the kernel synaptics module altogether.
It is more flexible to put a little script in the startup, and the same script to the menu to enable/diable it manually.

Thx guys.
 
Old 05-13-2016, 11:31 AM   #8
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
FYI, when you blacklist the module you can still load/unload it with modprobe. Blacklisting merely stops it being loaded automatically.
 
Old 05-13-2016, 12:37 PM   #9
dwnthk
Member
 
Registered: May 2016
Location: Hong Kong
Distribution: Slackware 14.1 + Fluxbox
Posts: 65

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
FYI, when you blacklist the module you can still load/unload it with modprobe. Blacklisting merely stops it being loaded automatically.
Thanks. It is beyond my knowledge. I need to learn it first. I will google it later.

Thx again.
 
Old 05-13-2016, 01:47 PM   #10
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
If its a synaptic touch pad, there is a neat little app call flsynclient. It allows you to turn it off and on from your desktop, and change many if the settings for the touchpad. I run slackware 14.1/64, its in sbo.
 
Old 05-13-2016, 06:08 PM   #11
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
There even is some way to turn it off automatically when keyboard is in use, can't recall details right now, but I think it is described in Arch wiki.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling touchpad Steve900 Zenwalk 8 08-29-2012 08:12 PM
[SOLVED] How would i go about disabling the touchpad of my laptop Knightron Linux - Newbie 8 05-09-2012 03:38 PM
Disabling Touchpad Thorsson Slackware 10 08-07-2010 01:31 PM
disabling synaptics touchpad? dkw Linux - Laptop and Netbook 0 08-04-2004 06:27 PM
Disabling the touchpad? zzZoiDzz Linux - Hardware 21 01-30-2004 09:17 PM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration