LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-25-2004, 10:58 PM   #1
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Rep: Reputation: 15
Disabling the touchpad?


How can i get ONLY the mouse to work and not the mouse and the touchpad? Im using mandrake 9.2 and the touchpad is driving me nuts when i try to type. Any help would be appreciated. Thanks
 
Old 01-26-2004, 06:53 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Have you disabled the touchpad in the CMOS of your comp? That may
or may not help with Mandrake. You should also have a file that is either
/etc/X11/XF86Config or /etc/X11/XF86Config-4 or something to that effect.
I don't know anything about Mandrake, but that file in Slack has the configuration
for the input devices such as mouse, keyboard, and monitor. I should think you
can disable the entry in there for your touchpad by commenting it out, which means
to put a hash mark # in front of the relative lines.

If you have that file and need help, just post the contents here and I think someone
can help you.

edit: Look at the first link at the bottom of this page. I thought this sounded familiar.
The post should show you what you're looking for as far as that file is concerned.
http://www.linuxquestions.org/questi...hreadid=138376

Last edited by Bruce Hill; 01-26-2004 at 06:56 AM.
 
Old 01-29-2004, 09:38 PM   #3
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
ok so heres what is in my xf86config-4 file.

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

it sees both the usb and the touchpad so should i just put pound signs in front of everyline for the psaux mouse? Im very very new to linux so please be as thourough as possible in your replies.

Another question, is it possible to enable and disable devices such as the mouse and touchpad at will without rebooting linux? The only reason i want to disable this touchpad is because is madness trying to type with it enabled.
 
Old 01-29-2004, 10:17 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by zzZoiDzz
ok so heres what is in my xf86config-4 file.

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

it sees both the usb and the touchpad so should i just put pound signs in front of everyline for the psaux mouse? Im very very new to linux so please be as thourough as possible in your replies.

Another question, is it possible to enable and disable devices such as the mouse and touchpad at will without rebooting linux? The only reason i want to disable this touchpad is because is madness trying to type with it enabled.
You are still better off disabling the touchpad through your BIOS (unless you want to use it from time to time). That way the OS won't even detect it.
I feel the same way about a touchpad. First thing I do when I use a lappy is disable that thing and plug in a real mouse.

Comment it out like this
Code:
#Section "InputDevice"
# Identifier "Mouse2"
# Driver "mouse"
# Option "Protocol" "PS/2"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"
#EndSection
I'm not certain how Mandrake works. It seems the more I try to help Mandrake users with problems, the more confused I get.
Mandy does some things different than the other three Linux distros I've used. So, let me tell you how we would do it in Slack.

First, edit the file (as super user - su to root) in a text editor (emacs, pico, nano, vi, whatever) or from command line interface. Then save the file.
Next press Ctrl + Alt + Backspace to shutdown your X-server and go to command line. Then type startx to start the X-server again, and it's a done deal.

Last edited by Bruce Hill; 01-30-2004 at 03:44 AM.
 
Old 01-29-2004, 11:10 PM   #5
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
hey thanks man
 
Old 01-29-2004, 11:22 PM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by zzZoiDzz
hey thanks man
So, did that work? It's always good to post back and tell the community what you did that fixed your problem. That way someone may search and find an answer without ever having to post. There are many people who browse these boards for answers that do just that - they never, or hardly ever, post a thread of their own.

And by all means, click on that affero button http://svcs.affero.net/rm.php?r=Chin...813#post729813
 
Old 01-30-2004, 12:55 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You should also look at Aussie's post #7 in this thread ->
http://www.linuxquestions.org/questi...989#post729989
and possibly follow it, as I will, to learn more.
 
Old 01-30-2004, 01:02 AM   #8
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
i cant disable my touchpad apparently with this presario2100. The only option is "both" and "auto". The bios was very limited to say the least. Im going to comment out that section of the config file reboot and let you know.
 
Old 01-30-2004, 01:23 AM   #9
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
Ok the only text editor i could get to work was vi. Also when i press Ctrl + Alt + Backspace my KDE session simply restarts, it doesnt goto command prompt. I thought there was a command prompt only selection from the boot menu but i guess not. I tried "failsafe" and that took me to a command prompt where my keyboard didnt work. I tried editing the file while KDE is running but everytime i press shift and 3 for the # sign it simply jumps up 4 or 5 lines. I have no idea why this is. I cant save the file reguardless until i figure out how to get to the command prompt without my X session running correct?
 
Old 01-30-2004, 01:30 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
In KDE you have a little icon that looks like a monitor with a shell overlay. That's called a konsole.
Use that, login as root, and then edit the file with either pico or nano. I don't know Mandy but
you probably have one of those two. Just do
# pico /etc/X11/XF86Config-4
or whatever the correct path and filename are under your distro. If pico isn't there
then try nano.

Last edited by Bruce Hill; 01-30-2004 at 01:31 AM.
 
Old 01-30-2004, 01:49 AM   #11
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
even if i get it edited with a text editor wont it say that it cant save the file because its in use? Nano and pico are bad commands or not with this distro. vi works fine. I have a Unix book in front of me with all the commands for pico and nano so if i can get them started im good. You typed "# pico..." does the pound sign make a difference? Pico doesnt need to be run from a certain directory does it?
 
Old 01-30-2004, 01:58 AM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
No it will not say you can't save the file because it's in use. This is NOT Windoze. Praise God!

Once you get into a terminal, pico or nano would be the command to run that application. The hash mark just indicates that you should do it as root - you don't actually type the hash mark.

The hash mark # indicates you are running as root. The dollar sign $ indicates you are running as a normal user. You cannot save that file as a normal user, unless you've messed with the permissions of that folder, which you shouldn't do. A normal user only has write priviledges to /home/<username> where your username is between < and >. If you are reading a book about Unix, read about commands. Keep reading that book. Send me one - we can't buy anything like that in English were I live.

If you don't have pico or nano, you must have some editor. Look in the KDE menu under Editors - there will be some listed there. But you will have to run as root to save the file. I've never run Mandy, so you'll have to do some searching on your own.

From cli (command line interface) you can just type pico and it will open; you type what I posted without the hash mark, but logged in as root so that you have a hash mark # and then you'll have privildges to save the file. If you do that same command logged in as a normal user, with a $, then you'll be told as you try to exit and save the file that you don't have permissions.

Last edited by Bruce Hill; 01-30-2004 at 02:01 AM.
 
Old 01-30-2004, 02:10 AM   #13
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
All righty! i like how i can just type the name of a program from the command line and it finds it. I used "kedit /etc/X11/XF86Config-4" and it cranked it up and i could even edit with a nice X window interface using mouse. Here is the book im using

http://www.amazon.com/exec/obidos/AS...747522-9356911

I believe thats probably a little below what you know already. It simply lists all the unix commands that you can use at a command prompt. I feel like i have to become a human compiler to use linux, but i still like it thus far. I'm gonna restart KDE now and see if it works.
 
Old 01-30-2004, 02:23 AM   #14
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
Ok i edited the document like you said and when i tried to restart with the hot keys it simply give and error message about line 58 needing an identifier and wouldnt start X. I have to edit the file again with vi at the command prompt and then typed startx and KDE started back up ok then. whew! Im glad you told me that startX command or i would have freaked. So i guess we edited the file wrong?
 
Old 01-30-2004, 02:37 AM   #15
zzZoiDzz
Member
 
Registered: Jan 2004
Location: Savannah
Distribution: mandrake 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
I even tried commenting out the "section" and endsection lines but that didnt work either. Hrm. It said undefined device or something to that nature. If you need the exact details i can get the error message.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 03:15 PM
disabling synaptics touchpad on hp ze4500 ouzo Suse/Novell 0 03-12-2005 02:02 PM
Disabling Synaptics Touchpad, Enabling PS/2 Mouse alex_denner Linux - Laptop and Netbook 2 11-28-2004 04:37 PM
disabling synaptics touchpad? dkw Linux - Laptop and Netbook 0 08-04-2004 05:27 PM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 02:19 PM


All times are GMT -5. The time now is 07:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration