LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices

Reply
 
Search this Thread
Old 07-24-2012, 08:19 AM   #1
Steve900
Member
 
Registered: Feb 2007
Location: Paris
Distribution: Slackware 13.1
Posts: 32

Rep: Reputation: 0
Disabling touchpad


I do NOT want the touchpad, ever. Apart from taking the PC apart and physically removing the connection, and that remains a possibility, what can I do? I have tried commenting out all the lines in /etc/X11/xorg.conf but nothing happens.

Latest Zenwalk in an Asus b43f.
 
Old 07-25-2012, 06:17 AM   #2
dru8274
Member
 
Registered: Oct 2011
Location: New Zealand
Distribution: Debian
Posts: 105

Rep: Reputation: 36
I use the xinput method described here... http://blog.yjl.im/2010/12/using-xin...ard-mouse.html
 
Old 07-26-2012, 09:31 AM   #3
Steve900
Member
 
Registered: Feb 2007
Location: Paris
Distribution: Slackware 13.1
Posts: 32

Original Poster
Rep: Reputation: 0
steve[~]$ xinput list
Ž Virtual core pointer id=2 [master pointer (3)]
Žœ † Virtual core XTEST pointer id=4 [slave pointer (2)]
Žœ † Mouse1 id=6 [slave pointer (2)]
Ž Virtual core keyboard id=3 [master keyboard (2)]
† Virtual core XTEST keyboard id=5 [slave keyboard (3)]
† Keyboard1 id=7 [slave keyboard (3)]
steve[~]$ xinput list-props Mouse1
Device 'Mouse1':
Device Enabled (115): 1
Coordinate Transformation Matrix (117): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (225): 0
Device Accel Constant Deceleration (226): 1.000000
Device Accel Adaptive Deceleration (227): 1.000000
Device Accel Velocity Scaling (228): 10.000000
steve[~]$ xinput list-props Virtual core XTEST keyboard
unable to find device Virtual
unable to find device core
unable to find device XTEST
unable to find device keyboard
steve[~]$ Virtual core XTEST keyboard

Does not show a touchpad? But shows info mouse.

Last edited by Steve900; 07-26-2012 at 09:32 AM.
 
Old 07-27-2012, 02:53 AM   #4
dru8274
Member
 
Registered: Oct 2011
Location: New Zealand
Distribution: Debian
Posts: 105

Rep: Reputation: 36
My netbook has a Synaptics touchpad, the most common type. Whereas upon checking, your Asus b43f laptop has an Elantech touchpad, one that I've not heard of before.
Quote:
I do NOT want the touchpad, ever. Apart from taking the PC apart and physically removing the connection, and that remains a possibility,
Yes, I agree entirely. Whenever I reinstall, disabling that touchpad is the first order of business. But the methods I've used may not work on your Elantech touchpad device. But searching on Google with "linux elantech touchpad ~disable" suggests that others have had the same problem too, with solutions.

I use Debian, and gpointing-device-settings is a settings gui for pointing devices, that might work with Elantech. Not sure if that package is in your repos though.
Quote:
Does not show a touchpad? But shows info mouse.
Did you have a mouse plugged in? From what little I've read about Elantech, they've found a hacky way to make it work with the Synaptics drivers. But they say it doesn't always show up in 'xinput list' as Elantech. Sometimes as Synaptics, or sometimes as a mouse instead.
 
Old 08-28-2012, 03:21 PM   #5
Steve900
Member
 
Registered: Feb 2007
Location: Paris
Distribution: Slackware 13.1
Posts: 32

Original Poster
Rep: Reputation: 0
A IT guy tried a few things (I cannot say what) but gave up due to lack of time and disconnected the touchpad physically. It certainly works that way, or doesn't work ....
 
Old 08-28-2012, 03:51 PM   #6
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 257

Rep: Reputation: 58
For future reference, what sometimes works is if the pad is seen by the synaptic client. You can tell with

synclient -l

If it lists some stuff, the touchpad is seen by by the synaptics driver. (ELantech should work with the synaptic, as should Sentelic--both becoming more popular with some of the ultra books, and fortunately, some of the kernel folks are adding support.)

Now, if this particular mouse works with synaptics,


https://wiki.archlinux.org/index.php...ouse_detection

might work.

The one that works for me, to disable while typing (but doesn't disable entirely)

syndaemon -t -k -i 2 -d &

Last edited by scottro11; 08-28-2012 at 03:53 PM.
 
Old 08-28-2012, 06:27 PM   #7
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by Steve900 View Post
I do NOT want the touchpad, ever.
Just curious... why?

jlinkels
 
Old 08-29-2012, 03:36 PM   #8
Steve900
Member
 
Registered: Feb 2007
Location: Paris
Distribution: Slackware 13.1
Posts: 32

Original Poster
Rep: Reputation: 0
I prefer to use a mouse and the pb is that I touch the touchpad accidentally while typing. Very annoying. I have tried touchpads but I cannot get used to this as a way of using the PC.
 
Old 08-29-2012, 07:12 PM   #9
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Ah ok. Personal preferences.

jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How would i go about disabling the touchpad of my laptop Knightron Linux - Newbie 8 05-09-2012 02:38 PM
Disabling Touchpad Thorsson Slackware 10 08-07-2010 12:31 PM
Disabling Touchpad while typing. nardz Linux - Desktop 4 01-24-2008 04:33 AM
disabling synaptics touchpad? dkw Linux - Laptop and Netbook 0 08-04-2004 05:27 PM
Disabling the touchpad? zzZoiDzz Linux - Hardware 21 01-30-2004 08:17 PM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration