LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-04-2008, 11:02 AM   #1
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Rep: Reputation: 15
Unhappy how to mute speaker when headphone is plugged in (on kubuntu) (solved)


My headphone never mutes my speaker. I have tried my best to solve it, but failed. This problem has become my headache.

I use kubuntu 7.10. I tried to use kmix to turn off my speaker, but in my kmix there is only two selections : input and output. And in the output, I can only control master, pcm, capture, much different from what was showed in the handbook. the bottom showed HDA NVidia. I also try alsamixer, but that didn't make any sense.

I also tried to search an answer from the internet. It seemed few people solved it. And the way was too complicated for me to understand.
I really really need your help!

some information I thought might be useful:

00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)


│ Card: HDA NVidia │
│ Chip: Conexant ID 5051

Last edited by sunnior; 04-18-2008 at 08:32 AM.
 
Old 04-05-2008, 09:49 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Hi sunnior, Welcome to lq. Is this a laptop, if so, what make/model?
Good luck. ;-)
 
Old 04-06-2008, 01:02 AM   #3
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Peacedog View Post
Hi sunnior, Welcome to lq. Is this a laptop, if so, what make/model?
Good luck. ;-)
Yes, it's a laptop. I use HP presario V3700 with AMD Turion 64X2 TL-58.
 
Old 04-06-2008, 02:29 AM   #4
mrfarad
LQ Newbie
 
Registered: Mar 2008
Posts: 9

Rep: Reputation: 0
On most electronics, portable radios and the like, the speaker mute is actually performed by a set of switch contacts in the headphone jack. I'm not aware that a laptop would be any different. Are you sure that the jack is not defective. Have you tried booting another OS to see if the mute works correctly with something other than Ubuntu?
 
Old 04-06-2008, 01:57 PM   #5
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
What is the output from the following?
Code:
# aplay -l
Good luck. ;-)
 
Old 04-07-2008, 08:49 AM   #6
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Peacedog View Post
What is the output from the following?
Code:
# aplay -l
Good luck. ;-)
By typing aplay -l I got:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 04-07-2008, 08:58 AM   #7
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mrfarad View Post
On most electronics, portable radios and the like, the speaker mute is actually performed by a set of switch contacts in the headphone jack. I'm not aware that a laptop would be any different. Are you sure that the jack is not defective. Have you tried booting another OS to see if the mute works correctly with something other than Ubuntu?
Just now, I have tried on fedora 8 for 64-bits(It really took me some time), but I didn't see any difference.I'm sure the jack works well in this new laptop.

After all, thank you for this good suggestion.
 
Old 04-07-2008, 10:17 AM   #8
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
That didn't give me what I was looking for. Try this please.
Code:
cat /proc/asound/card0/codec\#*
Good luck. ;-)
 
Old 04-08-2008, 12:25 AM   #9
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Codec: Conexant ID 5051
Address: 0
Vendor Id: 0x14f15051
Subsystem Id: 0x103c30d6
Revision Id: 0x100000
Default PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
Node 0x10 [Audio Output] wcaps 0xc1d: Stereo Amp-Out
Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=0
Amp-Out vals: [0x3a 0x39]
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Node 0x11 [Audio Output] wcaps 0xc1d: Stereo Amp-Out
Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=0
Amp-Out vals: [0x4a 0x4a]
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Node 0x12 [Audio Output] wcaps 0x211: Stereo Digital
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x5]: PCM AC3
Node 0x13 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=0
Amp-Out vals: [0x00]
Node 0x14 [Audio Input] wcaps 0x100d1b: Stereo Amp-In
Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=0
Amp-In vals: [0x06 0x06] [0x34 0x34]
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Connection: 2
0x1d 0x17*
Node 0x15 [Audio Input] wcaps 0x100d1b: Stereo Amp-In
Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=0
Amp-In vals: [0x4a 0x4a]
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Connection: 1
0x18
Node 0x16 [Pin Complex] wcaps 0x400581: Stereo
Pincap 0x081c: OUT HP Detect
Pin Default 0x01214030: [Jack] HP Out at Ext Rear
Conn = 1/8, Color = Green
Pin-ctls: 0xc0: OUT HP
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x17 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x081224: IN Detect
Pin Default 0x01a19020: [Jack] Mic at Ext Rear
Conn = 1/8, Color = Pink
Pin-ctls: 0x24: IN
Power: 0x0
Node 0x18 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x081224: IN Detect
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Node 0x19 [Pin Complex] wcaps 0x400581: Stereo
Pincap 0x0814: OUT Detect
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Connection: 2
0x10 0x11*
Node 0x1a [Pin Complex] wcaps 0x400501: Stereo
Pincap 0x0810010: OUT EAPD
Pin Default 0x92170110: [Fixed] Speaker at Int Front
Conn = Analog, Color = Unknown
Pin-ctls: 0x40: OUT
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x1b [Pin Complex] wcaps 0x400500: Mono
Pincap 0x0810010: OUT EAPD
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x40: OUT
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x1c [Pin Complex] wcaps 0x400701: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Connection: 1
0x12
Node 0x1d [Pin Complex] wcaps 0x40040b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x0820: IN
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Node 0x1e [Vendor Defined Widget] wcaps 0xf00000: Mono
Wish it will be helpful, though I can't understand at all.

Last edited by sunnior; 04-08-2008 at 12:26 AM.
 
Old 04-08-2008, 08:46 AM   #10
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Try adding one or the other of the following lines to your /etc/modprobe.d/alsa-base.
Code:
options snd-hda-intel model=laptop
options snd-hda-intel model=laptop-hp
Good luck. ;-)
 
Old 04-09-2008, 06:34 AM   #11
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
I tried both, added one each time to the end of the file /etc/modprobe.d/alsa-base, and then reboot. But it didn't work, strange thing....

This is a segment of the code:

Quote:
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd-hda-intel model=laptop


Last edited by sunnior; 04-09-2008 at 06:35 AM.
 
Old 04-09-2008, 06:53 AM   #12
webaware
Member
 
Registered: Nov 2007
Location: Australia
Distribution: Fedora FC-9 x86-64+i686,CentOS 5.2 i686
Posts: 58

Rep: Reputation: 15
I'm on Fedora 8 / x86-64 on an ASUS laptop, GNOME desktop, and what I find is that I have to enable the headphones on the Switches tab of the Volume Control applet, then mute the speakers. Voila - sound through headphone connection but not speakers.
 
Old 04-09-2008, 08:04 AM   #13
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Once you've got the module options in place you may have to adjust some things in your mixer also with proper module options you should have more channels available and recognized by your mixer. There is a thread here that may help.
Good luck. ;-)
 
Old 04-10-2008, 05:40 AM   #14
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Well, I must say I couldn't solve this problem now. I'll go and learn more, and then come back to have a try. I think this problem won't constitute solved to me unless I understand why is in this way.

Thank you "peacedog", sincerely.
 
Old 04-10-2008, 08:29 AM   #15
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Did the module options give you more channels in your mixer? If so, look for Jack sense, or Headphone Jack sense.
Good luck. ;-)
 
  


Reply

Tags
headphone, speaker


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound still on speaker when headphone is plugged in krisyok Linux - Newbie 12 04-12-2007 04:41 AM
Sound does not mute when headphones plugged in damiendusha Linux - Hardware 4 01-06-2007 07:21 AM
Headphone plugged in, sound still comes out of speakers tbraun Linux - Hardware 3 01-18-2005 04:36 PM
Mute PC speaker objorkum Linux - Software 2 01-16-2004 01:27 PM
mute pc speaker in redhat 8 without root access brian0918 Linux - Hardware 2 06-03-2003 11:22 AM


All times are GMT -5. The time now is 11:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration