LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-10-2008, 02:42 PM   #16
dbmacartney
Member
 
Registered: Mar 2007
Location: London, UK
Distribution: Debian, Red Hat Enterprise, Fedora
Posts: 70

Rep: Reputation: 15

I had this same problem when I was using a HP compaq laptop. I found a setting in the volume control applet, that by ticking it, it detects if the headphones are plugged in, it turns the speakers off. if there are no headphones then the speakers are on.

if I remove the tick then sound plays through both. I cant recall the exact wording for the tick box as I'm using a modified verson of alsa at the moment. but I just ticked a few things when I had my head phones in and figured out which one it was that was doing it. If this is the cause of your headaches i'm sure when you find it you will do what I did. when you find it you'll think to yourself "OOHHHH I guess that makes sense..... somehow. ???" I am still shocked over how long it took me to fix it. I think it took me at least a month.
 
Old 04-10-2008, 10:35 PM   #17
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Peacedog View Post
Did the module options give you more channels in your mixer? If so, look for Jack sense, or Headphone Jack sense.
Good luck. ;-)
I didn't get more channels, that's really frustrating.
 
Old 04-10-2008, 10:43 PM   #18
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dbmacartney View Post
I had this same problem when I was using a HP compaq laptop. I found a setting in the volume control applet, that by ticking it, it detects if the headphones are plugged in, it turns the speakers off.
That's really the problem, I have spent two month in finding the exactly setting.

Last edited by sunnior; 04-10-2008 at 10:45 PM.
 
Old 04-18-2008, 07:31 AM   #19
sunnior
Member
 
Registered: Feb 2008
Distribution: ubuntu
Posts: 43

Original Poster
Rep: Reputation: 15
I'm on the new ubuntu (8.04) now. This problem is perfectly solved on this new system.
 
Old 04-20-2008, 02:26 PM   #20
travioso
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
maybe this will work

i'm using a compaq tc4200, kubuntu 7.10, and lspci shows my card as
Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

all i did to fix the prob was load get the package alsamixergui, and there is a setting for head jack sense.. turn it on and presto..
 
  


Reply

Tags
headphone, speaker


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound still on speaker when headphone is plugged in krisyok Linux - Newbie 12 04-12-2007 03:41 AM
Sound does not mute when headphones plugged in damiendusha Linux - Hardware 4 01-06-2007 06:21 AM
Headphone plugged in, sound still comes out of speakers tbraun Linux - Hardware 3 01-18-2005 03:36 PM
Mute PC speaker objorkum Linux - Software 2 01-16-2004 12:27 PM
mute pc speaker in redhat 8 without root access brian0918 Linux - Hardware 2 06-03-2003 10:22 AM


All times are GMT -5. The time now is 05:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration