LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to mute speaker when headphone is plugged in (on kubuntu) (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-mute-speaker-when-headphone-is-plugged-in-on-kubuntu-633005/)

sunnior 04-04-2008 10:02 AM

how to mute speaker when headphone is plugged in (on kubuntu) (solved)
 
My headphone never mutes my speaker. I have tried my best to solve it, but failed. This problem has become my headache.:(

I use kubuntu 7.10. I tried to use kmix to turn off my speaker, but in my kmix there is only two selections : input and output. And in the output, I can only control master, pcm, capture, much different from what was showed in the handbook.:scratch: the bottom showed HDA NVidia. I also try alsamixer, but that didn't make any sense.

I also tried to search an answer from the internet. It seemed few people solved it. And the way was too complicated for me to understand.
I really really need your help!

some information I thought might be useful:

00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)


│ Card: HDA NVidia │
│ Chip: Conexant ID 5051

Peacedog 04-05-2008 08:49 PM

Hi sunnior, Welcome to lq. Is this a laptop, if so, what make/model?
Good luck. ;-)

sunnior 04-06-2008 12:02 AM

Quote:

Originally Posted by Peacedog (Post 3112135)
Hi sunnior, Welcome to lq. Is this a laptop, if so, what make/model?
Good luck. ;-)

Yes, it's a laptop. I use HP presario V3700 with AMD Turion 64X2 TL-58.

mrfarad 04-06-2008 01:29 AM

On most electronics, portable radios and the like, the speaker mute is actually performed by a set of switch contacts in the headphone jack. I'm not aware that a laptop would be any different. Are you sure that the jack is not defective. Have you tried booting another OS to see if the mute works correctly with something other than Ubuntu?

Peacedog 04-06-2008 12:57 PM

What is the output from the following?
Code:

# aplay -l
Good luck. ;-)

sunnior 04-07-2008 07:49 AM

Quote:

Originally Posted by Peacedog (Post 3112674)
What is the output from the following?
Code:

# aplay -l
Good luck. ;-)

By typing aplay -l I got:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0

sunnior 04-07-2008 07:58 AM

Quote:

Originally Posted by mrfarad (Post 3112258)
On most electronics, portable radios and the like, the speaker mute is actually performed by a set of switch contacts in the headphone jack. I'm not aware that a laptop would be any different. Are you sure that the jack is not defective. Have you tried booting another OS to see if the mute works correctly with something other than Ubuntu?

Just now, I have tried on fedora 8 for 64-bits(It really took me some time), but I didn't see any difference.I'm sure the jack works well in this new laptop.

After all, thank you for this good suggestion.

Peacedog 04-07-2008 09:17 AM

That didn't give me what I was looking for. Try this please.
Code:

cat /proc/asound/card0/codec\#*
Good luck. ;-)

sunnior 04-07-2008 11:25 PM

Quote:

Codec: Conexant ID 5051
Address: 0
Vendor Id: 0x14f15051
Subsystem Id: 0x103c30d6
Revision Id: 0x100000
Default PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
Node 0x10 [Audio Output] wcaps 0xc1d: Stereo Amp-Out
Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=0
Amp-Out vals: [0x3a 0x39]
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Node 0x11 [Audio Output] wcaps 0xc1d: Stereo Amp-Out
Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=0
Amp-Out vals: [0x4a 0x4a]
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Node 0x12 [Audio Output] wcaps 0x211: Stereo Digital
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x5]: PCM AC3
Node 0x13 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=0
Amp-Out vals: [0x00]
Node 0x14 [Audio Input] wcaps 0x100d1b: Stereo Amp-In
Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=0
Amp-In vals: [0x06 0x06] [0x34 0x34]
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Connection: 2
0x1d 0x17*
Node 0x15 [Audio Input] wcaps 0x100d1b: Stereo Amp-In
Amp-In caps: ofs=0x4a, nsteps=0x50, stepsize=0x03, mute=0
Amp-In vals: [0x4a 0x4a]
PCM:
rates [0x160]: 44100 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Connection: 1
0x18
Node 0x16 [Pin Complex] wcaps 0x400581: Stereo
Pincap 0x081c: OUT HP Detect
Pin Default 0x01214030: [Jack] HP Out at Ext Rear
Conn = 1/8, Color = Green
Pin-ctls: 0xc0: OUT HP
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x17 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x081224: IN Detect
Pin Default 0x01a19020: [Jack] Mic at Ext Rear
Conn = 1/8, Color = Pink
Pin-ctls: 0x24: IN
Power: 0x0
Node 0x18 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x081224: IN Detect
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Node 0x19 [Pin Complex] wcaps 0x400581: Stereo
Pincap 0x0814: OUT Detect
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Connection: 2
0x10 0x11*
Node 0x1a [Pin Complex] wcaps 0x400501: Stereo
Pincap 0x0810010: OUT EAPD
Pin Default 0x92170110: [Fixed] Speaker at Int Front
Conn = Analog, Color = Unknown
Pin-ctls: 0x40: OUT
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x1b [Pin Complex] wcaps 0x400500: Mono
Pincap 0x0810010: OUT EAPD
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x40: OUT
Power: 0x0
Connection: 2
0x10* 0x11
Node 0x1c [Pin Complex] wcaps 0x400701: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Connection: 1
0x12
Node 0x1d [Pin Complex] wcaps 0x40040b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x0820: IN
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Node 0x1e [Vendor Defined Widget] wcaps 0xf00000: Mono
Wish it will be helpful, though I can't understand at all.:)

Peacedog 04-08-2008 07:46 AM

Try adding one or the other of the following lines to your /etc/modprobe.d/alsa-base.
Code:

options snd-hda-intel model=laptop
options snd-hda-intel model=laptop-hp

Good luck. ;-)

sunnior 04-09-2008 05:34 AM

I tried both, added one each time to the end of the file /etc/modprobe.d/alsa-base, and then reboot. But it didn't work, strange thing....:scratch:

This is a segment of the code:

Quote:

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd-hda-intel model=laptop



webaware 04-09-2008 05:53 AM

I'm on Fedora 8 / x86-64 on an ASUS laptop, GNOME desktop, and what I find is that I have to enable the headphones on the Switches tab of the Volume Control applet, then mute the speakers. Voila - sound through headphone connection but not speakers.

Peacedog 04-09-2008 07:04 AM

Once you've got the module options in place you may have to adjust some things in your mixer also with proper module options you should have more channels available and recognized by your mixer. There is a thread here that may help.
Good luck. ;-)

sunnior 04-10-2008 04:40 AM

Well, I must say I couldn't solve this problem now. I'll go and learn more, and then come back to have a try. I think this problem won't constitute solved to me unless I understand why is in this way.

Thank you "peacedog", sincerely.

Peacedog 04-10-2008 07:29 AM

Did the module options give you more channels in your mixer? If so, look for Jack sense, or Headphone Jack sense.
Good luck. ;-)


All times are GMT -5. The time now is 09:23 PM.