LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-09-2007, 03:50 PM   #1
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Rep: Reputation: 0
Sound still on speaker when headphone is plugged in


Hi all,

I am wondering how to disable the sound on the speaker when my headphone is plugged in (sound is activated on both devices). I have openSuSe 10.2 installed on my Acer notebook 5550AWXMi with Intel ICH7 sound. Thank you in advance.
 
Old 04-09-2007, 04:10 PM   #2
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Need more information on your system. Could you run this script and post the resulting link?

Thanks
 
Old 04-09-2007, 04:18 PM   #3
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
Hi GrueMaster,

This is the result
http://pastebin.ca/431638

By the way, I have found some solution by using Alsamixer.
I haven't tried yet but if there is a solution for KMix
that I don't have to install anything, that would be better.
Thanks for your prompt reply.
 
Old 04-09-2007, 04:27 PM   #4
alienux
Member
 
Registered: Sep 2006
Location: Dayton, Ohio
Distribution: Slackware 12, Fedora Core, PCLinuxOS
Posts: 194

Rep: Reputation: 30
If you open up the full set of controls in KMix, there should be several tabs at the top of the mixer box. Click on the "switches" tab and look for an option that says something about headphone sensing.
 
Old 04-09-2007, 04:35 PM   #5
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
I'm not sure if there is a real solution other than a new driver. 1.0.12rc1 is quite old in the alsa world. Support for your system didn't really exist until 1.0.13, and there has been major enhancements since then.

If you are willing to try a set of new drivers, I have a self-contained build environment you could try. Download this tar file, extract it with "tar -jxvf my-build.tar.bz2", then cd into the directory, and type (as root) "make && audio_install". This will rebuild the driver, libs and utils, generating rpm files for each and install them.

After that, if you still have problems, we can explore changes in the driver before the next release.
 
Old 04-09-2007, 04:37 PM   #6
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by alienux
If you open up the full set of controls in KMix, there should be several tabs at the top of the mixer box. Click on the "switches" tab and look for an option that says something about headphone sensing.
Hi alienux,

There is no such an option in my KMix. I see only Caller ID, Off-hook, 2xInput Source in the Switches tab. Any idea? Thanks for your reply.
 
Old 04-09-2007, 04:52 PM   #7
alienux
Member
 
Registered: Sep 2006
Location: Dayton, Ohio
Distribution: Slackware 12, Fedora Core, PCLinuxOS
Posts: 194

Rep: Reputation: 30
Quote:
Originally Posted by krisyok
Hi alienux,

There is no such an option in my KMix. I see only Caller ID, Off-hook, 2xInput Source in the Switches tab. Any idea? Thanks for your reply.
Hmmm, not sure. My installations have always had that option (Slackware, PCLinuxOS, and Fedora). I'm not sure why you wouldn't have it. This probably won't be very helpful, but I found two places where others have the same issue, and also don't have the "Headphone Jack Sense" option, but unfortunately, neither link shows an actual solution:

http://www.mepis.org/node/12955

http://ubuntuforums.org/showthread.php?t=73358
 
Old 04-09-2007, 05:38 PM   #8
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by GrueMaster
If you are willing to try a set of new drivers, I have a self-contained build environment you could try. Download this tar file, extract it with "tar -jxvf my-build.tar.bz2", then cd into the directory, and type (as root) "make && audio_install". This will rebuild the driver, libs and utils, generating rpm files for each and install them.

After that, if you still have problems, we can explore changes in the driver before the next release.
I've just installed it. It looks more advanced than the one I had. Now I can only control the headphone volume. There is no sound on speaker although I enable the PC speaker option.
 
Old 04-09-2007, 05:51 PM   #9
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by krisyok
I've just installed it. It looks more advanced than the one I had. Now I can only control the headphone volume. There is no sound on speaker although I enable the PC speaker option.
I think now it's working perfectly with the new driver from GrueMaster (many thanks). I have noticed that the headphone is controlled by "Front" slider while the speaker is controlled by "Surround" slider (instead of "PC speaker"). I don't know the reason but it just works (after I tried all the 15 sliders. Thank you, GrueMaster
 
Old 04-10-2007, 12:13 PM   #10
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
krisyok, can you try reloading the driver with the following commands:

su
rmmod snd-hda-intel
modprobe snd-hda-intel model=acer

Make sure that there is no audio programs running before you do this. Type "lsmod | fgrep snd-hda-intel" to see if it is in use.
 
Old 04-11-2007, 04:05 AM   #11
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by GrueMaster
Make sure that there is no audio programs running before you do this. Type "lsmod | fgrep snd-hda-intel" to see if it is in use.
Nothing is reported but when I do
rmmod snd-hda-intel
I get an error saying that this module is in use.

Is it necessary to reload the driver?
I mean it's working fine now..
 
Old 04-11-2007, 02:05 PM   #12
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Not really, but I wanted to verify that you are getting the correct model identification. From your description of the surround slider controlling the speakers, you aren't.

Fou can also add a line in /etc/modprobe.conf for the model parameter. Essentially, your modprobe.conf file should look like this:
Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=acer
After adding the above lines, you can reboot to see the effect. This is easier than trying to kill all audio applications and reload the driver (although reloading the driver is much faster).

I hope you take a moment to try this, as if it works better with the "model=acer" option, then I can add your system info to the driver before it gets released.
 
Old 04-12-2007, 04:41 AM   #13
krisyok
LQ Newbie
 
Registered: Apr 2007
Distribution: openSuse
Posts: 13

Original Poster
Rep: Reputation: 0
I don't see any changes after rebooting.
Basically I put these lines in /etc/modprobe.conf before
# end of i386 part for modeprobe.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound on headphone jack kiaraho Linux - Hardware 3 02-16-2007 06:04 PM
How to fix when audio is heared both in headphone and inbuilt speaker of laptop san_irtt Linux - Laptop and Netbook 22 08-23-2006 05:47 AM
no sound --headphone Sherulinux Linux - Newbie 7 08-10-2005 04:39 PM
Headphone plugged in, sound still comes out of speakers tbraun Linux - Hardware 3 01-18-2005 04:36 PM
Sound//Headphone Config timmo567 Linux - Hardware 1 12-08-2004 12:56 AM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration