LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2007, 08:18 AM   #1
shawniecas
LQ Newbie
 
Registered: May 2007
Posts: 24

Rep: Reputation: 15
glib problem


I'm trying to install an applet for lm_sensors, and I'm getting the error:

"configure: error: Package requirements (glib-2.0 >= 2.6.0) were not met:

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

So, I just downloaded and installed glib 2.13.0 and I still get the same error. I don't know if it's just not in the right spot or what...
 
Old 06-01-2007, 08:20 AM   #2
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 37
Which distro are you using and how did you install glib?
 
Old 06-01-2007, 08:22 AM   #3
shawniecas
LQ Newbie
 
Registered: May 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Red Hat Enterprise 4. Im still really new at this, but I just found my way here: http://ftp.gnome.org/pub/GNOME/sources/glib/2.13/ and downloaded glib-2.13.0.tar.gz

Last edited by shawniecas; 06-01-2007 at 08:29 AM.
 
Old 06-01-2007, 08:32 AM   #4
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 37
Did you try to install it using yum? I would think that the package should be in RHEL repo.

For compiling from source you will most likely need package glib-devel.

Try as root:
Code:
yum install glib-devel
 
Old 06-01-2007, 08:43 AM   #5
shawniecas
LQ Newbie
 
Registered: May 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Yeah, the yum command isn't found, but what I did was the tar command, then I did ./configure, then make and make install and it seems to have worked fine, but when I try to install the lm_sensors applet, the ./configure says:

checking for GLIB... Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.4.7
configure: error: Package requirements (glib-2.0 >= 2.6.0) were not met:

So I figured that I need to change a file somewhere for it to point to the one I just installed (2.13.0)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
glib problem sameer666 Linux - Newbie 2 12-03-2005 12:49 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Glib problem Crazystorm2002 Mandriva 4 09-23-2003 08:41 PM


All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration