LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2005, 07:04 PM   #1
sameer666
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Rep: Reputation: 0
glib problem


hi

i was installing xmms for that i had to install glib 1.2.2 or greater, so i installed glib 1.2.8 but then i realised that i already have glib 1.2.10-16 which came with fedora core 4, now how do i fix it, i have looked into source file of glib 1.2.8 for a script for uninstalling but there is none, and tried to reinstall glib 1.2.10 but is giving me and error

make[2]: *** [gstrfuncs.lo] Error 1
make[2]: Leaving directory `/home/meme/programe/lib/glib-1.2.10'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/meme/programe/lib/glib-1.2.10'
make: *** [all-recursive-am] Error 2


and if i try to install gtk-1.2.10 it tells me that glib-config --version
1.2.8 is installed
glib 1.2.10-16 is installed as rpm package

i cann't uninstall rpm -e glib-1.2.10-16


thanx alot

Last edited by sameer666; 12-02-2005 at 07:05 PM.
 
Old 12-02-2005, 09:04 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
if you still have the source for glib-1.2.8, go back into it and run "make uninstall" ( note that not all packages will have this functionality, but with this one IIRC you should be fine). Also make sure you get the glib-1.2.10-xx-devel package that comes with your distro or xmms will not be able to compile against the 1.2.10 you have installed. Actually, what distro are you using, you would be better off just getting the package for xmms while you're at it and save yourself the trouble.
 
Old 12-03-2005, 01:49 PM   #3
sameer666
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
thanx alot

i installed the rpm for xmms and it worked fine

with it one more question, i.e. how to know if the source file i m compiling can be uninstalled, i mean is how to know if there is uninstall function in it, one more thing if the source package don't support make uninstall then how to remove them...

just wanna know for knowledge

thanx alot for ur reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
A problem about GLIB.... kenshinji Linux - Software 5 03-30-2005 01:27 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Glib 2.0 problem JreL Linux - Software 1 08-15-2003 01:16 PM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration