LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-20-2004, 12:25 PM   #1
eskiled
LQ Newbie
 
Registered: Aug 2004
Distribution: Mandrake 10 (Fluxbox)
Posts: 24

Rep: Reputation: 15
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message


***Repost from www.justlinux.com (but nobody answered there)***

I just tried installing the newest version of xmms and it decided to tell me that:

code:#tar -xvzf xmms-someversion.tar.gz
#cd xmms-someversion
#./configure



then I get this error message
"checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.

configure: error: *** GLIB >= 1.2.2 not installed - please install first ***"


I say fine, and I go pick up the latest tar.gz of glib (2.4.8). I go through the install (tar -xvzf, cd, ./configure, make, su root, make install) and everything is fine. I go back to complete my xmms installion:

code:
#cd xmms-someversion
#./configure



And I end up with the same error message as before! Whats going on?


Thanks,
eskiled


Ps. I know that this means ./configure cannot find my Glib updated packages. However I don't know where my updated packages are, and I don't know how to telll ./configure (as well as make and make install), where they are.

Pps. It would also be nice if I were able to move these Glib packages to a place where other "./configure's, make, and make install"s will be able to find and use them.
 
Old 12-20-2004, 12:42 PM   #2
corfe
Member
 
Registered: Dec 2004
Location: Washington State, USA
Distribution: Debian Sid
Posts: 128

Rep: Reputation: 15
Lightbulb

Usually, when installing libraries, there are two types to install - the regular library, that will let you run programs (you'll need this to run any program that uses it), and the development library, that will let you compile programs that use it. Since you're trying to compile xmms, even though you have the right version of the glib libraries installed, you'll want to install the development version of the glib libraries so that it can compile programs that use them..

However, that being said - with Mandrake, you can probably download an appropriate RPM or install all of these things (glib, glib-dev, and xmms) straight from a package manager. This is part of the ease of Mandrake and other user-friendly distributions - you don't often have to compile your own things. I don't know enough about Mandrake to know where their package manager is or anything, but I would check on some mandrake forums or in a mandrake tutorial, and it should tell you how to install all of this stuff without messing around with compiling your own stuff. You might also check your menus for some kind of "package manager" program, that might do the trick.

Good luck!
 
Old 12-19-2005, 09:12 PM   #3
wazzu
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
That worked! I had to install GTK and GLIB developement libs and it worked!

Thanks
wazzu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XMMS ./config GLIB >= 1.2.2 not installed error clonedmessiah Linux - Newbie 2 10-06-2006 01:23 AM
xmms glib pointer error / flac solution Bluesuperman Slackware 0 05-22-2005 01:19 PM
Installing XMMS Error with glib Egan Linux - Software 4 12-21-2004 10:31 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
XMMS glib-config error (old conflicting version maybe?) Balkman Linux - Software 0 02-06-2004 04:28 PM


All times are GMT -5. The time now is 04:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration