LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-17-2004, 01:11 AM   #1
scius
Member
 
Registered: Jul 2003
Location: Berkeley
Distribution: gentoo (kernel 2.6.7)
Posts: 39

Rep: Reputation: 15
conflicting glib versions and glib-config


running a fresh install of mandrake 10.
i'd like to install xmms(and other programs) from source (none of that rpm business).
xmms needed gtk+, gtk needs glib. So after installing glib 1.2.9(no errors) gtk says
Code:
checking for GLIB - version >= 1.2.8...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
So i guess i had 1.2.10 already installed (?).
1) I'm not sure how to remove the 1.2.9 i installed (is there an easy way?)... and if i did, it would seem i'd need a new glib-config, which i wasn't able to find for 1.2.10(see #3)
2) LD_LIBRARY_PATH is empty, and it wasn't clear how i should change this or /etc/ld.so.conf.
3) I couldn't find the 1.2.10 copy of glib-config (or really anything from 1.2.10 - i probably don't know what i'm looking for) so i'm not sure how to point to its glib-config (or remove it if that would help).
I would reinstall 1.2.10 but its source eludes me. I've reinstalled 1.2.9 but i don't know how to make 1.2.10 go away.
Google's been particularly stubborn about helping me, which generally means i don't know enough about whats going on to ask... Anyway, any suggestions would be great.
Thanks for your time,
graham

Also, another thread suggested 'rm usr/lib/libglib-1.2.so.0*' then running /sbin/ldconfig... however that seems pretty klugey, and i'm afraid of messing things up even more.
 
Old 07-17-2004, 04:44 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
http://gd.tuwien.ac.at/graphics/gimp...-1.2.10.tar.gz If you install it, use ./configure --prefix=/usr . If you do, uninstall glib-1.2.9 first. Compile it with the same options you chose the first time but use the command make uninstall instead of make install.
To modify LD_LIBRARY_PATH,
export LD_LIBRARY_PATH=/usr/local/lib # or wherever you want to include
 
Old 07-17-2004, 05:47 AM   #3
scius
Member
 
Registered: Jul 2003
Location: Berkeley
Distribution: gentoo (kernel 2.6.7)
Posts: 39

Original Poster
Rep: Reputation: 15
thanks so much. i ran into the same problem with gtk, i guess mandrake just didn't put in the gtk/glib-configs when they installed... which is annoying. And gtk didn't have their latest version w/ the old ones, which is also a bit confusing. Installing the same versions over them from source fixed it all.
I think my two day jaunt in mandrake is over... while the easy install was nice, i miss gentoo.
 
Old 07-17-2004, 07:33 AM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
All the stuff is there on the Mandrake CD's, you can install them with the package management tools in the Mandrake Control Centre. The names can be confusing though. It won't be called gtk-1.2.10, it'll be called something like libgtk-1.2.10-45768-mdk-devel. The important bits are the gtk, 1.2.10 and the dev - which means you can compile other things against it.
I found Mandrake was a good way in to using Linux but it's not stable enough for day to day use.
 
Old 07-28-2004, 09:27 AM   #5
dobrotescunicol
LQ Newbie
 
Registered: Jul 2004
Location: Bucharest/Romania
Distribution: Mandrake 10
Posts: 6

Rep: Reputation: 0
I have the same problem. I can't find GTK. Can you please tell me the correct name of the package?
 
Old 06-03-2008, 02:35 AM   #6
shaymaa
LQ Newbie
 
Registered: Jun 2008
Posts: 6

Rep: Reputation: 0
Exclamation

Quote:
Originally Posted by scius View Post
running a fresh install of mandrake 10.
i'd like to install xmms(and other programs) from source (none of that rpm business).
xmms needed gtk+, gtk needs glib. So after installing glib 1.2.9(no errors) gtk says
Code:
checking for GLIB - version >= 1.2.8...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
So i guess i had 1.2.10 already installed (?).
1) I'm not sure how to remove the 1.2.9 i installed (is there an easy way?)... and if i did, it would seem i'd need a new glib-config, which i wasn't able to find for 1.2.10(see #3)
2) LD_LIBRARY_PATH is empty, and it wasn't clear how i should change this or /etc/ld.so.conf.
3) I couldn't find the 1.2.10 copy of glib-config (or really anything from 1.2.10 - i probably don't know what i'm looking for) so i'm not sure how to point to its glib-config (or remove it if that would help).
I would reinstall 1.2.10 but its source eludes me. I've reinstalled 1.2.9 but i don't know how to make 1.2.10 go away.
Google's been particularly stubborn about helping me, which generally means i don't know enough about whats going on to ask... Anyway, any suggestions would be great.
Thanks for your time,
graham

Also, another thread suggested 'rm usr/lib/libglib-1.2.so.0*' then running /sbin/ldconfig... however that seems pretty klugey, and i'm afraid of messing things up even more.
I had installed glib-2.14.4 and then I was obligated to install glib-2.8.0
when I configure atk-1.9.0 i met this error:
checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.8.0, but GLIB (2.14.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

I removed glib-2.14.4 directories from all paths and : i typed
ldconfig -f /etc/ld.so.conf
then i retype:
[root@localhost atk-1.9.0]# ./configure --prefix=/usr/
I met the same error
where glib-2.14.4 existes and how to remove it.


Initialy i need to install mysql-workbench-5.0.21, what are library required and how to install
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two versions of glib installed rundjuling Linux - Software 5 06-03-2008 02:30 AM
2 different versions of glib and pkgconfig! karl0s Linux - Software 4 09-01-2004 06:05 AM
Two versions of Glib? OnlyMe Linux - Software 1 04-21-2004 06:13 AM
2 versions of glib conflict toships Linux - Newbie 2 02-21-2004 03:29 PM
XMMS glib-config error (old conflicting version maybe?) Balkman Linux - Software 0 02-06-2004 04:28 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration