LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2004, 05:38 PM   #16
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30

Quote:
Originally posted by motub
Sorry, you're using KDE, so I thought you'd be using Konqueror. If you were, you would just open Konq (which would open in your ~ directory), go to the View menu and choose Show Hidden Files, so you could see the dotfiles, then browse to .kde/Autostart, and right-click anywhere in the blank area to get the New=>Starter menu.

A Starter is what KDE calls a shortcut (if you're familiar with Windows shortcuts), is the same thing as what GNOME calls a Launcher, and you are probably indeed familiar with them, since your Panel and K-menu is full of them (the icons that start the various programs, like Konqueror or Mozilla or KMail).

If you don't want to use Konqueror to make the Launcher (though I can't imagine why if you're going to use KDE in the first place, since Konqueror is one of it's jewels), you can probably just make a symlink in ~./kde/Autostart and it will accomplish the purpose (I don't use KDE, so I can't say for absolute certain), using ln -s /usr/libexec/gnome-settings/daemon while within the ~/.kde/Autostart directory.

Hope this helps.
hi,

so i went to folder in konquerer, right clicked, but there's not 'autostart' option. so do i choose the option create a link to a program and enter the command as /usr/libexec/gnome-settings-daemon?
 
Old 07-06-2004, 05:50 PM   #17
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Autostart is a folder within the ~/.kde folder. It is where KDE looks for external programs that you want to start when KDE starts up. In that folder, one should put the Launchers/Starters/Shortcuts/Links to any programs that you want to start with KDE.

So yes, you would browse to the folder ~./kde/Autostart, and within that folder you would right-click and create a Link (or possibly choose New=>Launcher/Starter/whatever) to /usr/libexec/gnome-settings-daemon.

To save yourself some grief, you might want to type locate gnome-settings-daemon in a terminal first, to confirm the file path and that it is in fact installed on the system.
 
Old 07-06-2004, 06:20 PM   #18
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
Quote:
Originally posted by motub
Autostart is a folder within the ~/.kde folder. It is where KDE looks for external programs that you want to start when KDE starts up. In that folder, one should put the Launchers/Starters/Shortcuts/Links to any programs that you want to start with KDE.

So yes, you would browse to the folder ~./kde/Autostart, and within that folder you would right-click and create a Link (or possibly choose New=>Launcher/Starter/whatever) to /usr/libexec/gnome-settings-daemon.

To save yourself some grief, you might want to type locate gnome-settings-daemon in a terminal first, to confirm the file path and that it is in fact installed on the system.
amazing! got it to work. now firefox looks perfect w/o anti-alias. only thing i notice is that it takes aobut 10 seconds for it to fully load up. seems to only use 10mb...so not too bad.

thanks!
 
Old 07-06-2004, 10:36 PM   #19
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
update: although the fonts look better, gaim and gimp fonts for titles, menu bars, etc. still look a bit jagged. i think cuz they use a different font than the defaults for firefox/thunderbird, which look great. so is there a way i could change the fonts for these apps? i.e. is their an option to do it w/in gnome or reuse the:

Quote:
For Gimp2 /gtk2 try edit or create ~/.gtkrc-2.0 and add something like

code:

gtk-font-name = "Sans 12"
and replace it w/ a font that looks better?
 
Old 07-07-2004, 04:05 AM   #20
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Depends on which version of The Gimp you're using; I suspect that if gnome-settings-daemon is not affecting it, it's because you're using GIMP 1.x, which is based on GTK1 rather than GTK2 (so does not use the GTK2 settings cotrolled by gnome-settings-daemon).

If this is the case, use DemonBane's first suggestion:
Quote:
For Gimp1 or gtk1 apps try copying /etc/gtk/gtkrc.iso-8859-2 to ~/.gtkrc
.

If this is not the case (you're using GIMP 2.x), you can use Demonbane's second suggestion, but what I would do is log into GNOME one time and use the GNOME Control Center to globally adjust my GTK2 fonts to one consistent font and size, turn off AA, etc, thus changing the settings that gnome-settings-daemon is using.

But that's up to you.
 
Old 07-07-2004, 10:47 PM   #21
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
Quote:
Originally posted by motub
Depends on which version of The Gimp you're using; I suspect that if gnome-settings-daemon is not affecting it, it's because you're using GIMP 1.x, which is based on GTK1 rather than GTK2 (so does not use the GTK2 settings cotrolled by gnome-settings-daemon).

If this is the case, use DemonBane's first suggestion:
.

If this is not the case (you're using GIMP 2.x), you can use Demonbane's second suggestion, but what I would do is log into GNOME one time and use the GNOME Control Center to globally adjust my GTK2 fonts to one consistent font and size, turn off AA, etc, thus changing the settings that gnome-settings-daemon is using.

But that's up to you.
actually, gimp 1.25 looks great to me. However, the gtk2 apps like gaim and gimp have fonts on the menu bars that just look very jagged....either in kde or in gnome. on the other hand, apps like firefox/thunderbird which are also gtk2 i think look good. weird. regarding setting it to a fixed font, i tried that w/ helvetica and sans =12 but it didn't really make a difference. i've turned off anti-alias so that might be the major problem. i just can't stand aa and would rather get jagged fonts than smooth ones that are blurry.
 
Old 07-08-2004, 03:52 AM   #22
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
That last problem is more related to the fonts you have available than anything else. Btw, neither Helvetica nor Sans are "fixed" (monospace) fonts; they are both varible-width fonts. Try "Sans Mono" or "Monospace" for something like that.

The fonts Linux installs with (Sans, to name the main offender) are generally a bit blurry, even with AA. What you should also do is install some TrueType fonts (from Microsoft) and some Bitstream fonts and eliminate the use of Sans (which is usually the default under GNOME; iirc KDE uses Helvetica these days, which is not as blurry as Sans, but still a bit), and then change your default font in the relevant Control Center (KDE or GNOME or both) to reflect something like Arial (which always looks good) or Luxi Sans or Luxi Serif (which usually looks good). Check your Software Media Manager for additional fonts available for download, if you have a retail version of Mandrake, are a member of the Mandrake Club and/or have already configured external repositories in your SMM. If you haven't configured outside repositories (Mandrake, by default, only uses the CD's as software sources, but there are thousands of packages available on Mandrake repositories on the Internet), then go over to Easy URPMI and do so immediately.

Oh, and would you please use the large "Post Reply" button under the last post, instead of the smaller "Quote" button? There's no reason to quote the entire previous post when replying-- we can all see it .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Font doesn't work in The GIMP objorkum Linux - Software 1 11-03-2004 10:46 AM
How to change font size of OOo menus? bruno buys Linux - Software 0 09-12-2004 05:06 PM
GIMP stops the X font server LavaDevil94 Linux - Software 2 08-28-2004 11:04 AM
font installed, visible w/xfontsel, but not on program menus. Shay Slackware 0 10-31-2003 09:06 AM
changing the font-size of menus of GTK 2 apps running under KDE 3.1 melquiades Linux - Software 1 07-05-2003 01:17 PM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration