LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2004, 12:28 AM   #1
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
Font too small in gimp menus?


I'm having a problem (mainly with gimp) with fonts that are far too small on the menus for me to effectively read them. On firefox and thunderbird I also had this problem but there was a menu in the program to change from 75 to 96 dpi which did it nicely for me. However, there is no such menu in gimp that appears to be designed to increase menu size (there is a force option to increase dpi resolution for the editing part but not for the menu..) anyone know how I can fix this for gimp?
 
Old 05-13-2004, 01:22 AM   #2
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
I had a similar (same?) problem in Mandrake 10.0 official. When using KDE, you are only setting KDE desktop and application fonts. No matter what default fonts I chose, Evolution had tiny unchanged fonts. I opened the gnome control center (in KDE), changed the fonts there, and poof, Evolution, Gimp, etc, all changed. It is very weird. My first experience where KDE control center and default fonts didn't apply to Gnome apps. I am in Suse now, and didn't install Gnome, and don't remember what the command is to bring up Gnome font config. Give that a try though.

RO
 
Old 05-13-2004, 01:41 AM   #3
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Original Poster
Rep: Reputation: 30
Hmmm... interesting. Well I don't have gnome on here except for the libs to run the gnome apps.. but maybe the font config is on here anyway.. can't find it though so if anyone else has a clue I'd still appreciate..

Thanks for the help so far.
 
Old 05-13-2004, 04:31 AM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
I do have GNOME installed, so I'm not sure just how many extra packages you'd wind up with by doing the following, but:

GNOME/GTK fonts are set via the GNOME Control Center=>Desktop Appearance=>Fonts. I don't know if there's an alternate manner.

However, in order to get GTK fonts to look more generally correct under KDE or any other non-GNOME window manager, you should set the gnome-settings-daemon to run upon loading of X or loading of the WM/DE. This will conform the menu fonts of GTK apps to something readable.

As I said, I have GNOME installed, and use it, so I don't know if this means you pretty much have to install GNOME to get these (no idea what the dependencies are, etc), but it does work, as I tested it in KDE and the Mozilla/Firefox menus looked quite normal (finally), rather than being too big or too small.

Hope this helps.
 
Old 05-13-2004, 06:04 AM   #5
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Original Poster
Rep: Reputation: 30
well you are the second person who said it so I guess I get gnome.. personally I prefer KDE very much over gnome which I personally think looks extremely bland (not to start a flame war about the differences hehe)..
If I was going to go for an alternative wm it'd be fluxbox far before gnome..
 
Old 05-13-2004, 06:22 AM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
I prefer GNOME very much over KDE (although today is "Day 2 with Fluxbox", which is so far working out quite well), but I have KDE installed anyway. There are a couple of K-programs that I use, and occasionally I like to boot into it and see if I can stand it any better than the last time . I could run the k-programs by just installing kde-base and the libs (which is how I usually start, trying to limit the amount of KDE that I install), but I usually find that once you've gotten to the point that you have to install the "base" of either DE, you might as well install enough of the thing to make it useable, unless you know for an absolute fact that you never, ever, will use it for any reason (including emergencies). So I wind up with both KDE and GNOME on the system.

But I do use other WMs (XFce and now Fluxbox), and running the gnome-settings-daemon helps Firefox and other apps look good under those as well.
 
Old 05-13-2004, 06:46 AM   #7
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
For Gimp1 or gtk1 apps try copying /etc/gtk/gtkrc.iso-8859-2 to ~/.gtkrc
then change the font sizes in there.
For Gimp2 /gtk2 try edit or create ~/.gtkrc-2.0 and add something like
Code:
gtk-font-name = "Sans 12"
 
Old 05-13-2004, 07:05 AM   #8
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Original Poster
Rep: Reputation: 30
wow dude.. you completely rock
 
Old 05-31-2004, 03:01 PM   #9
Eagle_Y
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
Oh MY GOD, AT LAST the fonts are normal again!!!! I'v looked all over the web for this. Thannnnnnnnnk soooooooo much "Demonbane" if you were infront of me i'd give u a huge hug!



 
Old 07-06-2004, 12:21 AM   #10
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
Quote:
Originally posted by Demonbane
For Gimp1 or gtk1 apps try copying /etc/gtk/gtkrc.iso-8859-2 to ~/.gtkrc
then change the font sizes in there.
For Gimp2 /gtk2 try edit or create ~/.gtkrc-2.0 and add something like
Code:
gtk-font-name = "Sans 12"

Hi,

I'm using a laptop lcd screen at xga and i'd like to change how the font for firefox .9/thunderbird .7 /gaim .75 look. on my computer, sometimes they're anti-aliased, others not. they're different in apperance from the fonts i set up in the mandrake control center of kde. i.e. the gimp fonts look like they're a size 8 or something while my regular fonts are a size 12. from doing a search, i think it has to do something w/ gtk 1 or 2. i'm pretty new to linux and don't know much so let me know how to fix it. thanks.

could u give me some more detailed instructions? i can't find ~/.gtkrc-2. or ~/.gtkrc-2. (i'm new to linux and don't know where those are). my gimp fonts, firefox, and thunderbird are all really small and anti-aliased. i'd like them normal.

===================
For Gimp1 or gtk1 apps try copying /etc/gtk/gtkrc.iso-8859-2 to ~/.gtkrc
then change the font sizes in there.

--> when i enter /etc/gtk/gtkrc.iso-8859-2 into konquerer, it opens a file w/ a bunch of text. what should i do next? and how do i copy it to ~/.gtkrc (where is ~ anyways?)?

============
For Gimp2 /gtk2 try edit or create ~/.gtkrc-2.0 and add something like

code:

gtk-font-name = "Sans 12"


--> so where do i find this file and if i have to create it, where would it be, and is the only line of text [gtk-font-name = "Sans 12"]? could i use another font like helvetica or arial?

btw, the fonts in gnome look 10 times better than kde..... i don't have any of the small fonts, anti-aliasing, etc.

i'm using mdk 10.

thanks.

Last edited by webazoid; 07-06-2004 at 12:29 AM.
 
Old 07-06-2004, 07:35 AM   #11
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
You're using GTK apps under KDE. That's a different kettle of fish (similar to using KDE/QT apps under GNOME).

The most common solution to this problem (and the one I use) is to run the gnome-settings-daemon when starting up any DE/WM that is not GNOME. What this does is provide/insert/inject the settings (like menu font size) for the GTK programs that they would have under GNOME (where GTK is the base library).

You don't say what distribution you are using, so if you don't have GNOME, or at least the base libraries or gnome-base installed, I can't necessarily tell you how to install gnome-settings-daemon "mostly by itself" (search Google), and this solution may not be ideal if you don't want to install any part of GNOME. Demonbane's solution avoids this.

I can tell you how to find ~/.gtkrc-2. or ~/.gtkrc-2 if they exist on your system, if you want to use that solution instead.

"~/" is an abbreviation for "your $HOME$ folder", or the "/home/your_username" folder. This abbreviation is also known to Linux, so if you open a file manager or a terminal window (both of which open in your home folder by default), you may see the current path listed as /home/your_username" or "~", and you can in fact type "cd ~" into a terminal to return to your home folder.

.gtkrc-2. and .gtkrc-2 are "dotfiles" so named because of the "dot" before the filename proper. A dot before the filename indicates a hidden file or folder.

So if you turn on "Show Hidden Files and Folders" in Konqueror (I believe it's in the lower half of the "View" menu), you will be able to see all the dotfiles in a particular folder, which is helpful when you want to adjust the configuration of an installed program that has per-user configuration files (which are stored in dotfiles in your ~/ ).

Hope this helps explain what's going on so you can try Demonbane's suggestion.
 
Old 07-06-2004, 05:33 PM   #12
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
Quote:
Originally posted by motub
You're using GTK apps under KDE. That's a different kettle of fish (similar to using KDE/QT apps under GNOME).

The most common solution to this problem (and the one I use) is to run the gnome-settings-daemon when starting up any DE/WM that is not GNOME. What this does is provide/insert/inject the settings (like menu font size) for the GTK programs that they would have under GNOME (where GTK is the base library).

You don't say what distribution you are using, so if you don't have GNOME, or at least the base libraries or gnome-base installed, I can't necessarily tell you how to install gnome-settings-daemon "mostly by itself" (search Google), and this solution may not be ideal if you don't want to install any part of GNOME. Demonbane's solution avoids this.

I can tell you how to find ~/.gtkrc-2. or ~/.gtkrc-2 if they exist on your system, if you want to use that solution instead.

"~/" is an abbreviation for "your $HOME$ folder", or the "/home/your_username" folder. This abbreviation is also known to Linux, so if you open a file manager or a terminal window (both of which open in your home folder by default), you may see the current path listed as /home/your_username" or "~", and you can in fact type "cd ~" into a terminal to return to your home folder.

.gtkrc-2. and .gtkrc-2 are "dotfiles" so named because of the "dot" before the filename proper. A dot before the filename indicates a hidden file or folder.

So if you turn on "Show Hidden Files and Folders" in Konqueror (I believe it's in the lower half of the "View" menu), you will be able to see all the dotfiles in a particular folder, which is helpful when you want to adjust the configuration of an installed program that has per-user configuration files (which are stored in dotfiles in your ~/ ).

Hope this helps explain what's going on so you can try Demonbane's suggestion.
i have mandrake 10 and gnome already installed. how do i activate this? thanks.
 
Old 07-06-2004, 05:38 PM   #13
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Go to ~/.kde/Autostart and make a new starter to /usr/libexec/gnome-settings-daemon.
 
Old 07-06-2004, 06:03 PM   #14
webazoid
Member
 
Registered: Jun 2004
Posts: 224

Rep: Reputation: 30
Quote:
Originally posted by motub
Go to ~/.kde/Autostart and make a new starter to /usr/libexec/gnome-settings-daemon.
hi,

so in a terminal window in my home directory,

i press:

cd ~/.kde/Autostart

and that brings me to the Autostart directory. How do i make this starter? (dunno what i starter is)...does it automatically load each time computer boots? thanks. does it require extra memory every time I boot?

Last edited by webazoid; 07-06-2004 at 06:11 PM.
 
Old 07-06-2004, 06:21 PM   #15
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Sorry, you're using KDE, so I thought you'd be using Konqueror. If you were, you would just open Konq (which would open in your ~ directory), go to the View menu and choose Show Hidden Files, so you could see the dotfiles, then browse to .kde/Autostart, and right-click anywhere in the blank area to get the New=>Starter menu.

A Starter is what KDE calls a shortcut (if you're familiar with Windows shortcuts), is the same thing as what GNOME calls a Launcher, and you are probably indeed familiar with them, since your Panel and K-menu is full of them (the icons that start the various programs, like Konqueror or Mozilla or KMail).

If you don't want to use Konqueror to make the Launcher (though I can't imagine why if you're going to use KDE in the first place, since Konqueror is one of it's jewels), you can probably just make a symlink in ~./kde/Autostart and it will accomplish the purpose (I don't use KDE, so I can't say for absolute certain), using ln -s /usr/libexec/gnome-settings/daemon while within the ~/.kde/Autostart directory.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Font doesn't work in The GIMP objorkum Linux - Software 1 11-03-2004 11:46 AM
How to change font size of OOo menus? bruno buys Linux - Software 0 09-12-2004 06:06 PM
GIMP stops the X font server LavaDevil94 Linux - Software 2 08-28-2004 12:04 PM
font installed, visible w/xfontsel, but not on program menus. Shay Slackware 0 10-31-2003 10:06 AM
changing the font-size of menus of GTK 2 apps running under KDE 3.1 melquiades Linux - Software 1 07-05-2003 02:17 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration