LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2009, 10:40 PM   #1
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Rep: Reputation: 15
Error while initializing the sound driver


hi im running sabayon linux 4.0 and when loaded into kde i get this error message:

"Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device."

i did alsaconf in the terminal as su went through the prompts. im useing onboard audio i think the driver is via technologies, inc. vt1708/a high definition.


modprobe maestro responds with:

"FATAL: Module maestro not found."

when going into the control center > sound & multimedia > sound sytem/hardware i changed the device to alsa than hit apply same error message appears same thing with all of the other devices oss jack toss and autodection. i went into kmix unmuted the sound and raised the volume to 100% still no sound. any help will be greatly apperciated thanks

i just did alsaconf again then did lsmod and got back new results:

"localhost sircody # lsmod | grep snd
snd_seq_dummy 9988 0
snd_seq_oss 35840 0
snd_seq_midi_event 13056 1 snd_seq_oss
snd_seq 50224 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 43136 0
snd_mixer_oss 20992 1 snd_pcm_oss
snd_ymfpci 34464 0
snd_vx222 16544 0
snd_vx_lib 34048 1 snd_vx222
snd_virtuoso 14596 0
snd_via82xx_modem 16776 0
snd_via82xx 26904 0
snd_trident 36996 0
snd_sonicvibes 22944 0
snd_sis7019 18948 0
snd_rme9652 28320 0
snd_rme96 25220 0
snd_rme32 24480 0
snd_riptide 26004 0
snd_pcxhr 38560 0
snd_oxygen 12164 0
snd_nm256 69920 0
snd_mona 29572 0
snd_mixart 38688 0
snd_mia 29188 0
snd_maestro3 24196 0
snd_layla24 31876 0
snd_layla20 28932 0
snd_korg1212 25092 0
snd_intel8x0m 18956 0
snd_intel8x0 31388 0
snd_indigoio 24452 0
snd_indigodj 23940 0
snd_indigo 23940 0
snd_ice1724 81340 0
snd_ak4114 14720 1 snd_ice1724
snd_pt2258 11136 1 snd_ice1724
snd_ice1712 55844 0
snd_ice17xx_ak4xxx 10624 2 snd_ice1724,snd_ice1712
snd_ak4xxx_adda 14336 3 snd_ice1724,snd_ice1712,snd_ice17xx_ak4xxx
snd_cs8427 14464 1 snd_ice1712
snd_i2c 11648 4 snd_ice1724,snd_pt2258,snd_ice1712,snd_cs8427
snd_hifier 11140 0
snd_oxygen_lib 32256 3 snd_virtuoso,snd_oxygen,snd_hifier
snd_hdspm 36896 0
snd_hdsp 46852 0
snd_hda_intel 318252 0
snd_gina24 29444 0
snd_gina20 25988 0
snd_fm801 21024 0
snd_tea575x_tuner 10752 1 snd_fm801
snd_es1968 29216 0
snd_es1938 23300 0
snd_ens1371 24992 0
snd_ens1370 25504 0
snd_emu10k1x 20484 0
snd_emu10k1 129696 0
snd_util_mem 10880 2 snd_trident,snd_emu10k1
snd_echo3g 32388 0
snd_darla24 24836 0
snd_darla20 23172 0
snd_cs5535audio 16776 0
snd_cs5530 12036 0
snd_sb16_dsp 16128 1 snd_cs5530
snd_cs46xx 79848 0
snd_cs4281 22176 0
snd_cmipci 34592 0
snd_ca0106 33568 0
snd_bt87x 17700 0
snd_azt3328 22788 0
snd_aw2 17180 0
snd_au8830 49844 0
snd_au8820 34208 0
snd_au8810 43956 0
snd_atiixp_modem 17416 0
snd_atiixp 20108 0
snd_als4000 17184 0
snd_sb_common 18432 3 snd_cs5530,snd_sb16_dsp,snd_als4000
snd_opl3_lib 16384 9 snd_ymfpci,snd_sonicvibes,snd_riptide,snd_fm801,snd_es1938,snd_cs4281,snd_cmipci,snd_azt3328,snd_als 4000
snd_hwdep 14084 4 snd_hdspm,snd_hdsp,snd_emu10k1,snd_opl3_lib
snd_mpu401_uart 13568 16 snd_ymfpci,snd_via82xx,snd_trident,snd_sonicvibes,snd_riptide,snd_ice1712,snd_oxygen_lib,snd_fm801,s nd_es1968,snd_es1938,snd_cmipci,snd_azt3328,snd_au8830,snd_au8820,snd_au8810,snd_als4000
snd_rawmidi 24960 15 snd_mia,snd_layla24,snd_layla20,snd_ice1724,snd_hdspm,snd_hdsp,snd_ens1371,snd_ens1370,snd_emu10k1x, snd_emu10k1,snd_echo3g,snd_cs46xx,snd_cs4281,snd_ca0106,snd_mpu401_uart
snd_seq_device 13324 6 snd_seq_dummy,snd_seq_oss,snd_seq,snd_emu10k1,snd_opl3_lib,snd_rawmidi
snd_als300 15492 0
snd_ali5451 23436 0
snd_ad1889 16800 0
snd_ac97_codec 91044 29 snd_ymfpci,snd_via82xx_modem,snd_via82xx,snd_trident,snd_sis7019,snd_riptide,snd_nm256,snd_maestro3, snd_intel8x0m,snd_intel8x0,snd_ice1724,snd_ice1712,snd_fm801,snd_es1968,snd_ens1371,snd_emu10k1x,snd _emu10k1,snd_cs5535audio,snd_cs46xx,snd_cs4281,snd_ca0106,snd_au8830,snd_au8820,snd_au8810,snd_atiix p_modem,snd_atiixp,snd_als300,snd_ali5451,snd_ad1889
snd_pcm 67332 65 snd_pcm_oss,snd_ymfpci,snd_vx_lib,snd_via82xx_modem,snd_via82xx,snd_trident,snd_sonicvibes,snd_sis70 19,snd_rme9652,snd_rme96,snd_rme32,snd_riptide,snd_pcxhr,snd_oxygen,snd_nm256,snd_mona,snd_mixart,sn d_mia,snd_maestro3,snd_layla24,snd_layla20,snd_korg1212,snd_intel8x0m,snd_intel8x0,snd_indigoio,snd_ indigodj,snd_indigo,snd_ice1724,snd_ak4114,snd_ice1712,snd_oxygen_lib,snd_hdspm,snd_hdsp,snd_hda_int el,snd_gina24,snd_gina20,snd_fm801,snd_es1968,snd_es1938,snd_ens1371,snd_ens1370,snd_emu10k1x,snd_em u10k1,snd_echo3g,snd_darla24,snd_darla20,snd_cs5535audio,snd_sb16_dsp,snd_cs46xx,snd_cs4281,snd_cmip ci,snd_ca0106,snd_bt87x,snd_azt3328,snd_aw2,snd_au8830,snd_au8820,snd_au8810,snd_atiixp_modem,snd_at iixp,snd_als4000,snd_als300,snd_ali5451,snd_ad1889,snd_ac97_codec
snd_timer 24840 6 snd_seq,snd_ymfpci,snd_emu10k1,snd_azt3328,snd_opl3_lib,snd_pcm
snd 49700 84 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_ymfpci,snd_vx222,snd_vx_lib,snd_virtuoso,snd_via82 xx_modem,snd_via82xx,snd_trident,snd_sonicvibes,snd_sis7019,snd_rme9652,snd_rme96,snd_rme32,snd_ript ide,snd_pcxhr,snd_oxygen,snd_nm256,snd_mona,snd_mixart,snd_mia,snd_maestro3,snd_layla24,snd_layla20, snd_korg1212,snd_intel8x0m,snd_intel8x0,snd_indigoio,snd_indigodj,snd_indigo,snd_ice1724,snd_ak4114, snd_pt2258,snd_ice1712,snd_ak4xxx_adda,snd_cs8427,snd_i2c,snd_hifier,snd_oxygen_lib,snd_hdspm,snd_hd sp,snd_hda_intel,snd_gina24,snd_gina20,snd_fm801,snd_es1968,snd_es1938,snd_ens1371,snd_ens1370,snd_e mu10k1x,snd_emu10k1,snd_echo3g,snd_darla24,snd_darla20,snd_cs5535audio,snd_cs5530,snd_sb16_dsp,snd_c s46xx,snd_cs4281,snd_cmipci,snd_ca0106,snd_bt87x,snd_azt3328,snd_aw2,snd_au8830,snd_au8820,snd_au881 0,snd_atiixp_modem,snd_atiixp,snd_als4000,snd_sb_common,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_r awmidi,snd_seq_device,snd_als300,snd_ali5451,snd_ad1889,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc 14472 36 snd_ymfpci,snd_via82xx_modem,snd_via82xx,snd_trident,snd_rme9652,snd_riptide,snd_pcxhr,snd_mona,snd_ mixart,snd_mia,snd_layla24,snd_layla20,snd_korg1212,snd_intel8x0m,snd_intel8x0,snd_indigoio,snd_indi godj,snd_indigo,snd_hdsp,snd_hda_intel,snd_gina24,snd_gina20,snd_es1968,snd_ens1370,snd_emu10k1x,snd _emu10k1,snd_echo3g,snd_darla24,snd_darla20,snd_cs5535audio,snd_cs46xx,snd_ca0106,snd_bt87x,snd_atii xp_modem,snd_atiixp,snd_pcm
videodev 39936 1 snd_tea575x_tuner
gameport 16396 17 snd_ymfpci,snd_via82xx,snd_trident,snd_sonicvibes,snd_riptide,snd_es1968,snd_es1938,snd_ens1371,snd_ ens1370,snd_cs46xx,snd_cs4281,snd_cmipci,snd_azt3328,snd_au8830,snd_au8820,snd_au8810,snd_als4000
ac97_bus 9344 1 snd_ac97_codec"

is it normal for it to load that many modules afterwards? but i belive sndmaestro3 is the module i want correct? ok so i go the sound to work useing kaffine media player. but useing my music player juk its still not working its useing arts for audio output when slected to gstreamer it wont play the song at all vs arts no sound so im probally going to get a differnt player since i cant figure out how to get the sound to work useing this one. downloaded installed rhythmbox it doesnt play the sound either. not sure if its a alsa problem or a gstreamer problem any ideas? sound error still exists message poped up again when reloading kde.

Last edited by bloodyscript; 01-09-2009 at 12:17 AM.
 
Old 01-09-2009, 08:31 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Post lspci | grep Multimedia
If it is a VT1708 this may help;
http://www.google.com/search?hl=en&q...snd-hda-intel+
 
Old 01-09-2009, 03:00 PM   #3
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
lspci didnt print out any information. but alsa config find two cards hda ati radeon 2400 pro thats my ati video card that has hdmi video output and audio but im not useing the hdmi video cable im useing vga. the second one is hda via tech vt1708/a so im just assuming thats my onboard sound card. the funny this is is that i had sabayon 3.4 mini edition on it yesturday and the sound worked, the live cd of sabayon 4.0 had sound and it worked so i dunno what happend. so far ive been only able to get sound to work after i do alsaconf each time after boot up and only in kaffine media player rythmbox sound didnt work jik music player sound didnt work itried downloading amarok to see if that works but cant find the installed app. i installed it through entropy. thanks for the help

ok so i did alsamixer in the terminal its stateing that my video card is the sound device on the computer but im currently only useing th eonboard so how do i change the settings in alsamixer this is hat alsamixer /proc has to say:

"/proc/asound/version: # │
│ │==================== # │
│ │Advanced Linux Sound Architecture Driver Version 1.0.17. # │
│ │ # │
│ │/proc/asound/cards: # │
│ │=================== # │
│ │ 0 [HDMI ]: HDA-Intel - HDA ATI HDMI ▒ │
│ │ HDA ATI HDMI at 0xfdefc000 irq 25 ▒ │
│ │ 1 [VT82xx ]: HDA-Intel - HDA VIA VT82xx ▒ │
│ │ HDA VIA VT82xx at 0xbfffc000 irq 17 ▒ │
│ │ ▒ │
│ │/proc/asound/devices: ▒ │
│ │===================== ▒ │
│ │ 2: : timer ▒ │
│ │ 3: [ 0- 3]: digital audio playback ▒ │
│ │ 4: [ 0] : control ▒ │
│ │ 5: [ 1- 1]: digital audio playback"

how do i make the vt1708 my default sound card. kaffine player works with sound no problem at all so im confused as to whats going on. but the error message still appears.

Last edited by bloodyscript; 01-09-2009 at 03:24 PM.
 
Old 01-09-2009, 03:13 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
as root or sudo type alsactl restore if that works then you will find that the alsa is not running from the start up scripts. mine is in /etc/rc.d/rc.alsa. and make sure it is set to executable. this runs the script to do alsactl restore at boot.
 
Old 01-09-2009, 03:30 PM   #5
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
drakeo,thanx for the reply

localhost sircody # alsactl restore
Unknown hardware: "HDA-Intel" "Realtek ALC662 rev1" "HDA:10ec0662" "0x1565" "0x820f"
Hardware is initialized using a guess method


thats what got printed out. does that mean my machine doesnt even know what device to run and setup?

oh ya after about 2 mins of audio play kaffine prints out a error message audio device is busy and then no more sound.
 
Old 01-09-2009, 04:14 PM   #6
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
need the out put of your lspci and dmesg in dmesg it will show the card being found then not being loaded. I had one like this a while back had to go into bios and enable onboard sound and make sure then while your in there set your bios to non windows or non-os controld system. Linux is not great at reading bios so do not ask it to control them.
after rebooting know we know there is no IRQ problems. list your lspci and your dmesg part about sound cards. type lspci and then dmesg.
 
Old 01-09-2009, 04:19 PM   #7
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
if you have more than one device you need to set it up in the sound server program so both devices can run what ever yours is.
 
Old 01-09-2009, 04:31 PM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
https://help.ubuntu.com/community/Hd...ntelSoundHowto)
and also type aplay -l see witch device is being used.
 
Old 01-09-2009, 04:38 PM   #9
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
Quote:
Originally Posted by Drakeo View Post
https://help.ubuntu.com/community/Hd...ntelSoundHowto)
and also type aplay -l see witch device is being used.
https://bugzilla.redhat.com/show_bug.cgi?id=475756
 
Old 01-09-2009, 04:54 PM   #10
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
drakeo, no sound option or os option in my bios its biostar. i checked all the menus and options and couldnt find anything.

lspci | grep audio

02:00.1 Audio device: ATI Technologies Inc RV610 audio device [Radeon HD 2400 PRO]
80:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)


dmesg
Code:
localhost sircody # dmesg



[    0.318540] NET: Registered protocol family 2
[    0.321408] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.321831] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.322691] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
[    0.323256] TCP: Hash tables configured (established 131072 bind 65536)
[    0.323261] TCP reno registered
[    0.324534] NET: Registered protocol family 1
[    0.324754] checking if image is initramfs...<7>Switched to high resolution mode on CPU 1
[    0.501040] Switched to high resolution mode on CPU 0
[    0.814134]  it is
[    1.352361] Freeing initrd memory: 14865k freed
[    1.354355] audit: initializing netlink socket (disabled)
[    1.354381] type=2000 audit(1231432432.354:1): initialized
[    1.354693] highmem bounce pool size: 64 pages
[    1.354703] HugeTLB registered 4 MB page size, pre-allocated 0 pages
[    1.358536] VFS: Disk quotas dquot_6.5.1
[    1.358592] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    1.359731] squashfs: version 3.4 (2008/08/26) Phillip Lougher
[    1.361227] Registering unionfs 2.5 (for 2.6.27-rc6)
[    1.361778] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[    1.362932] NTFS driver 2.1.29 [Flags: R/W].
[    1.363425] QNX4 filesystem 0.2.3 registered.
[    1.363433] fuse init (API version 7.9)
[    1.363962] JFS: nTxBlock = 8192, nTxLock = 65536
[    1.369780] SGI XFS with ACLs, security attributes, realtime, large block numbers, no debug enabled
[    1.371200] SGI XFS Quota Management subsystem
[    1.371510] aufs 20081208
[    1.371520] msgmni has been set to 1729
[    1.371806] async_tx: api initialized (async)
[    1.371975] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    1.371981] io scheduler noop registered
[    1.371984] io scheduler anticipatory registered
[    1.371987] io scheduler deadline registered
[    1.372030] io scheduler cfq registered (default)
[    1.372064] PCI: VIA PCI bridge detected.Disabling DAC.
[    1.372192] pci 0000:02:00.0: Boot video device
[    1.372395] pcieport-driver 0000:00:02.0: setting latency timer to 64
[    1.372456] pcieport-driver 0000:00:02.0: found MSI capability
[    1.372532] pci_express 0000:00:02.0:pcie00: allocate port service
[    1.372603] pci_express 0000:00:02.0:pcie01: allocate port service
[    1.372661] pci_express 0000:00:02.0:pcie02: allocate port service
[    1.372724] pci_express 0000:00:02.0:pcie03: allocate port service
[    1.372861] pcieport-driver 0000:00:03.0: setting latency timer to 64
[    1.372926] pcieport-driver 0000:00:03.0: found MSI capability
[    1.373009] pci_express 0000:00:03.0:pcie00: allocate port service
[    1.373067] pci_express 0000:00:03.0:pcie01: allocate port service
[    1.373126] pci_express 0000:00:03.0:pcie02: allocate port service
[    1.373183] pci_express 0000:00:03.0:pcie03: allocate port service
[    1.379190] aer 0000:00:02.0:pcie01: service driver aer loaded
[    1.384870] aer 0000:00:03.0:pcie01: service driver aer loaded
[    1.428243] hpet_resources: 0xfe800000 is busy
[    1.428344] toshiba: not a supported Toshiba laptop
[    1.428609] Linux agpgart interface v0.103
[    1.428859] uvesafb: failed to execute /sbin/v86d
[    1.428868] uvesafb: make sure that the v86d helper is installed and executable
[    1.428876] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    1.428882] uvesafb: vbe_init() failed with -22
[    1.428891] uvesafb: probe of uvesafb.0 failed with error -22
[    1.429095] vesafb: framebuffer at 0xc0000000, mapped to 0xf8d00000, using 3072k, total 16384k
[    1.429099] vesafb: mode is 1024x768x16, linelength=2048, pages=9
[    1.429103] vesafb: protected mode interface info at c000:9eec
[    1.429107] vesafb: pmi: set display start = c00c9f8e, set palette = c00ca04c
[    1.429110] vesafb: scrolling: redraw
[    1.429114] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
[    1.546335] Console: switching to colour frame buffer device 128x48
[    1.899660] fbcondecor: console 0 using theme 'sabayon'
[    2.665568] fbcondecor: switched decor state to 'on' on console 0
[    2.667261] fb0: VESA VGA frame buffer device
[    2.667405] vga16fb: initializing
[    2.667410] vga16fb: mapped to 0xc00a0000
[    2.667532] fb1: VGA16 VGA frame buffer device
[    2.667684] input: Power Button (FF) as /class/input/input0
[    2.669045] ACPI: Power Button (FF) [PWRF]
[    2.669254] input: Power Button (CM) as /class/input/input1
[    2.671042] ACPI: Power Button (CM) [PWRB]
[    2.671235] input: Sleep Button (CM) as /class/input/input2
[    2.673049] ACPI: Sleep Button (CM) [SLPB]
[    2.673456] fan PNP0C0B:00: registered as cooling_device0
[    2.673466] ACPI: Fan [FAN] (on)
[    2.674102] ACPI: SSDT 7FEE96C0, 026C (r1  PmRef  Cpu0Ist     3000 INTL 20040311)
[    2.674665] processor ACPI0007:00: registered as cooling_device1
[    2.675022] ACPI: SSDT 7FEE9B80, 0152 (r1  PmRef  Cpu1Ist     3000 INTL 20040311)
[    2.675522] processor ACPI0007:01: registered as cooling_device2
[    2.682743] thermal LNXTHERM:01: registered as thermal_zone0
[    2.683319] ACPI: Thermal Zone [THRM] (25 C)
[    2.683559] isapnp: Scanning for PnP cards...
[    2.996955] isapnp: No Plug & Play device found
[    2.996962] Serial: 8250/16550 driver4 ports, IRQ sharing enabled
[    3.241212] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    3.242584] 00:0c: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    3.257249] FDC 0 is a post-1991 82077
[    3.261086] brd: module loaded
[    3.262215] loop: module loaded
[    3.262218] Compaq SMART2 Driver (v 2.6.0)
[    3.262368] HP CISS Driver (v 3.6.20)
[    3.262911] MM: desc_per_page = 128
[    3.263208] input: Macintosh mouse button emulation as /class/input/input3
[    3.263575] Loading iSCSI transport class v2.0-870.
[    3.264248] iscsi: registered transport (tcp)
[    3.266080] Loading Adaptec I2O RAID: Version 2.4 Build 5go
[    3.266083] Detecting Adaptec I2O RAID controllers...
[    3.266869] Adaptec aacraid driver 1.1-5[2456]-ms
[    3.267482] aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
[    3.267825] NCR53c406a: no available ports found
[    3.267831] sym53c416.c: Version 1.0.0-ac
[    3.267865] qlogicfas: no cards were found, please specify I/O address and IRQ using iobase= and irq= options<6>QLogic Fibre Channel HBA Driver: 8.02.01-k7
[    3.268153] iscsi: registered transport (qla4xxx)
[    3.268237] QLogic iSCSI HBA Driver
[    3.268241] Emulex LightPulse Fibre Channel SCSI driver 8.2.7
[    3.268245] Copyright(c) 2004-2008 Emulex.  All rights reserved.
[    3.290067] Failed initialization of WD-7000 SCSI card!
[    4.057620] DC390: clustering now enabled by default. If you get problems load
[    4.057624] 	with "disable_clustering=1" and report to maintainers
[    4.057795] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[    4.057930] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[    4.058022] megasas: 00.00.04.01 Thu July 24 11:41:51 PST 2008
[    4.058201] GDT-HA: Storage RAID Controller Driver. Version: 3.05
[    4.058428] 3ware Storage Controller device driver for Linux v1.26.02.002.
[    4.058504] 3ware 9000 Storage Controller device driver for Linux v2.26.02.011.
[    4.058585] nsp32: loading...
[    4.058669] ipr: IBM Power RAID SCSI Device Driver version: 2.4.1 (April 24, 2007)
[    4.058751] RocketRAID 3xxx/4xxx Controller driver v1.3 (071203)
[    4.058828] stex: Promise SuperTrak EX Driver version: 3.6.0000.1
[    4.058987] st: Version 20080504, fixed bufsize 32768, s/g segs 256
[    4.059051] Driver 'st' needs updating - please use bus_type methods
[    4.059110] osst :I: Tape driver with OnStream support version 0.99.4
[    4.059112] osst :I: $Id: osst.c,v 1.73 2005/01/01 21:13:34 wriede Exp $
[    4.059167] Driver 'osst' needs updating - please use bus_type methods
[    4.059272] Driver 'sd' needs updating - please use bus_type methods
[    4.059323] Driver 'sr' needs updating - please use bus_type methods
[    4.060013] sata_via 0000:00:0f.0: version 2.3
[    4.060046] sata_via 0000:00:0f.0: PCI INT B -> GSI 21 (level, low) -> IRQ 21
[    4.060093] sata_via 0000:00:0f.0: routed to hard irq line 11
[    4.060182] scsi2 : sata_via
[    4.060366] scsi3 : sata_via
[    4.063062] ata1: SATA max UDMA/133 cmd 0xfc00 ctl 0xf800 bmdma 0xec00 irq 21
[    4.063067] ata2: SATA max UDMA/133 cmd 0xf400 ctl 0xf000 bmdma 0xec08 irq 21
[    4.263138] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    4.464874] ata1.00: ATA-7: ST3160815AS, 4.AAB, max UDMA/133
[    4.464882] ata1.00: 312581808 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    4.539853] ata1.00: configured for UDMA/133
[    4.740109] ata2: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
[    4.740392] scsi 2:0:0:0: Direct-Access     ATA      ST3160815AS      4.AA PQ: 0 ANSI: 5
[    4.740652] sd 2:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
[    4.740677] sd 2:0:0:0: [sda] Write Protect is off
[    4.740681] sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    4.740719] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.740817] sd 2:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
[    4.740838] sd 2:0:0:0: [sda] Write Protect is off
[    4.740842] sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    4.740879] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.740884]  sda: sda1 sda2
[    4.763202] sd 2:0:0:0: [sda] Attached SCSI disk
[    4.763434] sd 2:0:0:0: Attached scsi generic sg0 type 0
[    4.767027] pata_via 0000:00:0f.1: version 0.3.3
[    4.767211] scsi4 : pata_via
[    4.767345] scsi5 : pata_via
[    4.770135] ata3: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xe400 irq 14
[    4.770140] ata4: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xe408 irq 15
[    4.924949] ata3.00: ATAPI: ASUS    CRW-4824AH, 0.89, max UDMA/33
[    4.926623] ata3.01: ATA-7: Maxtor 6L200R0, BAJ41G20, max UDMA/133
[    4.926631] ata3.01: 398297088 sectors, multi 16: LBA48 
[    4.929490] ata3.00: configured for UDMA/33
[    4.936954] ata3.01: configured for UDMA/133
[    5.088805] scsi 4:0:0:0: CD-ROM            ASUS     CRW-4824AH       0.89 PQ: 0 ANSI: 5
[    5.091070] sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray
[    5.091079] Uniform CD-ROM driver Revision: 3.20
[    5.091468] sr 4:0:0:0: Attached scsi CD-ROM sr0
[    5.091682] sr 4:0:0:0: Attached scsi generic sg1 type 5
[    5.091903] scsi 4:0:1:0: Direct-Access     ATA      Maxtor 6L200R0   BAJ4 PQ: 0 ANSI: 5
[    5.092142] sd 4:0:1:0: [sdb] 398297088 512-byte hardware sectors (203928 MB)
[    5.092168] sd 4:0:1:0: [sdb] Write Protect is off
[    5.092172] sd 4:0:1:0: [sdb] Mode Sense: 00 3a 00 00
[    5.092210] sd 4:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    5.092292] sd 4:0:1:0: [sdb] 398297088 512-byte hardware sectors (203928 MB)
[    5.092313] sd 4:0:1:0: [sdb] Write Protect is off
[    5.092317] sd 4:0:1:0: [sdb] Mode Sense: 00 3a 00 00
[    5.092354] sd 4:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    5.092358]  sdb: sdb1
[    5.111854] sd 4:0:1:0: [sdb] Attached SCSI disk
[    5.112029] sd 4:0:1:0: Attached scsi generic sg2 type 0
[    5.112738] I2O subsystem v1.325
[    5.112743] i2o: max drivers = 8
[    5.113017] I2O Configuration OSM v1.323
[    5.113176] I2O Bus Adapter OSM v1.317
[    5.113231] I2O Block Device OSM v1.325
[    5.113485] I2O SCSI Peripheral OSM v1.316
[    5.113539] I2O ProcFS OSM v1.316
[    5.113610] Fusion MPT base driver 3.04.07
[    5.113614] Copyright (c) 1999-2008 LSI Corporation
[    5.113623] Fusion MPT SPI Host driver 3.04.07
[    5.113720] Fusion MPT FC Host driver 3.04.07
[    5.113810] Fusion MPT SAS Host driver 3.04.07
[    5.113898] Fusion MPT misc device (ioctl) driver 3.04.07
[    5.114016] mptctl: Registered with Fusion MPT base driver
[    5.114019] mptctl: /dev/mptctl @ (major,minor=10,220)
[    5.114023] Fusion MPT LAN driver 3.04.07
[    5.114719] usbcore: registered new interface driver usblp
[    5.114724] Initializing USB Mass Storage driver...
[    5.114784] usbcore: registered new interface driver usb-storage
[    5.114789] USB Mass Storage support registered.
[    5.114853] usbcore: registered new interface driver libusual
[    5.115032] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    5.115527] serio: i8042 KBD port at 0x60,0x64 irq 1
[    5.115534] serio: i8042 AUX port at 0x60,0x64 irq 12
[    5.117342] mice: PS/2 mouse device common for all mice
[    5.146550] input: AT Translated Set 2 keyboard as /class/input/input4
[    5.151345] md: linear personality registered for level -1
[    5.151350] md: raid0 personality registered for level 0
[    5.151354] md: raid1 personality registered for level 1
[    5.151359] md: raid10 personality registered for level 10
[    5.168075] raid6: int32x1    453 MB/s
[    5.185051] raid6: int32x2    429 MB/s
[    5.202163] raid6: int32x4    359 MB/s
[    5.219139] raid6: int32x8    316 MB/s
[    5.236008] raid6: mmxx1     1406 MB/s
[    5.253021] raid6: mmxx2     1628 MB/s
[    5.270008] raid6: sse1x1     949 MB/s
[    5.287050] raid6: sse1x2    1238 MB/s
[    5.304013] raid6: sse2x1    1679 MB/s
[    5.321038] raid6: sse2x2    1902 MB/s
[    5.321041] raid6: using algorithm sse2x2 (1902 MB/s)
[    5.321045] md: raid6 personality registered for level 6
[    5.321048] md: raid5 personality registered for level 5
[    5.321051] md: raid4 personality registered for level 4
[    5.321055] md: multipath personality registered for level -4
[    5.321059] md: faulty personality registered for level -5
[    5.321303] device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com
[    5.321415] EDAC MC: Ver: 2.1.0 Dec 20 2008
[    5.321841] EISA: Probing bus 0 at eisa.0
[    5.321897] EISA: Detected 0 cards.
[    5.321971] cpuidle: using governor ladder
[    5.321974] cpuidle: using governor menu
[    5.822139] input: ImExPS/2 Generic Explorer Mouse as /class/input/input5
[    5.827412] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[    5.827571] usbcore: registered new interface driver hiddev
[    5.827631] usbcore: registered new interface driver usbhid
[    5.827636] usbhid: v2.6:USB HID core driver
[    5.828491] TCP bic registered
[    5.828497] NET: Registered protocol family 17
[    5.828815] RPC: Registered udp transport module.
[    5.828818] RPC: Registered tcp transport module.
[    5.829948] Starting balanced_irq
[    5.829993] Using IPI No-Shortcut mode
[    5.830308] TuxOnIce 3.0-rc7 (http://tuxonice.net)
[    5.830414] registered taskstats version 1
[    5.830646] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[    5.831106] Freeing unused kernel memory: 588k freed
[    7.285352] CAPI Subsystem Rev 1.1.2.8
[    7.290949] b1: revision 1.1.2.2
[    7.336134] Linux telephony interface: v1.00
[    7.340261] ixj driver initialized.
[    7.656852] scsi: <fdomain> Detection failed (no card)
[    7.991197] ehci_hcd 0000:00:10.4: PCI INT C -> GSI 21 (level, low) -> IRQ 21
[    7.991223] ehci_hcd 0000:00:10.4: EHCI Host Controller
[    7.992433] ehci_hcd 0000:00:10.4: new USB bus registered, assigned bus number 1
[    7.992485] ehci_hcd 0000:00:10.4: irq 21, io mem 0xfdfff000
[    7.998046] ehci_hcd 0000:00:10.4: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[    7.998855] usb usb1: configuration #1 chosen from 1 choice
[    7.999387] hub 1-0:1.0: USB hub found
[    7.999399] hub 1-0:1.0: 8 ports detected
[    8.157329] USB Universal Host Controller Interface driver v3.0
[    8.157511] uhci_hcd 0000:00:10.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[    8.157529] uhci_hcd 0000:00:10.0: UHCI Host Controller
[    8.158317] uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
[    8.158364] uhci_hcd 0000:00:10.0: irq 20, io base 0x0000e000
[    8.159043] usb usb2: configuration #1 chosen from 1 choice
[    8.159178] hub 2-0:1.0: USB hub found
[    8.159190] hub 2-0:1.0: 2 ports detected
[    8.362158] uhci_hcd 0000:00:10.1: PCI INT B -> GSI 22 (level, low) -> IRQ 22
[    8.362173] uhci_hcd 0000:00:10.1: UHCI Host Controller
[    8.362970] uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
[    8.363014] uhci_hcd 0000:00:10.1: irq 22, io base 0x0000dc00
[    8.363714] usb usb3: configuration #1 chosen from 1 choice
[    8.363853] hub 3-0:1.0: USB hub found
[    8.363864] hub 3-0:1.0: 2 ports detected
[    8.566122] uhci_hcd 0000:00:10.2: PCI INT C -> GSI 21 (level, low) -> IRQ 21
[    8.566144] uhci_hcd 0000:00:10.2: UHCI Host Controller
[    8.566941] uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
[    8.566975] uhci_hcd 0000:00:10.2: irq 21, io base 0x0000d800
[    8.567660] usb usb4: configuration #1 chosen from 1 choice
[    8.567790] hub 4-0:1.0: USB hub found
[    8.567801] hub 4-0:1.0: 2 ports detected
[    8.770118] uhci_hcd 0000:00:10.3: PCI INT D -> GSI 23 (level, low) -> IRQ 23
[    8.770139] uhci_hcd 0000:00:10.3: UHCI Host Controller
[    8.770916] uhci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 5
[    8.770959] uhci_hcd 0000:00:10.3: irq 23, io base 0x0000d400
[    8.771666] usb usb5: configuration #1 chosen from 1 choice
[    8.771807] hub 5-0:1.0: USB hub found
[    8.771819] hub 5-0:1.0: 2 ports detected
[    9.055624] ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
[    9.104478] sl811: driver sl811-hcd, 19 May 2005
[    9.270810] Intel(R) PRO/1000 Network Driver - version 7.3.20-k3-NAPI
[    9.270816] Copyright (c) 1999-2006 Intel Corporation.
[   14.673402] kjournald starting.  Commit interval 5 seconds
[   14.673417] EXT3-fs: mounted filesystem with ordered data mode.
[   18.088178] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   18.092661] parport_pc 00:0d: reported by Plug and Play ACPI
[   18.092717] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
[   18.124273] via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
[   18.124283] via-rhine: Broken BIOS detected, avoid_D3 enabled.
[   18.124388] via-rhine 0000:00:12.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[   18.129047] eth0: VIA Rhine II at 0x1d000, 00:e0:4d:57:df:37, IRQ 23.
[   18.129767] eth0: MII PHY found at address 1, status 0x786d advertising 01e1 Link 45e1.
[   18.159977] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   18.168554] agpgart: Detected VIA P4M890 chipset
[   18.181083] agpgart-via 0000:00:00.0: AGP aperture is 128M @ 0xd8000000
[   18.245682] input: PC Speaker as /class/input/input6
[   18.331059] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[   18.373889] [fglrx] Maximum main memory to use for locked dma buffers: 1889 MBytes.
[   18.374807] [fglrx]   vendor: 1002 device: 94c3 count: 1
[   18.376655] [fglrx] ioport: bar 4, base 0xbc00, size: 0x100
[   18.376688] pci 0000:02:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
[   18.376696] pci 0000:02:00.0: setting latency timer to 64
[   18.377744] [fglrx] Pat entry 2 is already configured
[   18.377747] [fglrx] PAT is enabled successfully!
[   18.380326] [fglrx] module loaded - fglrx 8.55.2 [Oct 28 2008] with 1 minors
[   18.380594] ppdev: user-space parallel port driver
[   18.548329] HDA Intel 0000:02:00.1: PCI INT B -> GSI 25 (level, low) -> IRQ 25
[   18.548409] HDA Intel 0000:02:00.1: setting latency timer to 64
[   18.548420] HDA Intel 0000:02:00.1: PCI: Disallowing DAC for device
[   18.574460] HDA Intel 0000:80:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   18.574516] HDA Intel 0000:80:01.0: setting latency timer to 64
[   18.574524] HDA Intel 0000:80:01.0: PCI: Disallowing DAC for device
[   18.583966] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
[   20.071775] rtc_cmos 00:08: rtc core: registered rtc_cmos as rtc0
[   20.071884] rtc0: alarms up to one year, y3k, hpet irqs
[   21.823780] EXT3 FS on dm-0, internal journal
[   22.248425] kjournald starting.  Commit interval 5 seconds
[   22.248743] EXT3 FS on sda1, internal journal
[   22.248752] EXT3-fs: mounted filesystem with ordered data mode.
[   28.604627] Adding 1015800k swap on /dev/mapper/VolGroup00-LogVol01.  Priority:-1 extents:1 across:1015800k
[   30.029407] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   30.201083] fbcondecor: console 1 using theme 'sabayon'
[   30.523353] fbcondecor: switched decor state to 'on' on console 1
[   30.640565] NET: Registered protocol family 10
[   30.641892] lo: Disabled Privacy Extensions
[   30.911151] fbcondecor: console 2 using theme 'sabayon'
[   31.203519] fbcondecor: switched decor state to 'on' on console 2
[   31.537424] fbcondecor: console 3 using theme 'sabayon'
[   31.838753] fbcondecor: switched decor state to 'on' on console 3
[   31.953587] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[   31.971285] NFSD: starting 90-second grace period
[   32.133871] fbcondecor: console 4 using theme 'sabayon'
[   32.504131] fbcondecor: switched decor state to 'on' on console 4
[   32.567420] [fglrx] Reserved FB block: Shared offset:0, size:1000000 
[   32.567447] [fglrx] Reserved FB block: Unshared offset:ff73000, size:88000 
[   32.567452] [fglrx] Reserved FB block: Unshared offset:fffc000, size:4000 
[   32.867564] fbcondecor: console 5 using theme 'sabayon'
[   33.146955] fbcondecor: switched decor state to 'on' on console 5
[   41.212347] eth0: no IPv6 routers present
[   58.065173] eth0: no IPv6 routers present
aplay -l

localhost sircody # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: VT82xx [HDA VIA VT82xx], device 0: ALC662 Analog [ALC662 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: VT82xx [HDA VIA VT82xx], device 1: ALC662 Digital [ALC662 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

ok thats lspci dmesg and aplay -l i have more then one device butthe second device is my video card useing hdmi t i dont use hdmi so really i only should have one device setup and thats the vt1708/a i tired rmmod snd_hda_intel then modprobe snd_hda_intel didnt work
 
Old 01-09-2009, 05:37 PM   #11
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
This should help;
http://www.linuxquestions.org/questi...d-card-325694/
 
Old 01-09-2009, 06:08 PM   #12
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
this one is your real nice ati graphics card with built in HDMI so the midi side of that card is shown in the lspci | grep audio so go in to your sound program the one that does sound events that is your sound server and set it up as out or alsa that may be your problem so it comes to configuring things every thing is loaded
 
Old 01-09-2009, 10:36 PM   #13
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
rhytmbox has no option or jukb music player ha no option for setting device or setting output
 
Old 01-10-2009, 10:55 AM   #14
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
how do i make card 1 (the vt1708/a or vt82xx) card 0 im not useing my ati graphics card as my sound card im not useing hdmi.
 
Old 01-10-2009, 11:20 AM   #15
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Are you reading any of the links I take the time to put here?
http://alsa.opensrc.org/index.php/MultipleCards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while initializing the sound driver maybbach Linux - Hardware 1 06-08-2006 11:32 PM
Error while initializing the sound driver. duffmckagan Slackware 11 01-11-2006 09:31 AM
Sound server informational message: Error while initializing the sound driver... LA004 Linux - Hardware 4 08-21-2005 09:25 PM
Error while initializing the sound driver mohapi Linux - General 3 04-22-2005 02:06 PM
<<Error while initializing the sound driver>> eloyj88 Slackware 4 07-29-2004 11:44 PM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration