LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2009, 12:08 PM   #16
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15

yes im currently looking at the one u just posted and folowing the steps as i read along
 
Old 01-10-2009, 06:37 PM   #17
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
they didnt work i still get the error message after folowing what they said to do and no audio at all either
 
Old 01-10-2009, 06:52 PM   #18
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Is that on Debian?
post /etc/modules.d/alsa-base or if you don't have that;
/etc/modules.d/alsa

You need to give more information on what you have done, or everything is just a guess.

Here is how I do it but I am not on debian;
Multiple sound cards

You can have more than one sound card in your system simultaneously, provided that you have built ALSA as modules in your kernel. You just need to specify which should be started first in /etc/modules.d/alsa. Your cards are identified by their driver names inside this file. 0 is the first card, 1 is the second, and so on. Here's an example for a system with two sound cards.

options snd-emu10k1 index=0
options snd-via82xx index=1

index=0 will be your default sound card

After you edit that file you will need to restart alsa or reboot for the changes to take effect.

You may be better off just blacklisting the module for your video cards audio device if that is possible.

Last edited by comprookie2000; 01-10-2009 at 07:18 PM.
 
Old 01-10-2009, 08:26 PM   #19
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
ok all the information: im useing sabayon linux 4.0 r1

lspci | grep audio

02:00.1 Audio device: ATI Technologies Inc RV610 audio device [Radeon HD 2400 PRO]
80:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)


aplay -l

localhost sircody # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: VT82xx [HDA VIA VT82xx], device 0: ALC662 Analog [ALC662 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: VT82xx [HDA VIA VT82xx], device 1: ALC662 Digital [ALC662 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

step 1: localhost sircody # rmmod snd_hda_intel
step 2: localhost sircody # modprobe snd_hda_intel ALC662
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.27-sabayon/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
localhost sircody # modprobe snd_hda_intel 834
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.27-sabayon/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
localhost sircody # modprobe snd-hda-intel alc662
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.27-sabayon/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
localhost sircody # modprobe snd-hda-intel 835
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.27-sabayon/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg:
[ 19.109936] HDA Intel 0000:02:00.1: PCI INT B -> GSI 25 (level, low) -> IRQ 25
[ 19.110038] HDA Intel 0000:02:00.1: setting latency timer to 64
[ 19.110050] HDA Intel 0000:02:00.1: PCI: Disallowing DAC for device
[ 19.136460] HDA Intel 0000:80:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 19.136503] HDA Intel 0000:80:01.0: setting latency timer to 64
[ 19.136510] HDA Intel 0000:80:01.0: PCI: Disallowing DAC for device
[ 19.145961] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...

[ 226.349889] HDA Intel 0000:80:01.0: PCI INT A disabled
[ 226.352832] HDA Intel 0000:02:00.1: PCI INT B disabled
[ 235.105012] snd_hda_intel: Unknown parameter `ALC662'
[ 310.493587] snd_hda_intel: Unknown parameter `834'
[ 336.632701] snd_hda_intel: Unknown parameter `alc662'
[ 365.676409] snd_hda_intel: Unknown parameter `835'

etc/modules.d/alsa:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.18 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---

etc/modprobe.d/alsa:
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
## alias snd-card-0 snd-hda-intel
## alias snd-card-1 snd-ens1371
## OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
## OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

in step two it states to do modeprobe snd-hda-intel then use "your modle name" useing the chart above the line that has my card
834 ALC662
835 3stack-dig 3-stack (2-channel) with SPDIF


my process for the name alc662:

localhost sircody # rmmod snd_hda_intel
localhost sircody # modprobe snd_hda_intel model=ALC662
localhost sircody # dmesg | grep hda
[ 20.779946] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
[ 4467.442757] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
[ 4629.029548] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
[ 4821.689137] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
 
Old 01-10-2009, 09:04 PM   #20
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
From the kernel doc /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt
Code:
	ALC662/663
	  3stack-dig	3-stack (2-channel) with SPDIF
	  3stack-6ch	 3-stack (6-channel)
	  3stack-6ch-dig 3-stack (6-channel) with SPDIF
	  6stack-dig	 6-stack with SPDIF
	  lenovo-101e	 Lenovo laptop
	  eeepc-p701	ASUS Eeepc P701
	  eeepc-ep20	ASUS Eeepc EP20
	  ecs		ECS/Foxconn mobo
	  m51va		ASUS M51VA
	  g71v		ASUS G71V
	  h13		ASUS H13
	  g50v		ASUS G50V
	  asus-mode1	ASUS
	  asus-mode2	ASUS
	  asus-mode3	ASUS
	  asus-mode4	ASUS
	  asus-mode5	ASUS
	  asus-mode6	ASUS
	  auto		auto-config reading BIOS (default)
I would try;
options snd cards_limit=1
options snd_hda_intel index=0
options snd_hda_intel model="one of the above"
then
/etc/init.d/alsasound restart
 
Old 01-10-2009, 09:12 PM   #21
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
one of the above is like 3stack-dig or auto correct not alc662 and i would write this in etc/modules.d/alsa or etc/modprobe.d/alsa

Last edited by bloodyscript; 01-10-2009 at 09:16 PM.
 
Old 01-10-2009, 09:34 PM   #22
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
First to get a clean file to work with I would run;
alsaconf

1. yes
2. at the bottom of
/etc/modules.d/alsa

/etc/init.d/alsasound restart

You will get it working, It can be a pain sometimes, The only problem you may run into is the modprobe errors. sabayon is a patched together version of gentoo that does not like to be played with from the initial install.

http://www.gentoo.org/doc/en/alsa-guide.xml

When you ask questions the next time make sure to include the distro as they all do thing a little different.

Last edited by comprookie2000; 01-10-2009 at 09:36 PM.
 
Old 01-10-2009, 10:17 PM   #23
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
ok mayb this will help sounds works in kaffine media player with no problem oncew i open juk music player it opens up the error message sound distorts a lil bit bu not that bad
 
Old 01-11-2009, 11:43 AM   #24
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
after the rewrite of etc/modules.d/alsa sounds woks in kaffine and nothing else everyhting else displays the error message
 
Old 01-11-2009, 01:07 PM   #25
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
The problem is the RV610 uses snd-hda-intel
and your via uses snd-hda-intel
 
Old 01-11-2009, 01:32 PM   #26
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
is it an easy file that i have to rewrite or do i need to recompile the kernel
 
Old 01-11-2009, 02:17 PM   #27
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
I think you will need to create an .asoundrc file
http://alsa.opensrc.org/.asoundrc

Not much to do in the kernel because you need snd-hda-intel.
 
Old 01-12-2009, 11:51 AM   #28
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
pcm.!default front:VT82xx{
type hw:0,0
card 0
device 0
}
ctl.!default {
type hw:0,0
card 0
}


my .asoundrc file so far
 
Old 01-12-2009, 03:30 PM   #29
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Is the vt82xx showing up with alsamixer
or
alsamixer -c 1

alsamixer == hw:0
alsamixer -c 1 == hw:1
 
Old 01-12-2009, 06:35 PM   #30
bloodyscript
Member
 
Registered: Apr 2006
Distribution: Sabayon linux 5.1
Posts: 182

Original Poster
Rep: Reputation: 15
ok alsamixer -c 1 works to get vt82xx so that would mean to change

pcm.!default front:VT82xx{
type hw:0,0
card 0
device 0
}
ctl.!default {
type hw:0,0
card 0
}

to

pcm.!default front:VT82xx{
type hw:1,1
card 1
device 1
}
ctl.!default {
type hw:1,1
card 1
}

or

pcm.!default front:VT82xx{
type hw:1,0
card 1
device 0
}
ctl.!default {
type hw:1,0
card 1
}

or

pcm.!default front:VT82xx{
type hw:0,0
card 1
device 1
}
ctl.!default {
type hw:0,0
card 1
}

currently its set up is this

pcm.!default front:VT82xx{
type hw:0,0
card 1
device 1
}
ctl.!default {
type hw:0,0
card 1
}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while initializing the sound driver maybbach Linux - Hardware 1 06-08-2006 11:32 PM
Error while initializing the sound driver. duffmckagan Slackware 11 01-11-2006 09:31 AM
Sound server informational message: Error while initializing the sound driver... LA004 Linux - Hardware 4 08-21-2005 09:25 PM
Error while initializing the sound driver mohapi Linux - General 3 04-22-2005 02:06 PM
<<Error while initializing the sound driver>> eloyj88 Slackware 4 07-29-2004 11:44 PM


All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration