LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-23-2006, 03:50 PM   #1
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Rep: Reputation: 30
EPSON Stylus Photo R200 - CUPS+Gimp-Print v4.2.7 does not print anymore


I do not know why, but i found this error on CUPS page:

Printer State: stopped, accepting jobs.
"Unable to open USB device "usb://EPSON/Stylus%20Photo%20R220": No such device"
Device URI: usb://EPSON/Stylus%20Photo%20R220

I am using Slackware 10.2 with kernel 2.6.16.11 and KDE 3.5.2 that i recently compiled for athlon-xp.
No problems since last week and i have not upgraded my linux box.

I disconnected the printer and i run tail -f /var/log/messages
May 23 21:16:28 hell -- MARK --
May 23 21:36:28 hell -- MARK --
May 23 21:56:28 hell -- MARK --
May 23 22:09:25 hell kernel: usb 2-2: USB disconnect, address 2
May 23 22:09:25 hell kernel: drivers/usb/class/usblp.c: usblp0: removed
May 23 22:10:10 hell kernel: usb 2-2: new full speed USB device using uhci_hcd and address 3
May 23 22:10:11 hell kernel: usb 2-2: configuration #1 chosen from 1 choice
May 23 22:10:11 hell kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0005
May 23 22:10:57 hell kernel: usb 2-2: USB disconnect, address 3
May 23 22:10:57 hell kernel: drivers/usb/class/usblp.c: usblp0: removed

Than i reconnected the printer and the new message is:

May 23 22:11:45 hell kernel: usb 2-1: new full speed USB device using uhci_hcd and address 4
May 23 22:11:45 hell kernel: usb 2-1: configuration #1 chosen from 1 choice
May 23 22:11:45 hell kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0005


Thank you in advance for any help.
 
Old 05-24-2006, 10:59 AM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I think you have to restart cups if the printer is switched on afterwards. Seem to remember to have read something like that for the R300.

Last edited by Wim Sturkenboom; 05-24-2006 at 11:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Epson Stylus C60 will not print scuzzman Linux - Hardware 4 10-15-2005 12:23 PM
Epson Stylus C44+ doesn't print (no error message) addy86 Linux - Hardware 2 09-15-2005 11:51 AM
Search for Drivers Epson stylus photo R200 artems Linux - Hardware 2 07-14-2005 11:20 AM
epson stylus color 850 won't print shotokan Linux - Hardware 4 05-23-2005 01:48 PM
Photo print with Gimp FF103 Linux - Software 6 05-19-2004 04:02 PM


All times are GMT -5. The time now is 02:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration