LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   EPSON Stylus Photo R200 - CUPS+Gimp-Print v4.2.7 does not print anymore (http://www.linuxquestions.org/questions/linux-newbie-8/epson-stylus-photo-r200-cups-gimp-print-v4-2-7-does-not-print-anymore-447830/)

Harp00 05-23-2006 04:50 PM

EPSON Stylus Photo R200 - CUPS+Gimp-Print v4.2.7 does not print anymore
 
I do not know why, but i found this error on CUPS page:

Printer State: stopped, accepting jobs.
"Unable to open USB device "usb://EPSON/Stylus%20Photo%20R220": No such device"
Device URI: usb://EPSON/Stylus%20Photo%20R220

I am using Slackware 10.2 with kernel 2.6.16.11 and KDE 3.5.2 that i recently compiled for athlon-xp.
No problems since last week and i have not upgraded my linux box.

I disconnected the printer and i run tail -f /var/log/messages
May 23 21:16:28 hell -- MARK --
May 23 21:36:28 hell -- MARK --
May 23 21:56:28 hell -- MARK --
May 23 22:09:25 hell kernel: usb 2-2: USB disconnect, address 2
May 23 22:09:25 hell kernel: drivers/usb/class/usblp.c: usblp0: removed
May 23 22:10:10 hell kernel: usb 2-2: new full speed USB device using uhci_hcd and address 3
May 23 22:10:11 hell kernel: usb 2-2: configuration #1 chosen from 1 choice
May 23 22:10:11 hell kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0005
May 23 22:10:57 hell kernel: usb 2-2: USB disconnect, address 3
May 23 22:10:57 hell kernel: drivers/usb/class/usblp.c: usblp0: removed

Than i reconnected the printer and the new message is:

May 23 22:11:45 hell kernel: usb 2-1: new full speed USB device using uhci_hcd and address 4
May 23 22:11:45 hell kernel: usb 2-1: configuration #1 chosen from 1 choice
May 23 22:11:45 hell kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0005


Thank you in advance for any help.

Wim Sturkenboom 05-24-2006 11:59 AM

I think you have to restart cups if the printer is switched on afterwards. Seem to remember to have read something like that for the R300.


All times are GMT -5. The time now is 07:08 AM.