LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-21-2005, 05:39 PM   #1
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Rep: Reputation: 30
epson stylus color 850 won't print


I have an EPSON Stylus Color 850.
The driver is Gimp-Print v4.2.7 [English] I configured it with CUPS.
My distro is slackware 10, kernel is 2.6.8.1.

When I use the "KDE Print" add printer wizard, I run into a problem on the printer test.
It says:"Test page successfully sent to printer. Wait until printing is complete, then click the OK button."

Nothing happens.(it doesn't print) At the same time, the terminal I'm running it in says:
"kcontrol: WARNING: KFilterBase::findFilterByExtension : no filter found for text/plain"
 
Old 05-21-2005, 08:34 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Make sure you have foomatic installed.
 
Old 05-22-2005, 01:14 PM   #3
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Original Poster
Rep: Reputation: 30
I installed foomatic-db-20050521, foomatic-db-engine-3.0-20050521, foomatic-db-hpijs-1.5-20050521, and foomatic-filters-3.0-20050521
but the same thing still happens.

Should I re-install gimp print?
 
Old 05-22-2005, 10:14 PM   #4
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Original Poster
Rep: Reputation: 30
Well it's working now, thanks comprookie2000 it turns out I had to restart my print server, it was easy with kde print.
 
Old 05-23-2005, 01:48 PM   #5
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Original Poster
Rep: Reputation: 30
Well, I rebooted my computer and found out that before I had restarted the printer server I did these commands:
Code:
modprobe lp
modprobe parport
modprobe parport_pc
modprobe usblp
modprobe printer
Then linux could see the printer.
But, I tried printing again and a bunch of ink was scratched on the paper in lines. I did it again with various documents and the same thing happend.

I don't know what the problem was, but it wasn't the ink or printer because my dad is using it on his computer, and it's fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie - Epson stylus color 480 parallel - wont print. nmoog Linux - Hardware 3 05-06-2004 06:35 AM
Epson Stylus Color 777 printer won't print on Fedora Core 1 jtong77 Linux - Newbie 0 03-15-2004 10:28 PM
Why does Konqueror 3.1.1 crash when asked to print on an Epson Stylus Color 600? swved Linux - Software 2 10-21-2003 06:16 PM
Red Hat 8 & Epson Stylus Color 850 bigmista Linux - Hardware 6 01-19-2003 04:30 AM
Red Hat 8.0 & Epson Stylus Color 850 bigmista Linux - Newbie 2 11-04-2002 06:56 PM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration