LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-10-2002, 02:55 AM   #1
josefsvejk
LQ Newbie
 
Registered: Dec 2001
Posts: 2

Rep: Reputation: 0
Unhappy Trouble with 3Com Etherlink III card


I've got an old 3Com etherlinkII card, with the 3C509/3C509b chipset. The thing works fine under winblows, but I'm not sure how to set it up under Linux, since pnpdump won't detect it (evidently winblows switched off pnp for the card). What commands do I need to feed the shell (I know the card's IRQ and DMA) to get it hopping? I'm trying to turn this box into a router, so this'll be eth1.

Thanks!
 
Old 01-10-2002, 03:09 AM   #2
neil
Member
 
Registered: Jul 2001
Location: Kent, UK
Distribution: AIX/Gentoo/Fedora/Solaris 8/9/10
Posts: 100

Rep: Reputation: 15
Is it an ISA card then?
 
Old 01-10-2002, 03:16 AM   #3
josefsvejk
LQ Newbie
 
Registered: Dec 2001
Posts: 2

Original Poster
Rep: Reputation: 0
Yes, it is indeed an ISA card, I believe with pnp deactivated (and none of those nice little dipswitches either). Apparently this chipset works a little differently than other ISA cards.
 
Old 01-10-2002, 03:43 AM   #4
neil
Member
 
Registered: Jul 2001
Location: Kent, UK
Distribution: AIX/Gentoo/Fedora/Solaris 8/9/10
Posts: 100

Rep: Reputation: 15
I had the same trouble. This is where you need to find the module and load it manually. I do not know why this is not found by the OS! but there is a module for the Etherlink III.
My problem was finding what the module was called. I think I found it in a book in the end and it wasnt what I expected it to be.
Once it had loaded I could configure the IP details no problem. The next problem was the OS finding the card on a reboot!
I then ran into more serious problems elsewhere and didn't manage to fix that. Although a script in the start up would have sorted it out.
Sorry I cant remember the module name. Its something like 3c509B. So to load
# insmod 3c509B

There is a way to search for the modules on your system that can be used.
 
Old 01-10-2002, 04:06 AM   #5
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
Have you tried the isapnp command?
Read about it in the man pages, man isapnp
I haven't tried this my self, at least not recently.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3Com Etherlink III on Fedora kurtucky Linux - Hardware 10 07-08-2004 01:44 PM
Trouble detecting 3com etherlink III tymanrocks Linux - Hardware 4 04-18-2004 11:57 AM
3Com Etherlink III ISA card. comaptable? e1000 Linux - Networking 3 12-12-2003 04:47 AM
3com etherlink III card dxdad Linux - Networking 2 12-05-2003 11:26 AM
3com etherlink III card eweborg Linux - Networking 10 03-16-2002 01:46 PM


All times are GMT -5. The time now is 10:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration