LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 10-08-2005, 01:13 PM   #1
sydonn
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Synaptics touchpad on Compaq laptop


Hi!

I have a Synaptics touchpad on a Compay laptop. I am using Fecdora Core 4. Like man others I wish to turn off the tapping feature. I've altered the setting on /etc/X11/xorg.conf to maxtaptime = 0, maxtapmove =0.

However, there is one feature I haven't managed to remove: On Mozilla Firefox - by dragging left and right on the bottom part of the pad - the "Back" and "Next" commands are activated. Is there any way of either:

1. Turning off these features on the mouse.
2. Adjusting Firefox so as not to accept these commands?

Thanks.
 
Old 10-08-2005, 01:27 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Yes, start-up Firefox, and in the location bar enter "about:config" (without the quotes). You'll be presented with a screen of configuration options. Scroll down to:

mousewheel.horizscroll.withnokey.action

Double-click the entry and set the value to "0" (zero, again without the quotes). Down a few entries, double-click the entry:

mousewheel.horizscroll.withnokey.sysnumlines

to set its value to "true".

That should do it. Horozontal scrolling, if enabled in your Synaptics configuration, will now horizontally scroll pages in Firefox (as you would expect).
 
Old 10-08-2005, 01:46 PM   #3
sydonn
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Original Poster
Rep: Reputation: 0
thanks

Thanks for your swift reply,

I was actually trying to disable this option, so the opposite would be true

I have found another method of disabling the horizontal scrolling, simply by adding the following line to xorg.cong:

Option "HorizScrollDelta" "0"
 
Old 10-08-2005, 02:05 PM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
The option changes I had listed will give you true horizontal scrolling, instead of the back and forward functions that Firefox has as a default. Horizontal scrolling is useful (as is vertical scrolling). To each his own.
 
Old 12-18-2005, 10:29 AM   #5
prh
Member
 
Registered: Feb 2005
Location: Southampton, UK
Distribution: Mandrake/Mepis
Posts: 33

Rep: Reputation: 15
Quote:
Originally Posted by sydonn
Hi!

I have a Synaptics touchpad on a Compay laptop. I am using Fecdora Core 4. Like man others I wish to turn off the tapping feature. I've altered the setting on /etc/X11/xorg.conf to maxtaptime = 0, maxtapmove =0.
Hi,
I've just done this on my laptop bu it has made no difference, the mousepad tap still works, is there anything else I can do?
Thanks
 
Old 12-18-2005, 11:56 PM   #6
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Did you remember to logout, then restart X (ctrl-alt-backspace)? Did you set the options in the correct section? For example:

Code:
Section "InputDevice"
    Identifier     "Synaptics"
    Driver         "synaptics"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "auto-dev"
    Option         "Emulate3Buttons" "no"
    Option         "ShmConfig" "on"
    Option         "MaxTapTime" "0"
    Option         "TapButton1" "0"
    Option         "TapButton2" "0"
    Option         "TapButton3" "0"
        #Option "HorizScrollDelta" "0"
EndSection
 
  


Reply

Tags
touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 03:15 PM
Subtle synaptics touchpad problem on Compaq R4000 bear.remien Linux - Laptop and Netbook 0 11-30-2005 02:45 PM
Synaptics touchpad beatupbilly Linux - Hardware 6 11-28-2004 11:43 AM
Mandrake 10 CE Compaq Laptop Touchpad Mouse Issue KaiserSoze860 Mandriva 1 04-08-2004 11:28 AM
Synaptics Touchpad beatupbilly Fedora 2 01-14-2004 11:14 PM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration