LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 09-09-2005, 06:02 PM   #1
sarysa
LQ Newbie
 
Registered: Oct 2004
Location: CA
Distribution: Fedora Core 4
Posts: 14

Rep: Reputation: 0
Need to kill touchpad click. (Synaptics Touchpad / FC4)


Newbie alert. I need any help dumbed down to command-line step-by-step.

So I upgraded to try to fix problems with other drivers. (sorta worked) Now I'm having problems with my Synaptics Touchpad! I need to get touch-click disabled. So I tried another thread, they said to use drivers at:

http://compass.com/synaptics/

and enter in something etc. etc.

But I can't even figure out how to install it. Even the readme only tells me what to do -after- it's been installed. *edit* btw, I did figure out how to install this. It just wouldn't work...

So my questions are...
Which files do I download from there and what _exactly_ do I enter in the command line to make it install?
What else do I need to do to ensure that touchpad click never turns on again after another reboot?

Thanks in advance to anyone who can help...this touchpad thing is really crippling me right now.

sary

Original post I read before bothering everyone with a new thread:
http://www.linuxquestions.org/questi...touchpad+click

Last edited by sarysa; 09-10-2005 at 09:29 PM.
 
Old 09-09-2005, 07:33 PM   #2
sarysa
LQ Newbie
 
Registered: Oct 2004
Location: CA
Distribution: Fedora Core 4
Posts: 14

Original Poster
Rep: Reputation: 0
Some more information:
I'm not interested in keeping -any- of the touchpad features...except obviously move and the two click buttons. I will happily take a suggestion that'll disable them all, or is "just a hack" and has minor side effects. I mean, what's different between FC2 (apparently that's what I had before, not FC3) and FC4? What can I do that FC2 did that disabled all those annoying Touchpad extra features? (even though it didn't position the mouse exactly right after moving it...even THAT is less annoying than tap-to-click...)
 
Old 09-10-2005, 09:24 PM   #3
sarysa
LQ Newbie
 
Registered: Oct 2004
Location: CA
Distribution: Fedora Core 4
Posts: 14

Original Poster
Rep: Reputation: 0
I figured it out after way too many hours. :/ I'm going to post what I did here:

After trying a million links, stressing out, and needing to linux rescue twice, I did the following:

http://web.telia.com/~u89404340/touchpad/files/
That's where you can get the synaptics driver. Either their INSTALL or README file has instructions, yay! Instructions are a good thing.

Once I got that installed and followed the instructions, I needed something to manipulate it with to turn of all those annoying features. Here:

http://gsynaptics.sourceforge.jp/
This is the GUI control panel that, again, has directions you can follow AND tells you where it was installed to. (seriously, I have another GUI control panel in whoknowswhere on my system) Great for s like me. =p

May no one ever again have to deal with annoying overfeatured touchpads! Seriously, there's this one thing where you tap and it goes back a page on Mozilla. -What- were they thinking?! That pad's there to move your cursor. Going back a page is what backspace is for. etc. etc. [/rant]

sary
 
Old 09-15-2006, 11:49 AM   #4
culturejam
LQ Newbie
 
Registered: Sep 2004
Location: Hopatcong, NJ
Distribution: Debian
Posts: 26

Rep: Reputation: 15
Thank you so much for posting this! I was going nuts with my touchpad clicking every damn button/link I passed over.

I'm running Kubuntu 6.06 on a Presario 720US. By default, tapping is enabled, but there is no way to turn it off out of the box. I installed the ksynaptics GUI and I unchecked the "enable tapping" box in the System Settings subsection labeled "Touch Pad" (which appeared after I installed ksynaptics). However, tapping has not been disabled. Changing things with ksynaptics doesn't seem to do anything. I've even rebooted just to see that would help. No dice.

Using Adept, I can see that I have xserver-xorg-input-synaptics installed (the description says "Synaptics TouchPad driver for X.org Server"). I'm assuming this is the driver that I need.

Anyone have any ideas?

Last edited by culturejam; 09-15-2006 at 12:12 PM.
 
Old 02-19-2007, 04:15 PM   #5
jmstanleyjr
LQ Newbie
 
Registered: Feb 2007
Distribution: Mepis
Posts: 1

Rep: Reputation: 0
Debian

culturejam,

I have a Fujitsu laptop, Mepis, debian distro, SimplMepis 6.0 which is ubuntu release. I too had issues with disabling tapping, and spent many hours figuring it out. (as a newb)

In /etc/X11 is xorg.conf. In my case after some debugging with synclient. I figured out that the device settings were using ps/2 emulation and therefore any changes in xorg.conf with regard to synaptic device were being ignored. The KDE gui for changing settings had no effect.

My solution was to edit xorg.conf(as root)(urge you to make a backup).
comment out the line (ie add # in front of)
that reads
InputDevice "PS/2 Mouse" "CorePointer"
uncomment the line that reads:
InputDevice "Touchpad" "CorePointer"

then scroll down until you get to the device section:
Section "InputDevice"
Identifier "Touchpad"
Driver "synaptics"

and add the following lines:
Option "TapButton0" "0"
Option "TapButton1" "0"
Option "TapButton2" "0"

restart x by pressing ctrl alt bkspace.
and log in again.
mouse pad now werks but tapping is disabled. whew!
Hope this help in some way.
 
  


Reply

Tags
synaptic, tapping, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
synaptics touchpad with 2.6.14 dracolich Linux - General 10 11-11-2005 02:46 PM
stop synaptics touchpad tap click easily Frank Leone Linux - Newbie 6 10-30-2005 06:44 PM
Synaptics touchpad on FC4? sancho Linux - Laptop and Netbook 7 10-27-2005 10:25 PM
Synaptics Touchpad beatupbilly Fedora 2 01-15-2004 12:14 AM
synaptics touchpad d_lake Linux - Hardware 5 02-09-2003 12:01 AM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration