LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-30-2004, 07:52 AM   #1
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Rep: Reputation: 30
hdparm -d1 /dev/hda gives me "HDIO_SET_DMA failed: Operation not permitted"


I was trying to enable DMA on my disk (with hdparm -d1 /dev/hda) when I got the " "HDIO_SET_DMA failed: Operation not permitted" message.
What could cause this?
How do I solve it, I would like to be able to activate that DMA...

tnx,
elluva
 
Old 11-30-2004, 01:03 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
is DMA enabled in the kernel???
 
Old 11-30-2004, 03:03 PM   #3
geraldomanaus
Member
 
Registered: Nov 2002
Location: Amazonas/Brasil (Rain Forest)
Distribution: GNU/Slackware
Posts: 43

Rep: Reputation: 15
Hello, friends,

You have to enable the chipset module for your motherboard in the Kernel configuration.
 
Old 12-01-2004, 09:32 AM   #4
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by geraldomanaus
Hello, friends,

You have to enable the chipset module for your motherboard in the Kernel configuration.
tnx, that was the problem

grtz,
elluva
 
Old 12-28-2004, 12:31 PM   #5
ehrhardt
LQ Newbie
 
Registered: Dec 2004
Posts: 2

Rep: Reputation: 0
But how do you enable the chipset for your motherboard?

I needed to do exactly the same thing on my machine. Understanding english does not mean I knew how to

Quote:
enable the chipset module for your motherboard in the Kernel configuration.
So I googled the web to figure out, how to do it. And this is how:

run the 'lspci -v' command, from the output try to find the name/vendor of the IDE interface chip:
Code:
.
.
.
00:0f.0 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
        Subsystem: Elitegroup Computer Systems: Unknown device 1b41
        Flags: bus master, medium devsel, latency 32
        I/O ports at dc00 [size=16]
        Capabilities: [c0] Power Management version 2
.
.
.
The chip that controls access to the IDE bus on my motherboard is the: "VIA VT82Cxxxx".

Armed with this knowledge you can 'enable the chipset module for your motherboard in the Kernel configuration' and build a new kernel:
If you're using 'make xconfig' to configure your kernel the find the "ATA/IDE/MFM/RLL support" menu/button. From there click on the "IDE, ATA and ATAPI Block devices" button. Under the "PCI IDE chipset support" section they list a bunch of Chipset support options, I found mine "VIA82CXXX chipset support" and selected to build it in the kernel - not as a module (as suggested by other forums).

Then cross your fingers, tap the heels of your shoes together and compile, install the kernel and reboot.

After the reboot try to enable hard disk DMA with hdparm again.

hope it helps.
ehrhardt
 
Old 04-12-2006, 09:31 PM   #6
WaaX
LQ Newbie
 
Registered: Apr 2006
Posts: 1

Rep: Reputation: 0
Thanks, i was doing 4mb/s, now with the proper IDE driver built-in the kernel my hd is going ~50mb/s.

What a difference.
 
Old 05-19-2007, 11:43 AM   #7
jashar
LQ Newbie
 
Registered: May 2007
Posts: 5

Rep: Reputation: 0
initrd

In case anyone reading this thread still can't get it to work (like me) you can try editing /etc/mkinitrd/modules to load your motherboard's module, since your system may be like mine and loads the modules in initrd first, and once the ide_generic module is loaded, it's too late to do anything with insmod or modprobe or /etc/modules.

 
Old 07-21-2007, 03:49 AM   #8
shazam75
Member
 
Registered: Oct 2004
Location: Australia, Brisbane
Distribution: Gentoo
Posts: 296

Rep: Reputation: 30
hey

thanks for the heads up on the kernel part - didnt have it enabled -

Regards
Shelton
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDIO_SET_DMA failed: Operation not permitted new.thing Slackware 21 09-15-2007 05:46 PM
how to add "hdparm -c 1 -d 1 -k 1 /dev/hda" to startup script (as root)? jimothy05 Linux - Distributions 2 10-07-2004 07:32 AM
HDIO_SET_DMA failed: Operation not permitted kernel 2.6.4 Gaghiel Slackware 4 03-31-2004 06:18 PM
HDIO_SET_DMA failed: Operation not permitted acjt Linux - Hardware 4 05-02-2003 10:52 PM
HDIO_SET_DMA failed: Operation not permitted markus1982 Linux - General 2 10-28-2002 04:56 AM


All times are GMT -5. The time now is 08:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration