LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-25-2006, 04:17 PM   #1
tleibel
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
AC 97 Sound Card problem


Hey i'm a noob to linux and installing suse 10.1 for the first time. I've gotten most media to work including mp3's however although the mp3 plays fine i am not getting any sound out of the speakers. I've checked my BIOS and all volume controls.

Is there anything else I should be looking for, and any suggestions.

Thanks
 
Old 11-26-2006, 07:26 AM   #2
Spherical
LQ Newbie
 
Registered: Nov 2006
Location: Dutchyland
Distribution: Gentoo 2.6.18 custombuild
Posts: 29

Rep: Reputation: 15
What media player are you using? make sure you've selected the correct engine output for playing
 
Old 11-26-2006, 01:13 PM   #3
Cara25
Member
 
Registered: Mar 2006
Location: Nashville, Tennessee
Distribution: Salix 13.37 with KDE
Posts: 257

Rep: Reputation: 36
I had sound problems when I first started Mandriva Linux on my Compaq machine. It has an AC '97 embedded chip for sound.
For starters
1. Go to all the sound GUI apps in susie and make sure the volume is turned up to max on all controls.
2. Make sure none of the controls are muted, the little "light" on/off radio buttons are sometimes confusing to whether they're on or off.
3.Check on board sounds and see if you get a sound at "startup and shutdown"
4. Check headphone and see if you get sound through a CD player.
5. Make sure outboard speakers are powered up if using USB powered speakers, if not shutdown the PC and try another USB and restart the machine.
6.And my final suggestion, one that you will appreciated if you get it working because of the great quality of the sound is, load all the ALSA sound controls packages available to susie. Run the ALSA configuration file from the command line. Go back and make sure all your sound apps are using ALSA if given the choice.
7. Go to a forum specically for susie and ask questions and then go to http://www.alsa-project.org/ for answers to specific ALSA questions.
Hope this helps, try the ALSA if at all possible, it's fantastic !
Scott Nash
 
Old 12-01-2006, 08:02 PM   #4
horusfalcon
LQ Newbie
 
Registered: Nov 2006
Distribution: PCLinuxOS 2007
Posts: 11

Rep: Reputation: 0
Um, Some Simple Steps First...

Quote:
Originally Posted by tleibel
Hey i'm a noob to linux and installing suse 10.1 for the first time. I've gotten most media to work including mp3's however although the mp3 plays fine i am not getting any sound out of the speakers. I've checked my BIOS and all volume controls.

Is there anything else I should be looking for, and any suggestions.

Thanks
First, turn your speaker volume control down to a safe level so you don't get your ears blasted off.

If you are able to run KDE, open KMix and go to the "Switches" tab. Check and see if the "External Amplifier" switch is toggled on. If so, toggle it off. You might also check the "Line Input Sense" and "Headphone Jack Sense" switches. Some AC97 cards are weird in how they implement some of the features... they swap the headphone and speaker jacks or the speaker and line jacks.

Good hunting.

Later ON,
Dave
 
  


Reply

Tags
audio, multimedia, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
same old problem of nic card and sound card detection in 10.2 brgurung Slackware 8 03-29-2007 03:40 AM
Other problem with the sound in Mandrake - onboard sound card Swetko Linux - Hardware 24 06-19-2006 03:27 PM
Sound problem with intel8x0 sound card. ivopz Linux - Hardware 2 03-28-2005 05:01 AM
Tv card + Sound Card = Audio Problem? kak Slackware 2 01-02-2005 01:18 AM
Sound card and Graphics card problem abcdef3 Linux - Software 2 07-31-2001 04:20 AM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration