LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 06-22-2003, 12:02 PM   #1
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
Using Talk


Hey everyone,

Right now I'm trying to use TALK to chat with a user on my system. From reading forums and doing google, the TALK command seems very easy to use but I seem to always run into trouble. I would type:

"talk blahblah@localhost" and it would spit out:

Error on read from talk daemon: Connection refused. Press any key....
[Checking for invitation on caller's machine]

Am I not setting something up? I went under /etc/xinetd.d and editted the talk file from "disable=yes" to "disable=no" and restarted the xine service but that still didn't solve my problem.

Any suggestions? Thanx for any help!

-twantrd
 
Old 06-22-2003, 12:03 PM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Original Poster
Rep: Reputation: 52
Oh sorrie, I forgot to mention that I have redhat 7.3

-twantrd
 
Old 06-22-2003, 12:57 PM   #3
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
You mean you restarted the xinetd daemon right? Not xine.
 
Old 06-22-2003, 03:39 PM   #4
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Original Poster
Rep: Reputation: 52
Yea I restarted the xine daemon...

when i type in "talk <username>"

it says "unknown host"

So i'm assuming talkd does not recognize my hostname. Anyway to fix this? Thanx for any help...

-twantrd
 
Old 08-28-2003, 05:21 PM   #5
SlickWilly
Member
 
Registered: Dec 2002
Posts: 327

Rep: Reputation: 30
Not entirely sure what xine is... But you need to be restarting your xinetd..

Anyway, your problem is that you've only half enabled talk. You also need to edit your /etc/xinetd.d/ntalk file, and enable that aswell.

If you don't have an ntalk file you need to install the talkd daemon - probably listed as 'talk server'.

The reason you're getting the 'connection refused' is that when you 'talk' - it contacts a 'connection manager' which recieves your request and passes it onto the other user. The other user can then accept or reject your request, and it's all handled by talkd.

If you don't have talkd : disabled=no, then your talk request (talk <username>) ends up trying to contact a service that isn't running and your 'connection is refused'.

So :

1) edit /etc/xinetd.d/ntalk - disabled =no
2) service xinetd restart
3) talk <mybuddy>



Slick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Talk Joe2003 Linux - Newbie 3 10-18-2005 03:39 PM
talk talk daemon configuration ananthkrk Red Hat 1 10-16-2004 11:45 AM
talk mairul Linux - Newbie 7 10-09-2003 12:28 PM
Talk me through how to do this. Tayste_2000 Linux - Newbie 7 07-06-2002 12:52 PM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 02:04 AM


All times are GMT -5. The time now is 01:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration