LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-04-2003, 11:04 PM   #1
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Rep: Reputation: 15
talk


I have changed the /etc/xinet.d/talk file and write disable=no

But cannot establish talk connection between tty and pts/1

error on reading from talk daemon...connection refused...

please help.
 
Old 10-06-2003, 12:05 AM   #2
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

chkconfig --list | grep talk should list talk as on

else

chkconfig talk on would enable it

iptables -L should list firewall rules. make sure you are not blocking it

regards
rahul sundaram
 
Old 10-06-2003, 04:16 AM   #3
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
Boss...it is not working....can you help me more....

iptables -L shows a long list...I am newbiew....pls help...
 
Old 10-06-2003, 12:38 PM   #4
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

517/udp is the port used to connect to talk. if its not explicitly disabled i need you to post the iptables rules. if its redhat it will be in /etc/sysconfig/iptables

nmap localhost

will tell you which ports are open. hope that helps

regards
rahul sundaram
 
Old 10-08-2003, 06:14 AM   #5
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
My host name is pc2 and IP is 192.168.0.2

when i give nmap pc2 command it shows....

[root@pc2 /]$ nmap pc2

Starting nmap V. 2.54BETA31 ( www.insecure.org/nmap/ )
Warning: You are not root -- using TCP pingscan rather than ICMP
Interesting ports on pc2 (192.168.0.2):
(The 1549 ports scanned but not shown below are in state: closed)
Port State Service
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
111/tcp open sunrpc
1024/tcp open kdm
 
Old 10-08-2003, 02:39 PM   #6
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi
it looks like talk is disabled. run this

chkconfig talk on

chkconfig --list | grep 5n should list talk as on.

iptables -F would flush the iptables rules

then try it from another system

regards
rahul sundaram
 
Old 10-09-2003, 08:10 AM   #7
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
Thanks Mr. Rahul Sundaram...

Actually I edit the /etc/xinetd.d/ntalk file and then write disable=no.....then it is working...

But another problem...how can I accept talk request...

when I am giving talk request it says.....

[rony@pc2 /]$

Message from Talk_Daemon@pc2.com at 18:15 ...
talk: connection requested by root@pc2.
talk: respond with: talk root@pc2

i think I have to press any key at keyboard to accept talk request...

can you help me again pls...

 
Old 10-09-2003, 01:28 PM   #8
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

the user at the other end has to respond to your request with talk username

read

man talk

or in konqueror

man:/talk or #talk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Talk Joe2003 Linux - Newbie 3 10-18-2005 04:39 PM
talk talk daemon configuration ananthkrk Red Hat 1 10-16-2004 12:45 PM
Using Talk twantrd Linux - General 4 08-28-2003 06:21 PM
Talk me through how to do this. Tayste_2000 Linux - Newbie 7 07-06-2002 01:52 PM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 03:04 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration