LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices

Reply
 
Search this Thread
Old 02-28-2004, 01:52 PM   #1
orktes
LQ Newbie
 
Registered: Feb 2004
Posts: 6

Rep: Reputation: 0
Problem with UT2004demo... Couldn't initialize SDL...


I tried to run ut2004 but it gave me an error "Couldn't initialize SDL: No available video device"
How can i fix this?

System:
Knoppix 3.3
AMD Athlon xp 2000+
nVIDIA GeForce 420mx

Last edited by orktes; 02-28-2004 at 02:07 PM.
 
Old 02-28-2004, 02:55 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
please don't double post........thx

all ya gotta do is install .........SDL(simple directmedia layer).........
 
Old 02-28-2004, 02:59 PM   #3
orktes
LQ Newbie
 
Registered: Feb 2004
Posts: 6

Original Poster
Rep: Reputation: 0
root@Jaakon-boxi:/home/Jaakko# apt-get install libsdl1.2debian
Reading Package Lists... Done
Building Dependency Tree... Done
libsdl1.2debian is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 66 not upgraded.


It says that i already have the newest one

Last edited by orktes; 02-28-2004 at 03:02 PM.
 
Old 08-09-2005, 12:37 PM   #4
HellSpawn
Member
 
Registered: Jan 2005
Location: Venezuela
Distribution: Ubuntu 5.10 64bits
Posts: 81

Rep: Reputation: 15
This worked for me

apt-get install libsdl-gfx1.2

and this for alsa sound, but I still get /dev/[sound]dsp Device busy sometimes

apt-get install libsdl1.2debian-alsa
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to program an SDL application but cannot find the SDL.h file:SuSE 9.2&KDevelop pujolasdf Linux - Newbie 4 03-13-2005 07:50 AM
HELP! Couldn't initialize SDL: No available video device orktes Linux - Software 6 03-24-2004 02:04 PM
ut2004demo AlteZza2k2 Linux - Games 1 03-22-2004 04:19 PM
error message: Couldn't initialize SDL: Found no sufficiently capable X11 visuals JimBass Linux - Software 2 03-05-2004 07:50 AM
SDL: Could not initialize video zot Linux - Hardware 0 06-24-2003 09:05 AM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration