LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 01-06-2006, 01:05 AM   #1
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Rep: Reputation: 15
No core keyboard


I got XOrg to install, but now I have a different problem.

Well, I get an error saying it can't find keyboard drivers when I run X -config /root/xorg.conf.new I edited the file to have the drivers be named 'kbd' 'KBD' and 'keyboard' but it still can't find it. Any ideas?
 
Old 01-06-2006, 07:43 PM   #2
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
can you post the exact error? This will be helpful.
 
Old 01-06-2006, 09:27 PM   #3
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
here is the last part of the log file. The screen goes black, then it returns to the console saying...

Quote:
...

(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
No core keyboard

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
 
Old 01-07-2006, 12:54 AM   #4
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
You need to put an option in your xorg.conf. My keyboard section looks like this
Code:
Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
the part you're going to want to add is
Code:
Option "CoreKeyboard"
 
Old 01-07-2006, 11:33 AM   #5
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
Nope didn't work. Whats happenng is it can't find the Driver, what ever is in the driver option it doesn't like. I looked through /dev/ directory and no keyboard at all. So no matter if I put Driver "kbd" or driver "keyboard" it can't find it. Even when I do X -configure or whatever to create a default config, it can't find the keyboard. I know the keybaord is pluged in an works becuase I can type commands and edit the config file :P
 
Old 01-08-2006, 12:18 AM   #6
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
Sorry for double posting but I really need help. I forgot to put this in my post of the log.

Quote:
(EE) No Input driver matching `keyboard'
That is right befor it looks for the mouse. I hope with helps, I really want to get this working. I am using a very standard keybaord, nothing fancy. If nothing gets this working, should I try XFree86?
 
Old 02-02-2006, 02:12 PM   #7
Cat-in-hat
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
Question

I am having the same problem on FreeBSD 6.0. Did you finally resolved this issue? Could you please post your fix here.I followed all the steps mentioned in this thread but same problem on starting the startx

(EE) Failed to load module "Keyboard" (module does not exist, 0)
(EE) No Input driver matching 'Keyboard'
No core keyboard.

Fatal server error:
failed to initialize core devices.


Somebody plzzzz help !!!
 
Old 02-02-2006, 05:02 PM   #8
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
My problem was I didn't use the right .h file that you need to make. I used one from xfree...when I needed to use xorg
 
Old 03-11-2006, 10:46 AM   #9
Andrew Indrawn
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
Try change
Driver "Keyboard"
To
Driver "keyboard"

The first letter is small "k". It helps me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 4: Wierd problem with keyboard mappings yalavarthy Fedora 1 08-12-2005 08:28 AM
ATI 9200 Problem No core keyboard aeruzcar Linux - Hardware 1 05-13-2005 02:34 AM
Fedora Core 3 and latvian keyboard jato Fedora 0 12-14-2004 03:45 AM
Keyboard and Mouse reverse and don't function after Core 2 install...HELP! motionstorm Fedora 0 04-25-2004 05:37 AM
After installation of Fedora Core I and reboot mouse and keyboard will not work wheckel Fedora 3 03-03-2004 10:54 AM


All times are GMT -5. The time now is 12:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration