LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   No core keyboard (http://www.linuxquestions.org/questions/linux-from-scratch-13/no-core-keyboard-400105/)

Cirdan 01-06-2006 01:05 AM

No core keyboard
 
I got XOrg to install, but now I have a different problem.

Well, I get an error saying it can't find keyboard drivers when I run X -config /root/xorg.conf.new I edited the file to have the drivers be named 'kbd' 'KBD' and 'keyboard' but it still can't find it. Any ideas?

microsoft/linux 01-06-2006 07:43 PM

can you post the exact error? This will be helpful.

Cirdan 01-06-2006 09:27 PM

here is the last part of the log file. The screen goes black, then it returns to the console saying...

Quote:

...

(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
No core keyboard

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

microsoft/linux 01-07-2006 12:54 AM

You need to put an option in your xorg.conf. My keyboard section looks like this
Code:

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"    "us"

the part you're going to want to add is
Code:

Option "CoreKeyboard"

Cirdan 01-07-2006 11:33 AM

Nope didn't work. Whats happenng is it can't find the Driver, what ever is in the driver option it doesn't like. I looked through /dev/ directory and no keyboard at all. So no matter if I put Driver "kbd" or driver "keyboard" it can't find it. Even when I do X -configure or whatever to create a default config, it can't find the keyboard. I know the keybaord is pluged in an works becuase I can type commands and edit the config file :P

Cirdan 01-08-2006 12:18 AM

Sorry for double posting but I really need help. I forgot to put this in my post of the log.

Quote:

(EE) No Input driver matching `keyboard'
That is right befor it looks for the mouse. I hope with helps, I really want to get this working. I am using a very standard keybaord, nothing fancy. If nothing gets this working, should I try XFree86?

Cat-in-hat 02-02-2006 02:12 PM

I am having the same problem on FreeBSD 6.0. Did you finally resolved this issue? Could you please post your fix here.I followed all the steps mentioned in this thread but same problem on starting the startx

(EE) Failed to load module "Keyboard" (module does not exist, 0)
(EE) No Input driver matching 'Keyboard'
No core keyboard.

Fatal server error:
failed to initialize core devices.


Somebody plzzzz help !!!

Cirdan 02-02-2006 05:02 PM

My problem was I didn't use the right .h file that you need to make. I used one from xfree...when I needed to use xorg

Andrew Indrawn 03-11-2006 10:46 AM

Try change
Driver "Keyboard"
To
Driver "keyboard"

The first letter is small "k". It helps me :)


All times are GMT -5. The time now is 11:39 PM.