LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 04-05-2011, 09:32 AM   #1
illusionoflife
LQ Newbie
 
Registered: Apr 2011
Location: Russia, Moscow
Distribution: Debian, working on LFS
Posts: 14

Rep: Reputation: 0
Locale trouble.


Hi,
i have some problems with my new LFS-6.8.
With the following variables
LANG=ru
LC_ALL=ru_RU.UTF-8
FONT=UniCyr_8x16
CHARSET=ru4
UNICODE=1
i get well-written russian system messages(like "комманда не найдена"), but when i type russian text myself i get incorrect characters(like "?"). What did i forgot to do and say? Also, altho it may be related, in lynx i get russian cites translited. Any suggestions?
 
Old 04-05-2011, 12:16 PM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

Have you checked your content of: /etc/sysconfig/console and /etc/profile. No typo's or other mistakes?

Also: UTF-8 isn't well supported (BLFS - Locale Related Issues).

Hope this helps.

EDIT:

I found this, not mentioned in the later versions but it might help:

LFS 6.3 - Configuring the Linux Console (Bottom of the page, last console example).

Last edited by druuna; 04-05-2011 at 12:19 PM.
 
Old 04-05-2011, 01:49 PM   #3
illusionoflife
LQ Newbie
 
Registered: Apr 2011
Location: Russia, Moscow
Distribution: Debian, working on LFS
Posts: 14

Original Poster
Rep: Reputation: 0
Hi,
I tried a lot of combinations of LC_ALL KEYMAP and FONT variables values.
Configuration you pointed i tried also with different LC_ALL. No effect.
Will try to find out what variables are set on other comp's Debian.Any more ideas to try?
EDIT:
Combination found:
UNICODE=1
KEYMAP=ruwin_alt-UTF-8
LANG=ru
LC_ALL=ru_RU.UTF-8
Switches with right ALT.
Lynx still translite. No idea. Configured with nls.

Last edited by illusionoflife; 04-05-2011 at 02:46 PM. Reason: Solution found!
 
Old 04-05-2011, 03:27 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

Good to read you got the main problem fixed.

About lynx: did you check the Options Menu (start lynx, press o (not zero, the letter) to see if the settings are correct? Display character set is the first that came to mind....

Also look at:
- Preferred document language
-Preferred document character set

Hope this helps.
 
Old 04-17-2011, 11:29 AM   #5
illusionoflife
LQ Newbie
 
Registered: Apr 2011
Location: Russia, Moscow
Distribution: Debian, working on LFS
Posts: 14

Original Poster
Rep: Reputation: 0
Was easy, just set display set as UTF-8.
Also, its seems best to set FONT=LatArCyrHeb-14. This font looks best for me with ncurses application, like mcabber. Thanks a lot.
 
Old 04-17-2011, 11:41 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
You're welcome
 
  


Reply

Tags
lang, lfs, locale


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
after-Installation errors. locale error. unsupported locale settings and two more gh0st Fedora 1 05-02-2008 05:06 AM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 03-31-2006 11:38 PM
trouble grokking LOCALE stabu Linux - Newbie 1 05-04-2004 01:02 PM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration